Forum

Page 1 of 4 123 ... LastLast
Results 1 to 15 of 48
  1. #1
    Join Date
    July 2009
    Location
    Germany
    Posts
    6

    Global Hotkeys not working

    Hey guys,

    just installed TS3 Beta 2 on my MacBook (OSX 10.6.2) and noticed that my hotkeys:
    OPTION + V = Toggle Microphone
    OPTION + B = Toggle Speaker
    only work if I have TS3 in front (activated). So if I have another application in front such as Safari, iTunes or even Finder my hotkeys aren't working.
    I already tested another modifying key like COMMAND but the problem still persists.

    Thanks in advance - Horst33

  2. #2
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    For global hotkeys, you need to enable a setting in the Mac system preferences.

    - Open System Preferences
    - Universal Access
    - "Enable access for assistive devices" (on bottom)

    This is for Mac OS X 10.5.8, I don't know if it's still named the same on 10.6.

    Edit for 10.9.x
    - Open System preferences
    - Security & Privacy
    - Privacy tab
    - Accessibility
    - Enable Teamspeak 3 Client
    Edit end

    The reason for this is, on Mac by default you cannot catch keypresses from one application if another application has the focus for security reasons as a protection mechanism against malware trying to log keyboard input. In order to catch TeamSpeak 3 hotkeys when another application is running, this option must be explicitly enabled, otherwise OS X would not pass the keypresses to TS3.

    Admittedly, this should have been in the FAQ.
    Last edited by dante696; October 21st, 2016 at 12:02 PM.

  3. #3
    Join Date
    January 2009
    Location
    Kamloops BC Canada
    Posts
    9
    Yeah this probably didn't come up in alpha because I also run vent and mumble on my Mac, which requires this change in the system prefs for them to pick up the key presses as well.

    Mike

  4. #4
    Join Date
    July 2009
    Location
    Germany
    Posts
    6
    Thanks a lot PeterS - now it works. I tested it successfully with every modifier-key (shift; ctrl; alt; cmd) having Finder or Safari in front.

    A tiny problem for me was to find "Universal Access" in System Preferences in my German version of OS X - there it is called "Bedienungshilfen".
    Last edited by dante696; October 18th, 2013 at 11:54 AM.

  5. #5
    Join Date
    October 2004
    Location
    Germany
    Posts
    129
    You have to do this on Snow Leopard too... There has to be a hint in the Hotkeydialog like we sayed before Peter.

  6. #6
    Join Date
    December 2009
    Location
    Berlin, Germany
    Posts
    2
    Just for your info:

    After "Enable access for assistive devices" / "Zugriff für Hilfsgeräte aktivieren" it works under Tiger (4.11) too.

    Cu

    TuxB12

  7. #7
    Join Date
    December 2009
    Location
    foo
    Posts
    7
    Side note: With TeamSpeex, the inofficial TS2 client for Mac, Hotkeys used to work without "Enable access for assistive devices". I don't know why, but one might take a look at their source code ;-)

  8. #8
    Join Date
    August 2010
    Location
    ohio usa
    Posts
    2

    Universal Access Selected Still Cannot Change Mute Keys

    15" macbook pro 2.4 ghz core duo 2gb mem os x 10.6.4
    cannot change hotkeys for muting mic and sound!
    assistive devices always has been selected!
    please help me have checked library for applic support no file there
    how do i change these keys have done setup wizard does not work
    have uninstalled reinstalled does not work
    please help guys

  9. #9
    Join Date
    August 2012
    Posts
    3

    Push-to-talk doesn't work outside the actual TeamSpeak Client

    Hello,
    This is the first time I've experienced this problem.
    The PTT button (v in my cas) work perfectly when I am "focused" on the TS client. So whenever I'm browsing, playing or working, using TS with PTT doesn't work. It doesn't seem to have anything to do with the client version since I've taken my broher's version (older one) and put it on my computer. It didn't work ; so it must have something to do with the computer itself. I used SoundFlower that day on TeamSpeak (it made it crash). I don't know if the problem happend after that or not.
    Thanks in advance

    This thread was merged.
    Last edited by dante696; September 6th, 2012 at 10:47 AM.

  10. #10
    Join Date
    July 2006
    Posts
    1,600
    In general: always use the newest version!
    For your problem: try running as administrator.

  11. #11
    Join Date
    August 2012
    Posts
    3
    I am administrator. Tried with Pseudo too, but didn't work. AGAIN I always use the latest version. I just tested with an older one to see

  12. #12
    Join Date
    September 2012
    Posts
    1
    I can confirm the phenomena reported by Wolfunov.
    The same is happen with my MAC (OS X 10.7.4).
    If the TS Window is in the back, Push to Talk is not working.

  13. #13
    Join Date
    September 2012
    Posts
    6,044
    This is due to security settings in Mac OSX which does not forward keypresses to the TeamSpeak 3 Client and is already explained in both stickies in this forum.

  14. #14
    Join Date
    August 2012
    Posts
    3
    Resetting Permissions seem to have resolved the problem

  15. #15
    Join Date
    November 2012
    Posts
    1

    Hotkey does no longer work outside TS application.

    Recently my hotkey has stopped working if I don't have teamspeak as the active application.
    Once i switch over to teamspeak it works perfectly.

    I have read the stickies about this, i have enable access for assistive devices enabled, it actually worked a few weeks ago. I'm totally out of idea's now, any help would be appreciated.

    This thread was merged
    Last edited by dante696; November 28th, 2012 at 08:13 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Teamspeak 3 disables my media player's global hotkeys?
    By chaosglory in forum Windows
    Replies: 0
    Last Post: April 19th, 2015, 02:41 PM
  2. [Resolved] Hotkeys not working
    By Jolle in forum General Questions
    Replies: 20
    Last Post: May 29th, 2014, 02:17 PM
  3. Hotkeys not working?
    By DanTheHumann in forum General Questions
    Replies: 0
    Last Post: December 14th, 2013, 07:10 PM
  4. None of my hotkeys are working...
    By McJamesV in forum Windows
    Replies: 3
    Last Post: February 27th, 2012, 11:14 AM
  5. Replies: 0
    Last Post: September 8th, 2010, 05:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •