Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 11 of 11
  1. #1
    Join Date
    August 2008
    Location
    German
    Posts
    77

    Teamspeak 3 and connecting with MySQL

    Hello,

    I've been trying the whole time TS3 server with my MyAQL vebinden too. Unfortunately, this does not work, it only appears when you start the following:

    [code]2009-12-21 09:45:13.131005|INFO |ServerLibPriv | | Server Version: 3.0.0-beta2 [Build: 9398]
    2009-12-21 09:45:13.134311|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-21 09:45:13.134519|INFO |DatabaseQuery | | dbPlugin version: 1
    2009-12-21 09:45:13.151091|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)
    2009-12-21 09:45:13.151226|CRITICAL|ServerLibPriv | | Server() DatabaseError[/ code]

    But when I connect via console () with the following command:

    [code]mysql --host=localhost --port=3306 --user=teamspeak --password=x5gUjs ts3db[/ code]

    Will I be connected to MySQL. Can one help me, where is the problem?

    Sorry for my English, but I can not do it so well and let everything translate with google.

    Greeting
    RavLau

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    1
    Quote Originally Posted by RavLau View Post
    mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)
    This message tells you that the Server trys to connect with the user root und no password.

  3. #3
    Join Date
    December 2007
    Location
    Austria,Linz
    Posts
    214
    You should delet your mysql password for the user teamspeak....

    try with a file!
    (i) MySQL plugin

    To make your TeamSpeak 3 Server use a MySQL database you need to make sure that the
    "ts3db_mysql" library is located in your servers installation directory. Per default,
    the plugin is using the following parameters:

    * host (127.0.0.1)
    The hostname or IP addresss of your MySQL server.

    * port (3306)
    The TCP port of your MySQL server.

    * username (root)
    The username used to authenticate with your MySQL server.

    * password (<empty>)
    The password used to authenticate with your MySQL server.

    * database (test)
    The name of a database on your MySQL server. Note that this database must be created
    before the TeamSpeak 3 Server is started.

    * socket (<empty>)
    The name of the Unix socket file to use, for connections made via a named pipe to a
    local server.

    All parameters can be customized by creating a INI-style configuration file called
    "ts3db_mysql.ini". For example:

    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=x5gUjs
    database=ts3db
    socket=

    The path and filename of the configuration file can be set using the "dbpluginparameter"
    commandline parameter.

    To start the TeamSpeak 3 Server with MySQL support, you need to specify the "dbplugin"
    commandline parameter. You may also need to specify the "dbsqlcreatepath" parameter if
    you're starting the server instance for the first time since the syntax of the MySQL
    installation files differs from SQLite3.

    Example:
    $ ./ts3server_linux_amd64 dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql/

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    Hi,

    I have the same Problem i setup this file but it ignores it and try to connect as root.

    My ts3db_mysql.ini contains this and is stored in the maindir from the teamspeakserver.
    Code:
    [config]
    host=localhost
    port=3306
    username=teamspeak3
    password=mypassword
    database=teamspeak3
    socket=
    output from console
    Code:
     ./ts3server_linux_amd64 inifile=ts3db_mysql.ini dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql/
    Logging started
    2009-12-22 09:41:30.945098|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta3 [Build: 9419]
    2009-12-22 09:41:30.948474|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-22 09:41:30.948557|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2009-12-22 09:41:30.953494|ERROR   |DatabaseQuery |   | mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)
    Speicherzugriffsfehler
    Whats the Problem ? Why dont use my configfile?

    Greetings

    BlackScript

  5. #5
    Join Date
    August 2008
    Location
    German
    Posts
    77
    Quote Originally Posted by GrexAut View Post
    You should delet your mysql password for the user teamspeak....

    try with a file!
    I have addressed myself to the example where the bottom was ...

    Code:
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=x5gUjs
    database=ts3db
    socket=
    So I will use the database without a password?

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    2
    I've the same problem!

    It keeps ignoring the Username & Password for the mysql connection.
    No matter if I use the config file or the commandline params.

  7. #7
    Join Date
    June 2009
    Location
    Wuppertal
    Posts
    46
    Code:
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=x5gUjs
    database=ts3db
    socket=
    that is a buggy file
    Code:
    [config]
    host=localhost
    username=teamspeak
    password=x5gUjs
    database=ts3db
    blankline
    that the correkt

  8. #8
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    Quote Originally Posted by Prismatech View Post
    Code:
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=x5gUjs
    database=ts3db
    socket=
    that is a buggy file
    Code:
    [config]
    host=localhost
    username=teamspeak
    password=x5gUjs
    database=ts3db
    blankline
    that the correkt
    doesn't work.........
    no other ideas ?

  9. #9
    Join Date
    March 2005
    Location
    Germany
    Posts
    50
    Quote Originally Posted by BlackScript View Post
    doesn't work.........
    no other ideas ?

    must work ..

    and you must give a Empty Line into it ..

    tested and its working to me with this solution since beta 5 (thats where i tested it)

    in german:
    blankline = leere zeile.. dies komischerweise ganz wichtig

  10. #10
    Join Date
    August 2008
    Location
    German
    Posts
    77
    DELETED...
    I get the problem solved itself.
    Last edited by RavLau; December 30th, 2009 at 03:49 PM.

  11. #11
    Join Date
    June 2010
    Location
    UK
    Posts
    3
    Since this thread is the first place you land on when searching for the error on Google...

    This problem is caused on Windows by not escaping the backslashes on the dbpluginparameter parameter, i.e. you need something like:

    dbpluginparameter=C:\\Path\\ts3db_mysql.ini

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'
    By Svenskunganka in forum Server Support
    Replies: 2
    Last Post: September 12th, 2013, 10:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •