Forum

Results 1 to 13 of 13
  1. #1
    Join Date
    December 2009
    Location
    Belgium
    Posts
    18

    since the pulseaudio topic is closed... [Co carrier]

    the last person posted this in the topic:
    so please be patient (or try to disable your pulse audio) for a while.
    Well i tried to disable pulseaudio (removing pulseaudio binaries / reconfiguring alsa) the same problem popped up, (Teamspeak using up 100%CPU).

    the previous client version (ts2) diden't work on any linux install as well so i used the windows version in combination with wine from http://www.winehq.org/ everything on the client worked (atleast better than on the linux version, with exceptions of some graphical glitches and push to talk outside the wine environment). to my surprise the Windows version of teamspeak 3 works on linux perfectly (except the problem with "Push to talk" again), so i guess as a temporary solution linux users could use the windows binaries since those got tested and are confirmed working.

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    i use "padsp" as a loader for Teamspeak3 for using with Pulseaudio. I've had no problems until now, so you can test it. Maybe it will help you.

    so you change to your client-folder and use "padsp ./ts3client_linux_x86" if you use a 32bit Linux, else you have to change the name of the client-binary in this command.

  3. #3
    Join Date
    December 2009
    Location
    Belgium
    Posts
    18
    Quote Originally Posted by Master_D View Post
    i use "padsp" as a loader for Teamspeak3 for using with Pulseaudio. I've had no problems until now, so you can test it. Maybe it will help you.

    so you change to your client-folder and use "padsp ./ts3client_linux_x86" if you use a 32bit Linux, else you have to change the name of the client-binary in this command.
    Yes ive tried that, on both TS2 and TS3 this won't solve the problem. (i have audio and it works flawless, but it uses 2x100 CPU on my computer.) but no diff between using padsp and just pulseaudio.

    the only problems i had on linux with some was involving teamspeak and the old version of the Java plugin for the browser.

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    ok, i've tested it another time, to see the CPU-usage.

    With padsp both of my cores using about 40% of their maximum, maybe it is a configuration-problem in pulseaudio.

    can you test it on another linux-system, to find out, if it is only on your special system?

  5. #5
    Join Date
    December 2009
    Location
    Belgium
    Posts
    18
    Quote Originally Posted by Master_D View Post
    ok, i've tested it another time, to see the CPU-usage.

    With padsp both of my cores using about 40% of their maximum, maybe it is a configuration-problem in pulseaudio.

    can you test it on another linux-system, to find out, if it is only on your special system?
    Nothing is very special about my system. Ubuntu 9.10 default installation, updated all the way from 6.04. Pulseaudio is pretty default on ubuntu / debian / Fedora. and those are the most used Distrobutions. i don't think its good practice that my system needs to change just to run something, i can understand dependencies but 'conflicts' are bad practice.

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    I've tested it once more for a longer time, and now it would use also 100% of both cores. Maybe it is fixed in Beta5. Time to test

  7. #7
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    no, no fmod uptate yet

  8. #8
    Join Date
    March 2006
    Location
    Berlin, Germany
    Posts
    11
    yesterday one alsa sound Update on Ubuntu Updater ... but no issue Fix ... just try another sound device

  9. #9
    Join Date
    December 2009
    Location
    Europe
    Posts
    3
    Same Problem with beta5 ... would be nice to reopen the origin thread

  10. #10
    Join Date
    December 2009
    Location
    Poland / Wrocław (Breslau)
    Posts
    15
    Did anyone report this bug to the Fmod community? Are they aware of this problem?

  11. #11
    Join Date
    December 2009
    Location
    Germany
    Posts
    6
    I posted this in another thread. This way I've been able to easily get rid of Pulseaudio on Karmic:

    Unfortunately the approach of disabling Pulseaudio has some - if you're lucky only minor - adverse effects. For example the audio applet will stop working (you'll have to adjust your audio settings using alsamixer in a terminal), the sound settings won't open any more and additional applications, which rely on pulseaudio being present, might just stop working as expected or completely.

    Disabling Pulseaudio in Ubuntu 9.10 is pretty straighforward:
    Code:
    echo "autospawn = no" > ~/.pulse/client.conf
    pulseaudio -k
    If you want to reenable it:
    Code:
    rm ~/.pulse/client.conf
    pulseaudio -D
    Make sure you're not overwriting any settings you might have made to your user's PA client.conf, using the commands above. I rely on it being empty/non-existent, which it should be on a vanilla karmic.

  12. #12
    Join Date
    December 2009
    Location
    Germany
    Posts
    9
    As i wrote in the other thread:
    It makes no sense to disable PA if you want to use Apps that rely on it. This has to be fixed where the problem is and not at the symptoms!

  13. #13
    Join Date
    December 2009
    Location
    Belgium
    Posts
    18
    Quote Originally Posted by roul04 View Post
    As i wrote in the other thread:
    It makes no sense to disable PA if you want to use Apps that rely on it. This has to be fixed where the problem is and not at the symptoms!
    Fedora, Ubuntu, Mandriva, Linux Mint, and openSUSE use PA (i thin since Debian Squeeze as well) but not for KDE installs.

    what distro did the Devs test it on?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems using Pulseaudio
    By anony in forum Linux
    Replies: 0
    Last Post: November 1st, 2014, 09:48 PM
  2. PulseAudio and my Interface/Microphone
    By SmallTock in forum Linux
    Replies: 1
    Last Post: May 31st, 2014, 09:41 AM
  3. more issues with pulseaudio
    By FaykFox in forum Linux
    Replies: 7
    Last Post: May 12th, 2011, 06:45 PM
  4. Pulseaudio Update, no CPU Bug for me
    By Stephan13360 in forum Linux
    Replies: 3
    Last Post: January 28th, 2010, 01:05 PM
  5. Replies: 20
    Last Post: December 21st, 2009, 12:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •