Forum

Results 1 to 5 of 5

Thread: Anti-Spam Bug?

  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    57

    Question Anti-Spam / Anti-Flood Bug?

    Hey there,
    im not quite sure if it is a bug i had yesterday on my ts3 server.
    I wanted to block some channels to users with insufficient "channel join power" so i edited the "needed channel join power" for each channel and let a friend of mine test it. Well he was not able to move to the channels, fine so far. The problem now is that he tried "desperatly" ^^ to get into the channel -> he "spammed" it although he was not able to join.

    The result was that he got banned from the server due to spamming, fine. But after i deleted his ban he was instantly banned again in the moment he connected to the server, even deleting the "needed join power" and the channels could not help unless i gave him server admin rights.

    Only a restart of the entire TS3 Server could solve the problem, as he could not connect any longer being a normal user.

    Is this a wanted feature or is it a bug?
    Last edited by Phil7789; December 22nd, 2009 at 12:55 PM.

  2. #2
    Join Date
    September 2007
    Location
    Austria
    Posts
    16
    I had the same problem testing the anti-spam function.

    Once we were at 300 seconds this ended in an indefinite loop.
    At every login the 300 secs were renewed no matter if they had already passed or not.
    Deleting the IP from the ban list through the client did not seem to have any effect.

  3. #3
    Join Date
    December 2009
    Location
    Norway
    Posts
    1
    i have the same problem, my friend is now permabanned form the server, no matter what i do i cant seem to get him back on

    Solution please

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    57
    hey, i restartet the server and everything was fine again. do you own the server?

  5. #5
    Join Date
    July 2004
    Location
    Oirschot, Netherlands
    Posts
    123
    if you have serveradmin rights you maybe don't have to, because i think just restarting the virtual server will do the trick so then it is request query login, enter your desired login name. Now you can use the serverquery to login, and then it is: serveridgetbyport virtualserver_port=yourport

    then you know serverid.

    then it is serverstop sid=yoursid and then serverstart sid=yoursid

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Rejected] anti-flood/anti-spam
    By Tomas in forum Suggestions and Feedback
    Replies: 4
    Last Post: May 30th, 2011, 09:20 PM
  2. Anti spam ban Perminant?????
    By *{ELITE}* in forum Windows
    Replies: 1
    Last Post: March 1st, 2011, 04:24 AM
  3. Errorneuos Anti-Spam Ban
    By Nemisis in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: February 3rd, 2011, 10:16 AM
  4. anti spam measure
    By lalawinkee in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: May 6th, 2010, 10:57 PM
  5. Anti-Spam Bug?
    By Phil7789 in forum Server Support
    Replies: 4
    Last Post: December 30th, 2009, 12:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •