Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    December 2009
    Location
    London UK
    Posts
    28

    Please IGNORE

    has anyone been able to get the ts3 server to load with mysql? i see a lot of issue with it starting.

    mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)


    evan though the ts3db_mysql.ini is in the same folder as the bin.
    and yes it filled out right i just want to know if any 1 has been able to start it with mysql support on a linux server useing a username and password for mysql.

    //EDIT1

    Right system check
    i know mysql is running and working fine as other websites i run useing mysql are fine.

    the ts3db_mysql.ini is in the same folder as the bin file.
    made the ts3db_mysql.ini by makeing a new text file under windows 7 and renameing it to ts3db_mysql.ini
    then put int the following
    [config]
    host=localhost
    port=3306
    username=username
    password=blankblank
    database=TS3

    ive made the db usering cpanel
    made the username and added the username to the db with full permissions
    in the ini the username password and db name are right,

    so i cant figger out what is going on, it looks like to me the ts3 servers ignoreing the user/pass as ive evan put a fake one in there same issue
    Last edited by DarKZONE; December 22nd, 2009 at 09:01 PM.

  2. #2
    Join Date
    December 2009
    Location
    London
    Posts
    5
    create a ts3db_mysql.ini:
    -------cut here--------
    [config]
    host=localhost
    port=3306
    username=***
    password=***
    database=***
    socket=mysql

    -------cut here--------

    edit ts3server.ini, adding these:
    -------cut here--------
    dbplugin=ts3db_mysql
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    dbpluginparameter=ts3db_mysql.ini
    -------cut here--------

  3. #3
    Join Date
    December 2009
    Location
    London UK
    Posts
    28
    1 there is no ts3server.ini just made one thogh adding what you put.
    2. added the socet=mysql to the ts3db_myswl.ini
    3. trying to start the server with ./ts3server_linux_x86 dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql

    all = same results

    its still trying to use the root username >.>

    POSTING HERE AS SAME PROBLEM http://forum.teamspeak.com/showthrea...448#post205448

  4. #4
    Join Date
    December 2009
    Location
    United States
    Posts
    23
    Make sure you have a blank line as the last line in ts3db_mysql.ini
    If that doesn't help, remove the socket=mysql and try again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. discussion about MySQL support since server 3.0.11
    By ANR Daemon in forum Off Topic
    Replies: 3
    Last Post: November 14th, 2014, 11:15 AM
  2. Replies: 9
    Last Post: July 12th, 2014, 06:52 PM
  3. cant start the server with MySql
    By Taxoz in forum Linux / FreeBSD
    Replies: 1
    Last Post: March 30th, 2012, 03:40 PM
  4. Server can't start in BSD amd64 with MySQL
    By elenore in forum Linux / FreeBSD
    Replies: 10
    Last Post: December 11th, 2010, 02:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •