Forum

Page 4 of 4 FirstFirst ... 234
Results 46 to 52 of 52
  1. #46
    Join Date
    June 2010
    Location
    Michigan
    Posts
    4
    I had to reinstall TS3 because of HDD problems and I had the same problem as others posted above. I could not select any Hotkey at all on my keyboard. What worked for me was to unhook my Logitech G25 steering wheel and I was immediately able to program my left ALT key as PTT hotkey. I remember now that was what I had to do on the original installation awhile ago.

    Before I had done that I had tried to see if TS3 was being blocked by firewall/antivirus (which it wasnt) I also unchecked the Read Only box when I clicked on Properties for the main TS3 folder.

    If it helps here is what showed up AFTER I was able to set the hotkey. Maybe if you copy and paste to your config folder (opens with Notepad btw) under the PROFILES section and then save the file it SHOULD work for you.


    Hotkeys\Default\Bindings\1\Event\Type=1
    Hotkeys\Default\Bindings\1\Event\Mode=Down
    Hotkeys\Default\Bindings\1\Event\Key1=ALT
    Hotkeys\Default\Bindings\1\Event\KeyIdentifier1=18 64182625-54688-4559-191-199-68-69-83-84-0-056
    Hotkeys\Default\Bindings\1\Event\EventIdentifier={ 61969066-3c73-43ca-8b73-2ffec9d1ce4e}
    Hotkeys\Default\Bindings\1\Action\Type=1
    Hotkeys\Default\Bindings\1\Action\Mode=Activate
    Hotkeys\Default\Bindings\1\Action\Profile=Default
    Hotkeys\Default\Bindings\1\Action\Flag=Push-To-Talk
    Hotkeys\Default\Bindings\1\Action\Auto=true
    Hotkeys\Default\Bindings\2\Event\Type=1
    Hotkeys\Default\Bindings\2\Event\Mode=Up
    Hotkeys\Default\Bindings\2\Event\Key1=ALT
    Hotkeys\Default\Bindings\2\Event\KeyIdentifier1=18 64182625-54688-4559-191-199-68-69-83-84-0-056
    Hotkeys\Default\Bindings\2\Event\EventIdentifier={ 3747f0eb-f45a-4a41-9840-a85b73848272}
    Hotkeys\Default\Bindings\2\Action\Type=1
    Hotkeys\Default\Bindings\2\Action\Mode=Deactivate
    Hotkeys\Default\Bindings\2\Action\Profile=Default
    Hotkeys\Default\Bindings\2\Action\Flag=Push-To-Talk
    Hotkeys\Default\Bindings\2\Action\Auto=true
    Capture\Default\Push-To-Talk=ALT

    *note* I am running latest version 3.0.0 beta22 Build 11315 , on WinXP with standard keyboard (non USB) don't know if it makes a difference or not, but it shouldn't.

  2. #47
    Join Date
    July 2010
    Location
    australia
    Posts
    3
    Quote Originally Posted by ZeroTKA View Post
    Can you right click and run as admin?
    I have the same problem in that it simply doesn't bind a key and run as admin doesn't help.

    I've downloaded the program twice and it's the same both times.
    Any help appreciated.

    thanks

    Ibissix

  3. #48
    Join Date
    July 2010
    Location
    australia
    Posts
    3
    Ok, same problem.
    Disconnected Saitek X45, set key binding and bingo, all's well, reconnected, problem solved.
    thanks for the help.
    cheers,
    Ibis.
    Last edited by Ibissix; July 2nd, 2010 at 07:14 AM. Reason: to add thanks to posters who helped

  4. #49
    Join Date
    November 2008
    Location
    United States
    Posts
    1,718
    thanks for posting your solution.

  5. #50
    Join Date
    March 2011
    Posts
    1
    Quote Originally Posted by GsG Knighthawk66 View Post
    I had to reinstall TS3 because of HDD problems and I had the same problem as others posted above. I could not select any Hotkey at all on my keyboard. What worked for me was to unhook my Logitech G25 steering wheel and I was immediately able to program my left ALT key as PTT hotkey. I remember now that was what I had to do on the original installation awhile ago.
    Thanks, Unplugging the G25 worked and i was able to assign a hotkey!!

  6. #51
    Join Date
    September 2012
    Posts
    1

    Hotkey issue

    I think we're dealing with multiple comorbid issues here
    1: Saitek joysticks affecting hotkeys
    2: USB keyboards are unrecognized
    3: Hotkey menu isn't working with keyboard input

    I've noticed that the menu works fine with mouse input, including extra keys, at least on my Razer mouse, but it isn't working with input from my laptop keyboard, or my friend's USB keyboard, even after manually setting a hotkey with a script, or using the set-up wizard workaround if any of the TS folks are watching this thread, a hotfix would be appreciated

    EDIT:
    wow, just realized that these posts are a year or two old, this might be something different...

  7. #52
    Join Date
    November 2012
    Posts
    1
    hey guys i just tryed something and it seems to work,for me at least.

    go to settings>options>hotkeys>see down right "default" change it to "direct input" then apply. and your good to go.

    works for me i hope it works for you guys allso.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 11:39 AM
  2. Replies: 3
    Last Post: June 22nd, 2010, 11:35 PM
  3. Hotkey for switch "push to talk" and "voice activated"
    By eternal-blue in forum General Questions
    Replies: 1
    Last Post: January 8th, 2010, 10:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •