Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    December 2009
    Location
    California
    Posts
    6

    -bash: ./teamspeak3: Permission denied

    So I download the TS3 server for Linux 32bit, get it working well enough to login and insert the 1st token. I decided that I should move up a level and upload the TS3 server to my web host, and run it through SSH. Not so great. I get an error "-bash: ./teamspeak3: Permission denied". Confused I check to see if my old TS2 server still works, which it does. So I contact my web host's tech support, and they tell me the only reason that error shows up is because the program needs root to run, which is obviously NOT true for TS3. They tell me to contact the manufacturer to ask about the permission level the program needs. So as my last resort I am here asking... How do I get this to work? Is there anyway to lower the level of permission the program needs? I would love some help.

    Thanks
    Sirkyuubi

  2. #2
    Join Date
    December 2007
    Location
    Austria,Linz
    Posts
    214
    just do:

    chmod u+x ./teamspeak3

    U+X says, that the Owner (User) of the TS3 files is allowed, to execute the file.

  3. #3
    Join Date
    December 2009
    Location
    California
    Posts
    6

    chmod'd

    Ok so I did a chmod like u said and it got the program running, but now I get this instead

    2009-12-24 17:48:49.262998|DEVELOP | | | TS3ANetwork::Connect failed error: 110

    2009-12-24 17:48:49.263139|ERROR |Accounting | | Unable to connect to accounting server

    2009-12-24 17:48:49.271328|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: unable to connect to accounting server

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    20
    TS3 Linux Server dont need "root" login to install or to start.

    look in dir listing if all files and directories have the same Group-User permission.

    please note here your working to install the TS3 on your server

    greets from germany
    Deep

  5. #5
    Join Date
    December 2007
    Location
    Austria,Linz
    Posts
    214
    have you opened the ports ?

    10011 <- Telnet
    9987 <- TS Server
    2008 TCP -> License Server

  6. #6
    Join Date
    December 2009
    Location
    California
    Posts
    6
    All ports should be open. Is there something I need to do with the ini file?

  7. #7
    Join Date
    December 2007
    Location
    Austria,Linz
    Posts
    214
    post your inifile please (if you use)

  8. #8
    Join Date
    December 2009
    Location
    California
    Posts
    6
    I don't use an ini file. Should I start using one?

    I have all IPs at 0.0.0.0, which from what I know means any. Should I change this and make an ini file?

  9. #9
    Join Date
    March 2005
    Location
    Germany
    Posts
    50
    my server is running fine with all ip's showing 0.0.0.0 on startup.
    just made an ini for mysql support but startup is unchanged.

  10. #10
    Join Date
    December 2009
    Location
    California
    Posts
    6
    For those of you who don't know. As I mentioned above, I am not trying this from my home Linux box. I'm trying to get this working via SSH through the dedicated server that I pay a yearly fee for.
    Last edited by sirkyuubi; December 26th, 2009 at 06:09 AM.

  11. #11
    Join Date
    December 2009
    Location
    Malmö
    Posts
    11
    Quote Originally Posted by sirkyuubi View Post
    For those of you who don't know. As I mentioned above, I am not trying this from my home Linux box. I'm trying to get this working via SSH through the dedicated server that I pay a yearly fee for.
    Do PS -A in terminal to see if you got any ts3 service running allready if so just pkill teamspeak or a use its pid to kill it.

  12. #12
    Join Date
    December 2009
    Location
    spb
    Posts
    3
    i have some problem:
    Server() error while starting servermanager, error: unable to connect to accounting server
    wich port is using by "Server()", when connecting to the "accounting server"?

    my ini file:
    [~/teamspeak3-server_linux-x86]# less ts3server.ini
    machine_id=
    default_voice_port=8000
    voice_ip=67.20.x.x
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=0

    ts dir:
    [~/teamspeak3-server_linux-x86]# ls -la
    total 6268
    drwxr-xr-x 7 dikunorg dikunorg 4096 Dec 29 11:20 ./
    drwx--x--- 13 dikunorg nobody 4096 Dec 29 08:19 ../
    -rw-r--r-- 1 dikunorg dikunorg 8053 Dec 29 08:19 CHANGELOG
    -rw-r--r-- 1 dikunorg dikunorg 23747 Dec 29 08:19 LICENSE
    drwxr-xr-x 2 dikunorg dikunorg 4096 Dec 29 08:19 doc/
    drwx------ 3 dikunorg dikunorg 4096 Dec 29 08:21 files/
    -rwxr-xr-x 1 dikunorg dikunorg 194893 Dec 29 08:19 libts3db_mysql.so*
    -rwxr-xr-x 1 dikunorg dikunorg 821569 Dec 29 08:19 libts3db_sqlite3.so*
    -rw-r--r-- 1 dikunorg dikunorg 931 Dec 29 08:50 licensekey.dat
    drwx------ 2 dikunorg dikunorg 4096 Dec 29 11:10 logs/
    -rw-r--r-- 1 dikunorg dikunorg 112 Dec 29 10:43 serverkey.dat
    drwxr-xr-x 2 dikunorg dikunorg 4096 Dec 29 08:19 serverquerydocs/
    drwxr-xr-x 4 dikunorg dikunorg 4096 Dec 29 08:19 sql/
    -rw-r--r-- 1 dikunorg dikunorg 275 Dec 29 11:05 ts3server.ini
    -rw-r--r-- 1 dikunorg dikunorg 168960 Dec 29 11:13 ts3server.sqlitedb
    -rwxr-xr-x 1 dikunorg dikunorg 5127804 Dec 29 08:19 ts3server_linux_x86*
    Last edited by nd4w3; December 30th, 2009 at 11:06 AM.

  13. #13
    Join Date
    December 2009
    Location
    Europe
    Posts
    181
    Accounting is handled by port 2008 TCP.

  14. #14
    Join Date
    December 2009
    Location
    spb
    Posts
    3
    Quote Originally Posted by Birdie View Post
    Accounting is handled by port 2008 TCP.
    and i cant change this setting?

  15. #15
    Join Date
    December 2009
    Location
    Europe
    Posts
    181
    If I got it correctly, it is sufficient to allow outbound connections to remote port 2008 TCP. Your server will then try to connect the accounting server on the accounting server's TCP port 2008. Your server will use any free local TCP high port for establishing this connection. So you cannot change that port.
    (Again - if I have understood it correctly - I have derived this information from what I found in this forum).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak3 Bash Installer
    By stokes84 in forum Linux / FreeBSD
    Replies: 7
    Last Post: May 21st, 2014, 06:58 PM
  2. permission denied
    By singularity in forum Linux / FreeBSD
    Replies: 6
    Last Post: June 24th, 2012, 03:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •