Forum

Page 7 of 7 FirstFirst ... 567
Results 91 to 101 of 101
  1. #91
    Join Date
    September 2010
    Location
    us
    Posts
    3
    Quote Originally Posted by RefleX-mrl View Post
    Are you sure you want to install the Teamspeak Client and not the Server? Client is up on beta 29.. server on beta28.
    That's the out put from running the script on my server. Does the script only check for directories? Is that why it thinks theres a beta 29?

  2. #92
    Join Date
    September 2010
    Location
    us
    Posts
    3
    Quote Originally Posted by guhguh View Post
    That's the out put from running the script on my server. Does the script only check for directories? Is that why it thinks theres a beta 29?
    Ok so I changed the FTP path in the script to be http://ftp.4players.de/pub/hosted/ts3/releases/beta-28/

    When I try to update it says
    ts3server_linux_x86: no process killed
    tar: teamspeak3-server_linux-amd64-3.0.0-beta28.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    cp: cannot stat `teamspeak3-server_linux-x86/*': No such file or directory
    Unzip and copying are successfully

    Start TeamSpeak3 Server

    TeamSpeak3 Server Screen PID was write in /opt/ts3/teamspeak3-server_linux-amd64/ts3-screen.pid.
    TeamSpeak3 Server was started.
    Serverupdate from to beta28 !

    I can run a wget and pull down the file.

  3. #93
    Join Date
    January 2010
    Location
    Germany
    Posts
    15
    Hi,

    I have a problem: The Version, I have installed is beta 26. The current Server Version for Linux x86 is beta 28. But the Script say alwas "update to beta 29". And the script didn't show me the installed Version. If I want to update, some Erros where shown to me:
    Code:
    tar: teamspeak3-server_linux-x86-3.0.0-beta29.tar.gz: Kann open nicht ausführen: Datei oder Verzeichnis nicht gefunden
    tar: Nicht behebbarer Fehler: Programmabbruch.
    tar: Child returned status 2
    tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
    cp: Aufruf von stat für teamspeak3-server_linux-x86/* nicht möglich: Datei oder Verzeichnis nicht gefunden
    I hope that you can help me.
    Last edited by matrix142; September 13th, 2010 at 10:31 AM.

  4. #94
    Join Date
    September 2010
    Location
    Emden
    Posts
    1
    wen ich ./startscript.sh eingebe sagt er das zu mir sieh unten
    -bash: ./startscript.sh: /bin/sh^M: bad interpreter: No such file

  5. #95
    Join Date
    September 2010
    Location
    netherlands
    Posts
    2
    Quote Originally Posted by Skad3n View Post
    wen ich ./startscript.sh eingebe sagt er das zu mir sieh unten
    -bash: ./startscript.sh: /bin/sh^M: bad interpreter: No such file
    simple sollution:
    type:
    cd "path to the folder with startscript.sh" (i.e.: cd /home/ts3/)
    type: vi startscript.sh
    :set fileformat=unix (after this it seems that nothing happened, but something did happen)
    :wq!

    should work now

    and to the creator of this script: good work but you should fix the problem that:
    your script checks the newest release, but looks at the newest version, and i.e. at the moment server is @ beta 28 but client is already @ beta 32. and your script says: newest version available: beta 32, next thing that happens is: script can't download the beta 32 server files, since they are not there yet.

    possible sollutions for now:
    change the ftp-path into a folder where you placed the beta-28 files but NAMED THEM like beta 32 files.
    or: change the ftp path into: ..../releases/beta-28/
    should work


    vp

  6. #96
    Join Date
    January 2010
    Location
    France
    Posts
    31
    Ok so I changed the FTP path in the script to be http://ftp.4players.de/pub/hosted/ts3/releases/beta-28/
    Replace
    wget -O - $FTPPATH 2> /dev/null | grep -o -E $STATUS-[[:digit:]]+[[:digit:]]+ -o | tail -n1 > current
    in server_update() {

    BY

    INC=1
    COUNTER=0
    while [ $COUNTER -lt 10 ]; do
    wget -O - $FTPPATH 2> /dev/null | grep -o -E $TS_STATE-[[:digit:]]+[[:digit:]]+ -o | uniq | sort -r | sed -n "${INC}p" > current
    if wget -O - $FTPPATH$(cat current) 2> /dev/null | grep $FILENAME > /dev/null ; then
    COUNTER=20
    else
    let INC=$INC+1
    fi
    done
    Simple Code not optimized. the second wget see if FILENAME exist or not. If not, first wget decrease beta version and etc...

  7. #97
    Join Date
    August 2008
    Location
    Whois
    Posts
    586
    Thanks Ethaniel for u help!

    I have Fix the problem and update the Sroucecode
    besides i have add an email function, so i hope it works,
    i cant test it atm

    now u can add this script to ( crontab -e ), if a update available
    the script send an email too.

    Attention!!! This Script is ALPHA NONFULLTESTED !!! I cannot guarantee, all works fine!!!

    I must wait for a next serverupdate ...

  8. #98
    Join Date
    January 2011
    Location
    Germany
    Posts
    1
    My Server doesn't start with the startscript. I edited the configuration lines well i think. I have debian x64 on my Server. The script says that the server has started and the pid file is in the right directory. But the server is still down.
    ./startscript status says that screen awk ... are found.
    The update function works!
    I added my startscript.


    I hope someone can help me!


    Greets

  9. #99
    Join Date
    August 2008
    Location
    Whois
    Posts
    586
    New Update to 1.4.0 for public.

  10. #100
    Join Date
    September 2009
    Location
    Earth
    Posts
    3
    Quote Originally Posted by /dev/null/ View Post
    New Update to 1.4.0 for public.
    You can optimize your script to find the current ts_version.

    change line 169/258/337:
    cat update | grep -E -o virtualserver_version="([0-9].[0-9].[0-9].[0-9])" | cut -d "=" -f 2 > version

    to:
    cat update | grep -E -o virtualserver_version="(([0-9]{1,2}.){0,3}[0-9]{1,2})" | cut -d "=" -f 2 > version

    Now, versions from 1 to 99.99.99.99 are supported - I hope. ^^

    Greetz
    Last edited by HeinzMuell; August 6th, 2012 at 08:21 PM.

  11. #101
    Join Date
    February 2012
    Posts
    4
    Maybe someone could help me with this thing. Because it make's me verry nervous hehe. When i doo ./startscript.sh check i have error with email.

    ./startscript.sh: ./mail.sh: /bin/bash^M: bad interpreter: No such file or directory

    Could any one help ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please Update this Plugin ""Connection History"" Or Include to Client Version
    By varela1george in forum Suggestions and Feedback
    Replies: 2
    Last Post: October 13th, 2012, 08:28 AM
  2. [No Bug] Updated to "Beta Channel" version, reverted, "lost" my contacts
    By Nev0r in forum Client Support
    Replies: 3
    Last Post: March 21st, 2011, 02:02 PM
  3. [Implemented in beta 23] Copy "Server Group"
    By bubu_123 in forum General Questions
    Replies: 6
    Last Post: July 12th, 2010, 03:31 PM
  4. Linux-Startscript for Teamspeak3 (without screen)
    By zeitsofa in forum Tools / Web Based
    Replies: 8
    Last Post: February 2nd, 2010, 05:47 PM
  5. Replies: 4
    Last Post: December 24th, 2009, 12:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •