Forum

Results 1 to 12 of 12
  1. #1
    Join Date
    December 2009
    Location
    Silicon Valley
    Posts
    10

    Server Crash - 'std::bad_alloc'

    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead


    Code:
     ./ts3server_linux_amd64 inifile=ts3server.ini
    Logging started
    2009-12-28 00:53:44.007775|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta9 [Build: 9527]
    2009-12-28 00:53:44.008743|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-28 00:53:44.008787|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2009-12-28 00:53:44.787535|INFO    |Accounting    |   | Licensing Information
    2009-12-28 00:53:44.788063|INFO    |Accounting    |   | type              : Non-profit
    2009-12-28 00:53:44.788367|INFO    |Accounting    |   | starting date     : Sat Dec 26 15:00:00 2009
    2009-12-28 00:53:44.788587|INFO    |Accounting    |   | ending date       : Sun Dec 26 15:00:00 2010
    2009-12-28 00:53:44.788810|INFO    |Accounting    |   | max virtualservers: 10
    2009-12-28 00:53:44.789007|INFO    |Accounting    |   | max slots         : 512
    2009-12-28 00:53:44.804273|INFO    |FileManager   |   | listening on xxx.xxx.xxx.202:30033
    2009-12-28 00:53:44.830342|INFO    |VirtualServer |  1| listening on xxx.xxx.xxx.202:9987
    2009-12-28 00:53:44.830831|INFO    |Query         |   | listening on xxx.xxx.xxx.202:10011
    terminate called after throwing an instance of 'std::bad_alloc'
      what():  St9bad_alloc
    Aborted (core dumped)
    Any thoughts on this help would be appreciated. This is not from Upgrade brand new Tarball, clean install attempt.

    The server is up for mire moments maybe 25 or 30 seconds then it just dies.

    The Authentication system and the db all look clean and functional.
    Last edited by florian_fr40; November 10th, 2011 at 03:49 PM.

  2. #2
    Join Date
    December 2009
    Location
    Silicon Valley
    Posts
    10
    bump

    Still need help with this

  3. #3
    Join Date
    December 2009
    Location
    Silicon Valley
    Posts
    10

    Serious issue

    Did some additional research on my own it seems this error seems to refer to a memory allocation issue.

    Example

    http://www.cplusplus.com/forum/beginner/4485/

    There are others

    http://www.google.com/search?rlz=1C1...std::bad_alloc

    Still I am trying to run this on a 500 dollar a month dedicated rack server we have the resources.

    Code:
    top - 03:32:32 up 133 days, 13:37,  1 user,  load average: 0.08, 0.09, 0.07
    Tasks: 166 total,   1 running, 165 sleeping,   0 stopped,   0 zombie
    Cpu0  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu1  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu2  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu3  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu4  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu5  :  0.7%us,  0.0%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu6  :  4.4%us,  0.3%sy,  0.0%ni, 95.3%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Cpu7  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:   8182200k total,  7442472k used,   739728k free,   744404k buffers
    Swap:  2096472k total,      132k used,  2096340k free,  5283120k cached
    I hope this helps find a solution.

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    17
    tried a newer buid (beta11)? does the problem persist?
    tried a different machine?

    best regards

  5. #5
    Join Date
    April 2009
    Location
    England
    Posts
    9

    Problem starting server

    This is what was in my nohup file.

    2009-12-31 03:42:58.887721|INFO |ServerLibPriv | | Server Version: 3.0.0-beta11 [Build: 9559]
    2009-12-31 03:42:58.888131|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2009-12-31 03:42:58.888188|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2009-12-31 03:42:59.674959|INFO |Accounting | | Licensing Information
    2009-12-31 03:42:59.675852|INFO |Accounting | | type : Non-profit
    2009-12-31 03:42:59.676426|INFO |Accounting | | starting date : Wed Dec 23 23:00:00 2009
    2009-12-31 03:42:59.676955|INFO |Accounting | | ending date : Thu Dec 23 23:00:00 2010
    2009-12-31 03:42:59.677468|INFO |Accounting | | max virtualservers: 10
    2009-12-31 03:42:59.677978|INFO |Accounting | | max slots : 512
    2009-12-31 03:42:59.704219|INFO |FileManager | | listening on 0.0.0.0:30033
    2009-12-31 03:42:59.738002|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    2009-12-31 03:42:59.738529|INFO |Query | | listening on 0.0.0.0:10011
    terminate called after throwing an instance of 'std::bad_alloc'
    what(): St9bad_alloc

  6. #6
    Join Date
    December 2009
    Location
    Europe
    Posts
    181
    Seems to be the same problem as this one:
    http://forum.teamspeak.com/showthread.php?t=48433

  7. #7
    Join Date
    April 2009
    Location
    England
    Posts
    9
    There's no fix that has been posted for it though

  8. #8
    Join Date
    January 2010
    Location
    Germany
    Posts
    28
    Alloc could mean allocation, which has to do with the memory allocation.

    So it could be a problem with the memory or a special permissions to do something in the memory.

  9. #9
    Join Date
    January 2012
    Posts
    2

    Issues running TS3 server on new VPS

    I just moved to a new VPS. Until now, I have been able to run TS3 just fine. Now, when I issue the command:

    sh ts3server_startscript.sh start

    I get:

    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [email protected] [~/ts3]# terminate called after throwing an instance of 'St9bad_alloc'
    what(): std::bad_alloc

    I've been googling and searching on this forum for about three hours now, and can't seem to figure this out.

    I went so far as to even attempt to download the CPanel Gameservers plugin and run it via there... I can run it through the CPanel panel, but when I navigate to that folder and try to run it manually, I get the same error. To compound the issue, when I try to run it via the Gameservers CPanel plugin after swapping to my backed up copy of the old server's ts3server.sqlitedb file, I get:

    |ERROR |Accounting | | too many slots hosted, shutting down!

    Any ideas to help me get back up and running would be greatly appreciated.

    *** Thread Merged ***
    Last edited by florian_fr40; February 15th, 2012 at 09:34 AM.

  10. #10
    Join Date
    June 2008
    Posts
    17,479
    The error message says exactly why the server got stopped.
    It tells you, that your license file already does use to many slots.

    Make sure, that alll other server with the same license are stopped.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #11
    Join Date
    May 2010
    Posts
    6,310
    Hello

    The 'St9bad_alloc' error usually means that the requested amount of memory can not be allocated on a system.

    You should have a look at the memory consumption during this problem.

  12. #12
    Join Date
    September 2012
    Posts
    1
    Hello, Still no FIx with this issue mate?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] teamspeak 3 application android crash crash crash
    By hycksou in forum Android
    Replies: 4
    Last Post: July 5th, 2017, 07:05 PM
  2. Replies: 0
    Last Post: November 18th, 2014, 10:40 PM
  3. TS Server 3 Crash
    By kruskg in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: August 3rd, 2011, 09:21 AM
  4. Replies: 11
    Last Post: April 19th, 2010, 12:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •