Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    April 2009
    Location
    IN
    Posts
    18

    Solved Setting 2 push to talk buttons

    I play games with controller and use keyboard at the same time. It would be nice to have 2 push to talk options. That way if I'm typing on the keyboard, I don't have to pick up my controller and visa versa.

  2. #2
    Join Date
    December 2009
    Location
    Canberra, Australia
    Posts
    4
    I think you can already do this.

    Just go Settings > Options > Hotkeys
    From there you should be able to set up a second push to talk button.

    EDIT: I just confirmed this works

  3. #3
    Join Date
    April 2009
    Location
    IN
    Posts
    18
    Quote Originally Posted by Petoro View Post
    I think you can already do this.

    Just go Settings > Options > Hotkeys
    From there you should be able to set up a second push to talk button.

    EDIT: I just confirmed this works
    How, I tried and it said "this can only be done thru setup" and setup won't let me make 2 hotkeys for push to talk.

    Anyone have an idea how i can set 2 push to talk buttons? The guy above said he got it to work but no matter what I try, push to talk is only available thru the wizard and you can only set 1 there. Using hot keys doesn't give me access to push to talk, only whispers.
    Last edited by Gryphon; January 2nd, 2010 at 08:01 AM.

  4. #4
    Join Date
    December 2009
    Location
    Taiwan
    Posts
    313
    had any of you silly fools ever read the description in the hot key section

    you should see something like ...

    hotkey - Mouse Button 3 (down/up)
    Action - status change: Activate/Deactivate Push-to-Talk for Capture Profile: -Profile name here-

    so ... just try to "mimic" it?

    add -> status change -> activate/deactivate -> Push-To-Talk -> for profile: -Profile name here-

    look around, it's not complicated math

  5. #5
    Join Date
    April 2009
    Location
    IN
    Posts
    18
    Quote Originally Posted by willy_sunny View Post
    had any of you silly fools ever read the description in the hot key section

    you should see something like ...

    hotkey - Mouse Button 3 (down/up)
    Action - status change: Activate/Deactivate Push-to-Talk for Capture Profile: -Profile name here-

    so ... just try to "mimic" it?

    add -> status change -> activate/deactivate -> Push-To-Talk -> for profile: -Profile name here-

    look around, it's not complicated math
    Except you can't mimic push to talk. I tried. You cant even click on it form the hot key menu. It tells you "This hotkey can only be changed via setup!"

  6. #6
    Join Date
    December 2009
    Location
    Canberra, Australia
    Posts
    4
    Quote Originally Posted by MIGhunter View Post
    Except you can't mimic push to talk. I tried. You cant even click on it form the hot key menu. It tells you "This hotkey can only be changed via setup!"
    That message shows up when you press the Edit button on the existing push-to-talk hotkey, you want to add a new hotkey and not edit the existing one. Did you notice willy_sunny gave instructions to use the Add button and not the Edit button?

    I have tried this and it works.

    you should already have two hotkeys set up.
    which would look like.
    KEY1 (down) status chance: Activate Push-To-Talk for Capture Profile: Default
    and
    KEY1 (up) status chance: Deactivate Push-To-Talk for Capture Profile: Default

    On the hotkeys menu, add two new hotkeys which are going to be exactly the same as the ones above.
    To add these new buttons, on the hotkeys menu you must click:
    Add > Status Change > Activate/Deactivate > Push-ToTalk > for profile: Default
    Add one for down to activate and up to deactivate.

    You should have two new hotkeys in the list which would look like this.
    KEY2 (down) status chance: Activate Push-To-Talk for Capture Profile: Default
    and
    KEY2 (up) status chance: Deactivate Push-To-Talk for Capture Profile: Default

    Really, this shouldn't be too hard to grasp, let alone work out yourself.

  7. #7
    Join Date
    April 2009
    Location
    IN
    Posts
    18
    Quote Originally Posted by Petoro View Post
    That message shows up when you press the Edit button on the existing push-to-talk hotkey, you want to add a new hotkey and not edit the existing one. Did you notice willy_sunny gave instructions to use the Add button and not the Edit button?

    I have tried this and it works.

    you should already have two hotkeys set up.
    which would look like.
    KEY1 (down) status chance: Activate Push-To-Talk for Capture Profile: Default
    and
    KEY1 (up) status chance: Deactivate Push-To-Talk for Capture Profile: Default

    On the hotkeys menu, add two new hotkeys which are going to be exactly the same as the ones above.
    To add these new buttons, on the hotkeys menu you must click:
    Add > Status Change > Activate/Deactivate > Push-ToTalk > for profile: Default
    Add one for down to activate and up to deactivate.

    You should have two new hotkeys in the list which would look like this.
    KEY2 (down) status chance: Activate Push-To-Talk for Capture Profile: Default
    and
    KEY2 (up) status chance: Deactivate Push-To-Talk for Capture Profile: Default

    Really, this shouldn't be too hard to grasp, let alone work out yourself.
    Ya, but push to talk isn't in the tree for adding hotkey stuff. Maybe the server I'm using has something disabled? Are you just typing in the stuff or are you running through the tree?

  8. #8
    Join Date
    December 2009
    Location
    Canberra, Australia
    Posts
    4
    Quote Originally Posted by MIGhunter View Post
    Ya, but push to talk isn't in the tree for adding hotkey stuff. Maybe the server I'm using has something disabled? Are you just typing in the stuff or are you running through the tree?
    I was running through the tree as I was typing in the instructions so it is all correct.

    Status Change > Activate/Deactivate > Push-ToTalk > for profile: Default
    This Image shows you exactly where it is.
    http://img.photobucket.com/albums/v2...s/untitled.jpg

    I don't think I can make this any easier for you.
    It's very simple and I don't understand why you can't figure it out.
    If you still don't get it please go over the posts above a couple of times again, because trying to explain this to you is getting quite tiresome and I am not going to continue helping with this.

  9. #9
    Join Date
    November 2008
    Location
    United States
    Posts
    1,718
    Or you can add a hotkey profile, switch to the capture tab, assign the button you want, and then a pop up comes up asking which hotkey profile you want to set it to.

  10. #10
    Join Date
    April 2009
    Location
    IN
    Posts
    18
    Quote Originally Posted by Petoro View Post
    I was running through the tree as I was typing in the instructions so it is all correct.

    Status Change > Activate/Deactivate > Push-ToTalk > for profile: Default
    This Image shows you exactly where it is.
    http://img.photobucket.com/albums/v2...s/untitled.jpg

    I don't think I can make this any easier for you.
    It's very simple and I don't understand why you can't figure it out.
    If you still don't get it please go over the posts above a couple of times again, because trying to explain this to you is getting quite tiresome and I am not going to continue helping with this.
    Hmm, i don't have that option, wonder if it's disabled or something. I think I'm just going to make a 2nd profile with a hot key to change profiles or something.

  11. #11
    Join Date
    September 2010
    Location
    SE
    Posts
    10
    Don't have it either now, as I install TS3 on this older PC. I was able to set it up on my main PC a few versions ago, but not now on this older PC. The option "STATUS CHANGE" isn't there. If I go to my main PC, the added PTT keys are still there, but the option to add more are gone. Probably since an update.

    Not good, a new version that's less versatile than previous versions...

    Being clever as I am, I opted to have all settings in the installation folder, so I solved it by copying the TS folder from my main PC to this old one. Tada.

  12. #12
    Join Date
    November 2010
    Location
    My House
    Posts
    3
    I too reinstalled TS3 and was ticked off that I could no longer assign multiple push-to-talk keys.

    That was a great feature! Bring it back!

    I don't have the old install directory, so I can't revert it back to the good old days..

    I'm up for some file hacking if someone knows how to do it.

  13. #13
    Join Date
    November 2008
    Location
    United States
    Posts
    1,718
    Hello geneflum,

    I encourage you to wait for a new release.

    In the meantime you may get the old versions here if you so choose to do so http://ftp.4players.de/pub/hosted/ts3/releases/

  14. #14
    Join Date
    February 2007
    Location
    australia
    Posts
    1
    === Client Release 3.0.0-beta36 08 Nov 2010
    + Activate, Deactivate and Toggle PTT hotkeys have been moved to category
    Microphone and renamed to "Local Mic Mute" which is now more meanigful

    found it... i can haz cookie?

    dunno what they mean about meaningful...

  15. #15
    Join Date
    March 2011
    Posts
    1
    hmm just reinstalled and i was looking for over a day what what the problem
    guess im sticking to beta 35 then

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Push-to-talk with Mouse extra buttons
    By jjwwide in forum Windows
    Replies: 1
    Last Post: September 4th, 2015, 12:06 AM
  2. G buttons push to talk with G930
    By 0wn3r in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: September 23rd, 2013, 08:25 AM
  3. dual push to talk buttons
    By rtedgar in forum General Questions
    Replies: 1
    Last Post: January 4th, 2011, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •