Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
  1. #16
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Ok,

    then post your start command and your ts3server.ini also ts3sql.ini if you are using mysql.

    cheech

  2. #17
    Join Date
    December 2009
    Location
    Germany
    Posts
    2
    I have the same issue. The server crashed this morning.

    last line in log (nothing special before):
    2009-12-31 08:44:45.052911|CRITICAL|VirtualSvrMgr | | Assertion "m_pVirtualServerData->getFailedLocks() < 100" failed at server/serverlib/virtualserver_manager.cpp:1024;
    To start TS3 I'm using the start script from http://forum.teamspeak.com/showthread.php?t=47075 which uses screen to start the process in the background.

    ps ax:
    15990 ? Ss 0:00 SCREEN -AmdS TS3SERVER ./ts3server_linux_amd64 voice_ip=x.x.x.x default_voice_port=9987 create_default_virtualserver=1 machine_id= filetransfer_ip=x.x.x.x filetransfer_port=30033 query_ip=x.x.x.x query_port=10011 clear_database=0 logpath=logs/ dbplugin=ts3db_mysql dbpluginparameter= dbsqlpath=sql/ dbsqlcreatepath=create_mysql/ licensepath= createinifile=1 inifile=ts3server.ini
    15991 pts/1 Ssl+ 0:00 ./ts3server_linux_amd64 voice_ip=x.x.x.x default_voice_port=9987 create_default_virtualserver=1 machine_id= filetransfer_ip=x.x.x.x filetransfer_port=30033 query_ip=x.x.x.x query_port=10011 clear_database=0 logpath=logs/ dbplugin=ts3db_mysql dbpluginparameter= dbsqlpath=sql/ dbsqlcreatepath=create_mysql/ licensepath= createinifile=1 inifile=ts3server.ini
    ts3server.ini:
    machine_id=
    default_voice_port=9987
    voice_ip=x.x.x.x
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=x.x.x.x
    query_port=10011
    query_ip=x.x.x.x
    dbplugin=ts3db_mysql
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    logpath=logs/
    logquerycommands=0
    ts3db_mysql.ini:
    [config]
    host=x.x.x.x
    port=3306
    username=tools_TS3
    password=xxx
    database=tools_TS3
    socket=
    The mysql server is on another host, not local.

    ls -l:
    insgesamt 12328
    -rw-r--r-- 1 ts3 ts3 5844 2009-12-22 18:20 CHANGELOG
    drwxr-xr-x 2 ts3 ts3 4096 2009-12-22 23:25 doc
    drwx------ 6 ts3 ts3 4096 2009-12-26 18:16 files
    -rwxr-xr-x 1 ts3 ts3 212171 2009-12-22 18:20 libts3db_mysql.so
    -rwxr-xr-x 1 ts3 ts3 815728 2009-12-22 18:20 libts3db_sqlite3.so
    -rw-r--r-- 1 ts3 ts3 23747 2009-12-22 18:20 LICENSE
    -rw------- 1 ts3 ts3 898 2009-12-22 22:52 licensekey.dat
    drwxr-xr-x 2 ts3 ts3 4096 2009-12-31 13:14 logs
    -rw-r--r-- 1 ts3 ts3 112 2009-12-22 22:52 serverkey.dat
    drwxr-xr-x 2 ts3 ts3 4096 2009-12-22 18:20 serverquerydocs
    drwxr-xr-x 4 ts3 ts3 4096 2009-12-22 18:20 sql
    -rw-r--r-- 1 ts3 ts3 111 2009-12-22 21:48 ts3db_mysql.ini
    -rw-r--r-- 1 ts3 ts3 284 2009-12-31 13:14 ts3server.ini
    -rwxr-xr-x 1 ts3 ts3 3775120 2009-12-29 03:31 ts3server_linux_amd64
    -rwxr-xr-x 1 ts3 ts3 3769936 2009-12-28 14:33 ts3server_linux_amd64.beta10
    -rwxr-xr-x 1 ts3 ts3 3775120 2009-12-29 03:31 ts3server_linux_amd64.beta11
    -rw-r--r-- 1 ts3 ts3 169984 2009-12-22 23:23 ts3server.sqlitedb
    The directory is owned by ts3:ts3 and also all subdirs.

    --
    Edit: I've changed the startscript to http://forum.teamspeak.com/showthread.php?t=47710 without using screen. So ps ax now only shows:
    17280 pts/0 Sl 0:00 /opt/ts3/ts3server_linux_amd64 voice_ip=xxx default_voice_port=9987 create_default_virtualserver=1 machine_id= filetransfer_ip=xxx filetransfer_port=30033 query_ip=xxx query_port=10011 clear_database=0 logpath=logs/ dbplugin=ts3db_mysql dbpluginparameter= dbsqlpath=sql/ dbsqlcreatepath=create_sqlite/ licensepath= createinifile=0 inifile=ts3server.ini

  3. #18
    Join Date
    June 2009
    Location
    Germany
    Posts
    14
    grüß dich cheech

    Code:
    2009-12-31 12:09:34.185977|CRITICAL|VirtualSvrMgr |   | Assertion "m_pVirtualServerData->getFailedLocks() < 100" failed at server/serverlib/virtualserver_manager.cpp:1024;
    es liegt nicht daran, hatte den fehler wieder.

  4. #19
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    ok your start script is realy strange because there are so many commands and values but the most are not needed but ok.

    And choffi reports again same issue so i think it's really a server issue.

    Because choffi had deffently the correct settings and start command.

    sorry can't help you.

    cya
    cheech

  5. #20
    Join Date
    June 2009
    Location
    Germany
    Posts
    14
    hey cheech, ich nochmal, ich hab da noch was endeckt

    Code:
    2009-12-30 21:41:55.719534|WARNING |VirtualSvrMgr |   | dbLoadVirtualServers time: 00:00:02
    2009-12-30 21:41:55.720537|INFO    |Query         |   | listening on 0.0.0.0:10011
    2009-12-31 12:09:34.185977|CRITICAL|VirtualSvrMgr |   | Assertion "m_pVirtualServerData->getFailedLocks() < 100" failed at server/serverlib/virtualserver_manager.cpp:1024;
    keine ahnung ob das nen zusammenhang hat?

  6. #21
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    glaube nicht oder haste das immer wenn der fehler kommt ?

    Die Warnung sagt nur das die DB 2sek gebraucht hat zum reagieren und der Timeout steht beim TS3 standart mäßig auf 2 sek. also sagt die Warnung das dein MYSQL etwas langsam war.

    Kann zwar damit zusammen hängen muss aber nicht.

    Gruß
    cheech

  7. #22
    Join Date
    March 2006
    Location
    Chile
    Posts
    19
    guys, can you please try to keep the thread in english so we can all participate on the discussion? thanks!

  8. #23
    Join Date
    December 2009
    Location
    germany
    Posts
    13
    hatte eben den selben fehler

    gestartet hatte ich den server beta 12 am 31.12 um etwa 23 uhr
    abgeschmiert ist er am 02.01 um etwa 1 uhr



    dan wolte ich den server neu starten aber er kam nur bis

    INFO |ServerLibPriv | | Server Version: 3.0.0-beta12 [Build: 9596]
    INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    INFO |DatabaseQuery | | dbPlugin version: 3.6.21

    nachdem ich ihn dan wieder neu startete läuft er nun wieder

  9. #24
    Join Date
    January 2010
    Location
    Bochum, Germany
    Posts
    1
    same issue here. using newest beta (#12) 32bit @debian lenny

  10. #25
    Join Date
    June 2009
    Location
    Germany
    Posts
    14
    TS Support Team, pls help

    my Server crashs 6 times today -.-

    unsing beta12 too and debian lenny

    und @ Cheech
    ne, das passiert auch ohne das der Fehler kommt

  11. #26
    Join Date
    November 2002
    Location
    Spain
    Posts
    6
    After several days running, yesterday at night my server crush with same error as yours. I'm running beta11 y a Debian amd64. The permissions in directory application are ok, someone has a respond to fix this? any ideas...

  12. #27
    Join Date
    June 2009
    Location
    Germany
    Posts
    14
    i think the problem is screen ...
    all users who have this problem, are unsing screen.

    Yesterday is have start my Server with a Start script from this TS Forum.

    He is running now für 10 hours... without a crash.

    i hope this was the reason, and my server still runs

  13. #28
    Join Date
    December 2009
    Location
    germany
    Posts
    13
    i run the server only under screen and my server has crash 2 day ago first

    i think not the problem is screen

  14. #29
    Join Date
    June 2009
    Location
    Germany
    Posts
    14

    Angry

    yeah right!

    it crashes today again, an i started it without screen ....

    strange

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: May 11th, 2012, 11:43 AM
  2. Server 'Critical Error'
    By Broughton in forum Windows
    Replies: 1
    Last Post: September 28th, 2010, 06:16 AM
  3. Server Beta 23 Critical Error
    By Skjlkfd in forum Server Support
    Replies: 1
    Last Post: July 8th, 2010, 11:24 AM
  4. Server Chrash with Critical Error
    By Polli in forum Linux / FreeBSD
    Replies: 3
    Last Post: January 6th, 2010, 11:47 AM
  5. Server shut down critical error
    By Inktpotje in forum Linux / FreeBSD
    Replies: 0
    Last Post: December 22nd, 2009, 04:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •