Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    December 2009
    Location
    UK
    Posts
    5

    Few possible bugs/errors/omissions

    Not sure if this is the best place to post these so can you direct me to where the best place is if its not... thanks.

    Loving the new TS3... big improvement over TS2.

    Few issues I've come accross:

    1) Working in the client as server admin I 've been setting up some server groups on the permissons box. I've added a new server group and gone through adding all the permissions for the group but there is NO option in the permissions list that allows me to give members of the group the ability to turn on or off the "Priority Speaker" option when right clicking on someones name.

    2) When using the app scanner - some apps are listed in german when displayed in the client information window - like the calculator -" Windows Rechner" or the Nvidia display control panel - "NVIDIA Systemsteuerung"

    3) Is there a way to disable the notifications like:

    <11:12:20> You subscribed to channel "Blah Blah"... each time you log in. If you have 30 or 40 channels in TS you just get a massive long list of chnnels you subscribed to. This in itself is not really an issue except for 2 things:

    a) The connection info and welcome messages are no longer visible to people that have just joined as the text has been pushed up the list which mean people have to scroll back through all the "you subscribed to..." text to see the welcome message etc.

    b) When leaving someone an offline message for them to get when they sign on to teamspeak, they sign in and get this message:

    <11:31:30> You have 1 unread offline message

    but because it comes before all the " You subscribed to channel ...." messages people no longer see the offline message notification which means that they always miss it. It would be better if the "you have 1 unread off line message" notification came after all the "you subscribed" messages - so that it was visible.

    The order of messages when joining the server would be better as:

    <11:31:25> Connecting to server 89.42.110.40:316
    <11:31:26> Connected to server: Welcome to the Teamspeak 3 Server
    <11:31:31> You subscribed to channel "Channel 1"
    <11:31:31> You subscribed to channel "Channel 2"
    <11:31:31> You subscribed to channel "Channel 3"
    <11:31:31> You subscribed to channel "Channel 4"
    <11:31:26> Welcome to TeamSpeak, check www.teamspeak.com for latest infos. <<< This message moved to third last after all the "you subscribed messages to"
    <11:31:26> This is a test HOST message - Hello <<< This message moved to second last after all the "you subscribed messages to"

    <11:31:30> You have 1 unread offline message <<< This message moved to last after all the "you subscribed messages"


    4) Finally: I clicked on Edit Virtual Server in the client window. I changed the host message and clicked apply... all members that joined after that came in with SA permissions instead of the member group they had been assigned to through the use of a ticket. I assume this has something to do with the Default groups on the Misc tab. Also when changing the Default Server Group to guest on this misc tab - which I assumed would assign new members joining as guests - it then removed all SA permissions from everyone including myself meaning now that there is no way to be able to admin the server as no one - not even someone who used an SA ticket - is an admin anymore.... surely this is a flaw?

    How can this be corrected and restore my SA permissions without reinstalling the server?


    Well that's it for now. Liking the software except for these little things (SA error not so little though).


  2. #2
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    about part 4. if you setted default server group to serveradmin its obvious that all members will be removed and when you set it back you better have a token ready.
    its normal behaviour to me.

  3. #3
    Join Date
    December 2009
    Location
    Taiwan
    Posts
    313
    I believe that it is possible to generate a token with the serverquery

    need to look up the commands for it, be back at you later

  4. #4
    Join Date
    December 2009
    Location
    Taiwan
    Posts
    313
    Back, tested and confirmed to work.

    full code below

    Code:
    login serveradmin <passwordhere>
    serverlist
    use sid=<your server's id number, default is 1>
    servergrouplist
    tokenadd tokentype=0 tokenid1=<your serveradmin group, default is 6> tokenid2=0
    by doing so, you should be able to generate a server admin token for you to get your rights back

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 Bugs und Verbesserungsvorschläge (Bugs and Suggestions)
    By sp33dlink in forum Suggestions and Feedback
    Replies: 17
    Last Post: January 12th, 2010, 04:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •