Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 10 of 10

Thread: ts3server.ini

  1. #1
    Join Date
    December 2009
    Location
    London UK
    Posts
    28

    ts3server.ini

    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead


    ive used the crateini=1 thinggy command and it has made the ini file.
    when ever i edit download and edit the file and reupload it to the server vir ftp <tyyed binary and asii> the server just ignores it when im starting the server it just loads the server on the default port. what i am i doing wrong

    im trying to edit the server ip/port

    Code:
    machine_id=
    default_voice_port=8801
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    dbplugin=ts3db_mysql
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=0
    //EDIT1

    Starting command ./ts3server_linux_x86 dbplugin=ts3db_mysql
    im prob missing something from the starting command

    os is
    its Fedora release 7 (Moonshine)

    servers starting norm no issues with starting and that and yes ive cmod the folder
    Last edited by florian_fr40; November 10th, 2011 at 03:46 PM.

  2. #2
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    what is your start command ?

    which os ansd version ?

    ls -l ?

    Cheech

  3. #3
    Join Date
    December 2009
    Location
    London UK
    Posts
    28
    replyed

  4. #4
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    try

    ./ts3server_linux_x86 dbplugin=ts3db_mysql inifile=ts3server.ini &

    to see what happens:
    screen -r

    to go out of the screen press STRG +A+D

    or try 1st without & at the end.

    Cheech

  5. #5
    Join Date
    December 2009
    Location
    London UK
    Posts
    28
    [email protected] [~/TS3]# ./ts3server_linux_x86 dbplugin=ts3db_mysql nifile=ts3server.ini
    Logging started
    2009-12-30 19:28:32.005390|INFO |ServerLibPriv | | Server Version: 3.0.0-be ta11 [Build: 9559]
    2009-12-30 19:28:32.006987|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-30 19:28:32.007081|INFO |DatabaseQuery | | dbPlugin version: 1
    2009-12-30 19:28:32.012191|ERROR |DatabaseQuery | | mysql_real_connect() fai led with error: Access denied for user 'root'@'localhost' (using password: NO)
    2009-12-30 19:28:32.012308|CRITICAL|ServerLibPriv | | Server() DatabaseError
    [email protected] [~/TS3]# ./ts3server_linux_x86 dbplugin=ts3db_mysql
    Logging started
    2009-12-30 19:28:56.470915|INFO |ServerLibPriv | | Server Version: 3.0.0-be ta11 [Build: 9559]
    2009-12-30 19:28:56.473016|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-30 19:28:56.473271|INFO |DatabaseQuery | | dbPlugin version: 1
    2009-12-30 19:28:57.353811|INFO |Accounting | | Licensing Information
    2009-12-30 19:28:57.354865|INFO |Accounting | | type : Non- profit
    2009-12-30 19:28:57.355555|INFO |Accounting | | starting date : Sun Dec 20 16:00:00 2009
    2009-12-30 19:28:57.356027|INFO |Accounting | | ending date : Mon Dec 20 16:00:00 2010
    2009-12-30 19:28:57.356472|INFO |Accounting | | max virtualservers: 10
    2009-12-30 19:28:57.356903|INFO |Accounting | | max slots : 512
    2009-12-30 19:28:57.391468|INFO |FileManager | | listening on 0.0.0.0:300 33
    2009-12-30 19:28:57.460784|INFO |VirtualServer | 1| listening on 0.0.0.0:998 7
    2009-12-30 19:28:57.461894|INFO |Query | | listening on 0.0.0.0:100 11


    O.o?

  6. #6
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    did you create a database ?

    please post your ts3mysql.ini

    and on your line dbpluginparameter= ist empty.

    Must be:
    dbpluginparameter=ts3db_mysql.ini

    But if you don't know how to create new db in mysql then change it to sqlite and it will be working.

    cheech

  7. #7
    Join Date
    December 2009
    Location
    London UK
    Posts
    28
    server is working with mysql and i want to mysql >.> easyer for maintaining the server ^.^

    [config]
    host=localhost
    port=3306
    username=username_username
    password=tspas
    database=username_TS3
    socket=
    thats the msq.ini file
    witch will load the server with the command
    ./ts3server_linux_x86 dbplugin=ts3db_mysql

    ....

    keep geting db connect issues with the ./ts3server_linux_x86 dbplugin=ts3db_mysql nifile=ts3server.ini command
    evan tryed ./ts3server_linux_x86 nifile=ts3server.ini with no love >.>


    ts3server.ini
    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=0

  8. #8
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    ähm the "i" is missing at inifile=

    and you must have a blank line after the values in your ini files

    and database=username_TS3 must be the dbname not username

    and it's not needed to start the server with dbplugin=ts3db_mysql
    because the server run the ts3server.ini and over the lines
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini

    the server will automaticly run the correct plugin and also the mysql ini file.

    On my server is works without issue since the 1st beta.

    cheech

  9. #9
    Join Date
    December 2009
    Location
    London UK
    Posts
    28
    [~/TS3]# ./ts3server_linux_x86 inifile=ts3server.ini
    Logging started
    2009-12-30 19:55:18.690246|INFO |ServerLibPriv | | Server Version: 3.0.0-beta11 [Build: 9559]
    2009-12-30 19:55:18.691076|CRITICAL|DatabaseQuery | | unable to load database plugin library, halting!

    your most porb useing sqllite im useing mysql and ty for point out the missing i and get this

  10. #10
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    1 more fault found:

    dbsqlcreatepath=create_sqlite/ must be
    dbsqlcreatepath=create_mysql/

    and try again

    and i'm using also mysql.

    cheech

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] ts3server.pid
    By Eagleman in forum Linux / FreeBSD
    Replies: 10
    Last Post: January 29th, 2015, 04:11 PM
  2. Replies: 12
    Last Post: August 12th, 2014, 12:03 PM
  3. Move Server without ts3server.ini to configured ts3server.ini
    By EuReKa-LoS in forum Linux / FreeBSD
    Replies: 6
    Last Post: March 7th, 2013, 03:56 PM
  4. ts3server
    By luigi271 in forum Off Topic
    Replies: 2
    Last Post: October 16th, 2010, 11:22 AM
  5. ts3server.pid
    By Buggel in forum Linux / FreeBSD
    Replies: 0
    Last Post: March 19th, 2010, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •