Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    December 2009
    Location
    Ft. Worth, TX
    Posts
    2

    Question TS3 Server Listening on Wrong IP (0.0.0.0)

    Here is a copy of my server log file:

    12/29/2009 9:16:20 PM Accounting Info Licensing Information
    12/29/2009 9:16:20 PM Accounting Info type : Non-profit
    12/29/2009 9:16:20 PM Accounting Info starting date : Mon Dec 21 18:00:00 2009
    12/29/2009 9:16:20 PM Accounting Info ending date : Tue Dec 21 18:00:00 2010
    12/29/2009 9:16:20 PM Accounting Info max virtualservers: 10
    12/29/2009 9:16:20 PM Accounting Info max slots : 512
    12/29/2009 9:16:20 PM FileManager Info listening on 0.0.0.0:30033
    12/29/2009 9:16:20 PM VirtualServer Info listening on 0.0.0.0:9987
    12/29/2009 9:16:20 PM Query Info listening on 0.0.0.0:10011

    I can access my server on port 9987 (default) but I cannot access my 2nd virtual server on port 9997 (shown on serverlist query). How do I get the server to listen to my IP address (I tried inifile on the command line but still not listening on my IP)? Thanks in advance!

  2. #2
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    Quote Originally Posted by XS>BulletTrap View Post
    I can access my server on port 9987 (default) but I cannot access my 2nd virtual server on port 9997 (shown on serverlist query). How do I get the server to listen to my IP address (I tried inifile on the command line but still not listening on my IP)? Thanks in advance!
    by default the server binds to all ip addresses. try deleting virtual server 2 and redoing it. it could be that you mis-typed the port

  3. #3
    Join Date
    December 2009
    Location
    Ft. Worth, TX
    Posts
    2

    Question

    Deleted server and then recreated server but still cannot access server even though serverlist shows the 2nd virtual server running and online (port now 9989 with a sid=9). The server is running through a Go Daddy account if that helps any. Why can I access our server at port 9987 and not port 9989? Thanks for any help or suggestions.

  4. #4
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    Quote Originally Posted by XS>BulletTrap View Post
    Deleted server and then recreated server but still cannot access server even though serverlist shows the 2nd virtual server running and online (port now 9989 with a sid=9). The server is running through a Go Daddy account if that helps any. Why can I access our server at port 9987 and not port 9989? Thanks for any help or suggestions.
    could you post the ip so i can try to connect? maybe you should try it with a different port say 9988

  5. #5
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    Quote Originally Posted by XS>BulletTrap View Post
    Here is a copy of my server log file:

    12/29/2009 9:16:20 PM Accounting Info Licensing Information
    12/29/2009 9:16:20 PM Accounting Info type : Non-profit
    12/29/2009 9:16:20 PM Accounting Info starting date : Mon Dec 21 18:00:00 2009
    12/29/2009 9:16:20 PM Accounting Info ending date : Tue Dec 21 18:00:00 2010
    12/29/2009 9:16:20 PM Accounting Info max virtualservers: 10
    12/29/2009 9:16:20 PM Accounting Info max slots : 512
    12/29/2009 9:16:20 PM FileManager Info listening on 0.0.0.0:30033
    12/29/2009 9:16:20 PM VirtualServer Info listening on 0.0.0.0:9987
    12/29/2009 9:16:20 PM Query Info listening on 0.0.0.0:10011

    I can access my server on port 9987 (default) but I cannot access my 2nd virtual server on port 9997 (shown on serverlist query). How do I get the server to listen to my IP address (I tried inifile on the command line but still not listening on my IP)? Thanks in advance!
    0.0.0.0 is an alias to "every IP in system".
    It just can't be wrong in the terms that you are using.
    Please show results of "netstat -aon"

  6. #6
    Join Date
    December 2009
    Location
    Wangaratta
    Posts
    9

    Talking

    I had the same problem too. The below solved it.

    ts3server_win32.exe voice_ip=118.127.10.168 query_ip=118.127.10.168 filetransfer_ip=118.127.10.168

    The port is 9988 by default, I think you should be able to change this.

    I run a dedicated server with 4 dedicated IP's assigned to it.

    Hope this helps
    Nath

  7. #7
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    start your server with createinifile=1
    then stop it
    edit your ts3server.ini
    start server again with inifile=ts3server.ini

    cya
    cheech

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 Server not listening on UDP port
    By LukeK in forum Linux / FreeBSD
    Replies: 3
    Last Post: July 5th, 2015, 09:52 PM
  2. Replies: 1
    Last Post: March 23rd, 2013, 10:07 AM
  3. [Resolved] TS3 Server Stuck At listening
    By Spirit SF in forum Linux / FreeBSD
    Replies: 3
    Last Post: February 12th, 2012, 05:35 PM
  4. Server listening normaly but client login problem
    By sholverstar in forum Linux / FreeBSD
    Replies: 1
    Last Post: September 2nd, 2011, 08:12 AM
  5. Server isn't listening on External IP
    By Sheep190 in forum Windows
    Replies: 4
    Last Post: December 22nd, 2009, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •