Page 11 of 11 FirstFirst ... 91011
Results 151 to 163 of 163
  1. #151
    Join Date
    March 2016

    Teamspeak server on an Orange Pi

    Hello everyone,

    Recently I got myself an Orange Pi (a cheap version of the Raspberry Pi) and I've been playing around with it for a bit. I thought it would be pretty cool if I could get a teamspeak server running on it, so I started trying to set it up. Trough ssh I installed the 32 bit version of the linux server and unpacked everything. I tried running the command './ start' to start the server, but I got an error, picture here:
    Name:  Capture.PNG
Views: 7862
Size:  7.5 KB

    So I was wondering if anyone knows something about this error? And if it's even possible to run a Teamspeak server on this device?
    The OS I'm running is Ubuntu (Mate) version 15.04, which seems to be the only thing it can actually run.

  2. #152
    Join Date
    December 2011

    TeamSpeak3 Server running on Raspberry Pi2 and 3 *confirmed working*

    I installed the newest TeamSpeak3 Server on my Raspberry Pi 2 and 3. Everything works perfectly. We connected with 27 users and 2 music bots.

    Follow the instuctions in the link bellow how to get this puppy working
    Last edited by Chris; May 31st, 2016 at 08:37 AM.

  3. #153
    Join Date
    May 2016

    It's still emualted

    Quote Originally Posted by Jomant View Post
    I installed the newest TeamSpeak3 Server on my Raspberry Pi 2 and 3. Everything works perfectly. We connected with 27 users and 2 music bots.

    Follow the instuctions in the link bellow how to get this puppy working
    Using this guide will install an x86 emualtor, which will need more power then really necessary.. so an ARM build of teamspeak 3 would be really nice!

  4. #154
    Join Date
    June 2016
    Yes it would be a nice thing if the development team would support the ARM micro computers as well. With the Raspberry Pi, Banana Pi, and all the other credit card sized ARM Linux computers that are dirt cheap you can't beat the price.

    Then you have the Raspberry Pi Zero that is $5. So the thing is now why not make a ARM based distro of Teamspeak 3 server. That would be one cheap Teamspeak server right there.

    Please Dev Team.

  5. #155
    Join Date
    June 2016

    Arm would be very nice

    Using a raspberry pi for a ts server would be very green not to mention cheap.

  6. #156
    Join Date
    February 2016

    Lightbulb Any chance we get ARM version of TS3 server?

    Hi, I'm sure this has been asked by other users as well but whatever. Anyway, I'm looking into getting a single board computer for server purposes. Raspberry Pi looks like a good candidate. But as a teamspeak3 user, I would like to be able to run TS3 server on my pi.

    low power consumption
    low cost hardware
    no need to purchase an expensive x86 hardware for this, (specially no need to buy some old PCs for cheap for this since old PCs can draw lots of power)

    Now I am well aware of the fact that it's possible to use emulators, but that just defeats the purpose. ExaGear Desktop is not free, that defeats the low cost purpose. Using emulators in general will require more CPU power to emulate the x86 architecture, so high cpu usage, pi heating up, needing to purchase additional heat-sink and fan (chances are, the fan can draw more power than the pi it self) and etc. You get the point. And ts3 isn't open-source (wish it was) so nobody else can compile/port it for ARM.

    So it makes sense for there to exist an ARM version of the server. Any chance we can get an ARM version of TS3 server? and TS3 client as well (want server the most)? pretty please? is it difficult to port the server to ARM architecture? any reason you might "not have plans for this"/slap [rejected] onto this topic? what will it take you to make an ARM version?
    On raspberry pi forums, I saw a thread asking how to run it on pi back from 2012, that's like 4 years now.

    EDIT: Looks like the mod merged my post into this topic. Still, I would prefer if they taked my post seriously and gave me a reason. Whatever. I'm nobody. ARM servers are a thing, and it's kinda sad they have no plans for this.
    Last edited by Kyuunex; July 29th, 2016 at 11:25 PM.

  7. #157
    Join Date
    June 2008
    You are not nobody, but we stated several times in this thread (starts post #1 and last time #143) that ARM is not planned to be added.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #158
    Join Date
    August 2016
    WTB TeamSpeak3 Server for ARM !

  9. #159
    Join Date
    September 2016

    TS3 server working with QEMU 2.7


    just a quick heads up: The new QEMU release 2.7.0 can successfully emulate at least TeamSpeak 3 Server (x86) in user mode. Newer versions of Teamspeak yield to an error from QEMU (see

    As of now there are no official binary packages for QEMU 2.7.0 (at least for Debian or Ubuntu). Thus QEMU has to be compiled manually.

    1. Compile and install QEMU 2.7.0
    sudo apt-get build-dep qemu
    mkdir qemu-2.7.0/build
    cd qemu-2.7.0/build
    ../configure --target-list=i386-linux-user 2>&1 |tee configure.log
    make -j4 2>&1 |tee build.log
    sudo make install
    2. Obtain TeamSpeak 3 Server (x86)
    tar xjvf teamspeak3-server_linux_x86-
    3. Modifiy for ease of use
      - ./ts3server [email protected]
      + /usr/local/bin/qemu-i386 ./ts3server [email protected]
    4. Execute ./

    Wait for 6 Minutes until teamspeak server started. QEMU saturates the cpu while Teamspeak is precomputing a puzzle. (Whatever that means)

    After that Teamspeak settles with the following output:
      2016-09-03 10:50:59.555582|INFO    |Query         |   |listening on, :::10011
    The Qemu process is idling with ~10% cpu load on my Cubietruck.

    Best regards,

  10. #160
    Join Date
    March 2014
    I've been running a rpi 2 since February with the eltechs emulator and it has been flawless. I've had up to 55 people connected and not had a single issue... well one time I had an issue with the emulator licensing, but it was fixed in about an hour.

    I also purchased a ~$15 10,000 mAh battery pack, if ever a power blip it'll be good for a few hours. If you chose this route, make sure to get one that can charge and provide power at the same time.

  11. #161
    Join Date
    September 2016
    Quote Originally Posted by tquin View Post

    just a quick heads up: The new QEMU release 2.7.0 can successfully emulate at least TeamSpeak 3 Server (x86) in user mode. Newer versions of Teamspeak yield to an error from QEMU (see

    I ran into some errors whilst following your instructions on how to get a working TeamSpeak Server on my Raspberry Pi 2.
    The problem seems to be in the 'make -j4 2>&1 |tee build.log' part. When executing said command, I'm constantly getting this error:

    /home/pi/qemu/qemu/pixman/pixman/pixman-mmx.c:3812:1: internal compiler error: Max. number of generated reload insns per insn is achieved (90)
    I'm getting some other errors from pixman, but this one's abandoning the command.

    Any idea on what to do?

  12. #162
    Join Date
    November 2016

    ARM support?

    Is there any way to get ARM support without simulating x86 with 3rd party programs? (didn't find anything on google but maybe there's a beta or something..?)

    I want to install a server on my Raspberry Pi...
    Last edited by dante696; November 4th, 2016 at 08:19 AM. Reason: merged

  13. #163
    Join Date
    October 2018

    Teamspeak version for ARM (not only for Raspberry PI)

    I know there is additional software that can make it posible to run x86 programs on ARM processors.

    But in this days, there are more offers of the dedicated servers and VPS servers wich run on ARM.
    It's hard to find some forum topic about this.
    Is there a posibility to get native version of Teamspeak running on ARM servers?
    Last edited by dante696; October 21st, 2018 at 06:58 PM. Reason: merged

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 18
    Last Post: April 20th, 2011, 11:34 PM
  2. Issues moving TS3 server from 32-bit linux to 64-bit linux
    By DreamPhysix in forum Linux / FreeBSD
    Replies: 1
    Last Post: March 10th, 2011, 08:43 AM
  3. Linux server install for low-skill-in-linux-terminal guy
    By flakz0r in forum Linux / FreeBSD
    Replies: 5
    Last Post: December 30th, 2010, 09:03 AM
  4. Replies: 0
    Last Post: February 24th, 2010, 05:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts