Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Join Date
    October 2009
    Location
    Germany
    Posts
    23

    Lua Kick Script Clients with Version < last Version

    Is there a way to kick clients that not has the last version?

    Maybe a Lua Script? But i cant write Lua... Anyone able to do this for me, please?

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    8
    yeah that would be nice

  3. #3
    Join Date
    April 2007
    Location
    Germany
    Posts
    98
    I will have a look at it

    I'll report in today evening I think.

    Stay tuned.


    EDIT:

    Script is ready now!

    http://rapidshare.com/files/330455241/versionKicker.lua

    Informations
    • How to install?
      • Copy the file called "versionKicker.lua" to your scripts directory
      • Should be something like "C:\Program Files\Teamspeak 3 Client\scripts"

        If you do not want to change anything in your "ts3events.lua" just STOP HERE!
        You have to type "/lua load versionKicker.lua" everytime you restart your client, nothing else is different from the version below.
        If you are able to change it and not afraid of using your notepad, then go on and save some time in the future
      • Open the file called "ts3events.lua" with notepad or any other editor
      • Line 9-11 should look like that:
        Code:
        require("ts3defs")    -- Required
        require("ts3errors")  -- Required
        require("custom")     -- Demonstration and testing. Load this here to avoid having to "/lua load custom.lua" in the client.
      • Add the following line AT THE END OF THE FILE:
        Code:
        require("versionKicker")
      • It should look like that after you added the lines:
        Code:
        ts3.urlsToBB(textWithURLs) > bbCodeText
        
        ]]--
        
        
        require("versionKicker")
        ----------------------------------------------------
      • Start teamspeak as usual
    • How to use?
      • You can run the script on your own by typing "/lua run versionKicker"
      • But the script is also automatically kicking old versions in intervals


    03.01.2010 21:43 Uhr UPDATE:
    *did some changes to prevent (public) server from banning you because of spam

    05.01.2010 02:05 Uhr UPDATE:
    *again some improvements for getting a ban because of spam
    *possible fix for some malfunctions
    *PLEASE MAKE SURE YOU HAVE ENOUGH RIGHTS TO KICK SOMEONE!
    *Scripts is way not finished...
    Last edited by Lil-rich; January 5th, 2010 at 01:06 AM.

  4. #4
    Join Date
    October 2009
    Location
    Germany
    Posts
    23
    realy nice, thank you!

  5. #5
    Join Date
    December 2009
    Location
    Germany
    Posts
    4
    Arrgs rapidshare took 30mins ... for 4kb!!

  6. #6
    Join Date
    August 2005
    Location
    Nederland
    Posts
    56
    It says;

    Code:
    Invalid command: /lua run versionKick
    When running '/lua run versionKick'

  7. #7
    Join Date
    April 2007
    Location
    Germany
    Posts
    98
    Quote Originally Posted by Hollanda View Post
    It says;

    Code:
    Invalid command: /lua run versionKick
    When running '/lua run versionKick'
    If I remember correct the correct command is "/lua run versionKicker", sorry Changed it above...


    @all others: Thanks! I am glad if I could help you

  8. #8
    Join Date
    August 2005
    Location
    Nederland
    Posts
    56
    Code:
    Invalid command: /lua run versionKicker

  9. #9
    Join Date
    January 2010
    Location
    Poland
    Posts
    8
    Code:
    Error running Lua function 'versionKicker.lua': attempt to call a nil value

  10. #10
    Join Date
    September 2005
    Location
    Sweden
    Posts
    26
    You have to enable the LUA plugin.

  11. #11
    Join Date
    September 2005
    Location
    Sweden
    Posts
    26
    <14:22:26> "Raaf" was kicked from the server by "Ernesto" (UPDATE YOUR CLIENT!)
    <14:22:26> invalid clientID
    <14:22:26> invalid clientID

    Get that invalid clientID spam all the time when someone is kicked

  12. #12
    Join Date
    January 2010
    Location
    Poland
    Posts
    8
    Quote Originally Posted by Ernesto View Post
    You have to enable the LUA plugin.
    Disabled Lua Plugin:
    Code:
    Invalid command: /lua run versionKicker
    Enabled Lua Plugin:
    Code:
    Error running Lua function 'versionKicker.lua': attempt to call a nil value
    Client version: Beta9
    Server version: Beta12

    /BTW:
    try use
    Code:
    /lua run
    command
    Last edited by antihrist; January 4th, 2010 at 04:49 PM.

  13. #13
    Join Date
    April 2007
    Location
    Germany
    Posts
    98
    A new version is coming tonight with some bugfixes.

    It's not perfect but works much better. I am still working on a fix for the problem if you don't have enough rights to kick someone (e.g. if you are not able to kick someone or if the person has a higher needed kickpower etc.)

    I dunno why my array isn't working as expected But I'll fix that asap...

  14. #14
    Join Date
    January 2010
    Location
    Poland
    Posts
    8
    sometimes
    Code:
    <19:50:29> "Bekflip" is now known as ""
    <19:50:30> "" kicked from the server by "Antihrist" (Update Teamspeak!!)
    and starts chat with "" user

    //edit:
    Client Log:
    Code:
    2010-01-04 21:25:10.972263	ClientUI	Warning	Error requesting client variables: 1796
    Last edited by antihrist; January 4th, 2010 at 08:47 PM.

  15. #15
    Join Date
    April 2007
    Location
    Germany
    Posts
    98
    Check your rights management (after you downloaded the new version)


    /UPDATE

    Please report back in what goes wrong. And make sure you have enough rights to kick/write private messages...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Not Supported] [HELP] Plugin Check version, Set Version =/ Kick
    By SkinnyBruv in forum Tools / Web Based
    Replies: 2
    Last Post: October 20th, 2015, 01:02 PM
  2. Non registered User with Exploit can Kick - Version 3.0.6.1
    By Katsuhiko in forum General Questions
    Replies: 3
    Last Post: November 29th, 2012, 05:17 PM
  3. Little Windows Version post script
    By Sanji008 in forum Tools / Web Based
    Replies: 5
    Last Post: January 3rd, 2010, 07:06 PM
  4. Permit low-version clients to connect?
    By Polli in forum Permission System
    Replies: 1
    Last Post: December 30th, 2009, 07:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •