Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    August 2002
    Location
    London
    Posts
    1

    ts3server_linux_amd64 ignoring all input parameters?

    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead



    Hi,

    I've installed the ts3server_linux_amd64 version of ts3 (Server 64-Bit 3.0.0-beta12)

    I'm trying some basic input parameters

    ts3server_linux_amd64 default_voice_port=6689

    ts3server_linux_amd64 initfile=ts3server.ini

    No matter what I use I always get the default (same as not running any parameters). Anybody got the 64 bit version running with an ini file ? Mine does not seem to work and I always see examples of x32 versions.

    This is the output:

    2010-01-02 18:02:14.041521|INFO |ServerLibPriv | | Server Version: 3.0.0-beta12 [Build: 9596]
    2010-01-02 18:02:14.042000|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-01-02 18:02:14.042112|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-01-02 18:02:14.166359|INFO |Accounting | | Licensing Information
    2010-01-02 18:02:14.171602|INFO |Accounting | | type : Non-profit
    2010-01-02 18:02:14.173342|INFO |Accounting | | starting date : Fri Jan 1 23:00:00 2010
    2010-01-02 18:02:14.175456|INFO |Accounting | | ending date : Sat Jan 1 23:00:00 2011
    2010-01-02 18:02:14.177631|INFO |Accounting | | max virtualservers: 10
    2010-01-02 18:02:14.179778|INFO |Accounting | | max slots : 512
    2010-01-02 18:02:14.252574|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-01-02 18:02:14.332452|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    2010-01-02 18:02:14.334205|INFO |Query | | listening on 0.0.0.0:10011


    Thanks,
    Last edited by dante696; February 21st, 2011 at 12:29 PM.

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    28
    Quote Originally Posted by testlab View Post
    ts3server_linux_amd64 initfile=ts3server.ini
    I use the inifile, your syntax is wrong, to use the inifile try the following: ts3server_linux_amd64 inifile=ts3server.ini

    Before, you should use ts3server_linux_amd64 createinifile=1, to create a new inifile.

  3. #3
    Join Date
    December 2009
    Location
    HH
    Posts
    18
    Not all input parameters but "default_voice_port" by commandline or via inifile seems to get ignored.

    I use inifile=ts3server.ini after I have created it with createinifile=1
    and changed the default_voice_port and all three IPs but the port is been completly ignored and the server is always starting on default 9987.
    /Edit: the Port I choose is free of course.
    The IPs are just working fine.
    Vers. Linux beta 12 64Bit
    Last edited by Tris-HH; January 3rd, 2010 at 07:30 PM.

  4. #4
    Join Date
    January 2010
    Location
    Germany
    Posts
    2
    I have the same problem as you guys in changing the voice ports.

    If i use the command ./ts3server_linux_x86 inifile=ts3server.ini it doesnt work
    and not even ./ts3server_linux_x86 default_voice_port=63739 works.
    The programm is still using Port 9987.

    I even checked if my ini file is Windows editor corrupted and it isnt.
    I started manually ./ts3server_linux_x86 inifile=ts3server.ini it shows the ip i saved as listening port in the ini file instead 0.0.0.0:9987.

    Is this now a linux newbie error or is it a bug in the server that doesnt acceptany port change?

    MFG
    MrFriday

  5. #5
    Join Date
    December 2009
    Location
    HH
    Posts
    18
    Seems to be a bug.
    That was working already on my server even on newest beta 12. But I had some different problems, so I had to do a clean and new install of the server.
    The other porblems are gone and this one is new to me.
    Before I updated every beta since.
    But a fresh install of beta 12 seems to create that bug.

  6. #6
    Join Date
    January 2010
    Location
    Germany
    Posts
    28
    Important is, that you leave a blank line at the bottom of the configuration file!

    Make sure, you open the config file with wordpad, otherwise it wouldn't save it correct.

  7. #7
    Join Date
    December 2009
    Location
    HH
    Posts
    18
    blank line is there. I just change the three IPs and only one port on the autom. created (createinifile=1) inifile

    But after I deleted the sqlitedb (was a fresh install anyway) it's working and my default_voice_port is read out of the inifile now.
    I don't get it.
    I almost tried to do it by query/telnet with "serveredit virtualserver_port=.... "

    Anyway, thanks for your help. Who knows what the problem was.

  8. #8
    Join Date
    January 2010
    Location
    Germany
    Posts
    2
    Your right. I "accidently" deleted the database that teamspeak created and manualy started Teamspeak with the "inifile=...." again and voila. It finally accepted it.

    Maybe the port is beeing saved in the database and the database itself has the highest priority for the settings of the server. I think everything else will be be ignored.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ignoring music
    By Meganeura in forum General Questions
    Replies: 4
    Last Post: June 29th, 2013, 06:37 PM
  2. ./ts3server_linux_amd64: No such file or directory
    By MattG in forum Linux / FreeBSD
    Replies: 5
    Last Post: June 3rd, 2011, 08:58 PM
  3. [Resolved] ./ts3server_linux_amd64: No such file or directory
    By fischer1990 in forum Server Support
    Replies: 7
    Last Post: February 23rd, 2011, 03:17 PM
  4. Server ignoring the whitelist?
    By cembry90 in forum Server Support
    Replies: 6
    Last Post: July 30th, 2010, 07:54 AM
  5. Contact Ignoring You
    By xcalibur in forum Suggestions and Feedback
    Replies: 4
    Last Post: January 27th, 2010, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •