Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 4 of 5 FirstFirst ... 2345 LastLast
Results 46 to 60 of 65
  1. #46
    Join Date
    January 2010
    Location
    Az
    Posts
    5
    Quote Originally Posted by naitsirk View Post
    Which distribution do you use? And what version are you talking about?

    The version in Linux Mint 8 repository is 0.9.19, latest version of PulseAudio was released 23/11 -09 and that was 0.9.21.
    ubuntu karmic 64, PA version 1.0.9.22 from https://launchpad.net/~ubuntu-audio-dev/+archive/ppa

  2. #47
    Join Date
    November 2009
    Location
    Dublin, Ireland
    Posts
    379
    Quote Originally Posted by FMOD_Mathew View Post
    For those interested in testing a hunch...

    Try editing "/etc/pulse/daemon.conf", modify "default-fragments" to a smaller number, perhaps 4. Also consider adjusting "default-fragment-size-msec" to something smaller, perhaps 5, or various combinations of the two settings.

    You will need to reboot / restart the PulseAudio daemon to apply the changes.

    Any feedback you guys can provide will be useful.
    i tried the values you recommended and one of my cores lit up to 100% and i could not speak or hear on teamspeak.

    Still not working.

  3. #48
    Join Date
    July 2006
    Location
    Sweden
    Posts
    76
    Quote Originally Posted by Unitas View Post
    ubuntu karmic 64, PA version 1.0.9.22 from https://launchpad.net/~ubuntu-audio-dev/+archive/ppa
    Did you just add:
    to your apt-source list and added the signing key and then did a update?

  4. #49
    Join Date
    December 2009
    Location
    Flroida
    Posts
    65
    Can we get word from anyone with fedora or mandriva. That way we can determine if its a kernel issue. After updating to the alpha (lucid 10.04) i have had no problems except occasionally my mic breaking up. After compile a custom kernel I realized that ubuntu has the kernel frequency to 100 mhz. After compiling my kernel with 1000 mhz kernel frequency I no longer have mic problems.

    So I propose that there be several problems.
    1. Pulse audio takes up 100% cpu with a endless loop ( Supposedly fixed with latest pulse update)
    2. Ubuntu's kernel frequency is set too low for more than 1 audio stream ( if you have any other program open it breaks either playback or input by not updating fast enough) <-- not positive on this one need help from people with other distros
    3. Maybe problem with fmod however unlikely.

    One thing I do have to complain about is the fact that I have to navigate to my TeamSpeak3 folder and then run the script. I use Teamspeak 3 because it is Linux native and highly customizable, While I can deal with it for now I hope that they fix it for linux soon.

  5. #50
    Join Date
    November 2009
    Location
    Dublin, Ireland
    Posts
    379
    Quote Originally Posted by Whinis View Post
    Can we get word from anyone with fedora or mandriva. That way we can determine if its a kernel issue. After updating to the alpha (lucid 10.04) i have had no problems except occasionally my mic breaking up. After compile a custom kernel I realized that ubuntu has the kernel frequency to 100 mhz. After compiling my kernel with 1000 mhz kernel frequency I no longer have mic problems.

    So I propose that there be several problems.
    1. Pulse audio takes up 100% cpu with a endless loop ( Supposedly fixed with latest pulse update)
    2. Ubuntu's kernel frequency is set too low for more than 1 audio stream ( if you have any other program open it breaks either playback or input by not updating fast enough) <-- not positive on this one need help from people with other distros
    3. Maybe problem with fmod however unlikely.

    One thing I do have to complain about is the fact that I have to navigate to my TeamSpeak3 folder and then run the script. I use Teamspeak 3 because it is Linux native and highly customizable, While I can deal with it for now I hope that they fix it for linux soon.

    from the FMOD forum:

    I think there is a buffering issue going on, the reason for the high CPU is the PulseAudio buffers are emptying and blocking so FMOD is having trouble recovering and filling. Changing the PulseAudio buffer size is one piece of the problem, but changing the FMOD buffer size to be large enough to satisfy PulseAudio is the other.

    I don't think there is an option for FMOD buffer sizes available in TS3 so we are following up the TeamSpeak guys to see if increasing the buffer fixes the starvation issue.

    We are hopeful that this issue can be resolved via buffer adjustment, but if not we will continue with our plan for a PulseAudio backend around mid March.
    http://www.fmod.org/forum/viewtopic....ba80e70a0edfc2

  6. #51
    Join Date
    February 2010
    Location
    Toronto
    Posts
    4
    Quote Originally Posted by Whinis View Post
    Can we get word from anyone with fedora or mandriva....
    I have Mandriva 2010.0 and I can confirm that I am having a problem with TeamSpeak 3 and it crashes my entire machine. I put on a related question on my distro's forum (here) as whenever TeamSpeak 3 would crash the caps lock light would flash and I later learned this meant a kernel panic. I will also be re-posting the system log before the crash onto this post if this helps a bit:

    1st try:
    Quote Originally Posted by /var/log/messages
    Feb 22 18:22:36 Mandriva rtkit-daemon[2238]: Sucessfully made thread 29512 of process 29512 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:22:36 Mandriva pulseaudio[29512]: pid.c: Daemon already running.
    Feb 22 18:22:38 Mandriva draksnapshot-applet[29553]: ### Program is starting ###
    Feb 22 18:22:38 Mandriva mdkapplet[29559]: ### Program is starting ###
    Feb 22 18:22:38 Mandriva net_applet[29562]: ### Program is starting ###
    Feb 22 18:22:42 Mandriva draksnapshot-applet[29553]: ### Program is exiting ###
    Feb 22 18:22:42 Mandriva mdkapplet[29559]: running: ionice -p 29559 -n7
    Feb 22 18:22:55 Mandriva pulseaudio[2236]: ratelimit.c: 43 events suppressed
    Feb 22 18:23:00 Mandriva pulseaudio[2236]: ratelimit.c: 27 events suppressed
    Feb 22 18:23:01 Mandriva CROND[31085]: (root) CMD ( /usr/share/msec/promisc_check.sh)
    Feb 22 18:23:05 Mandriva pulseaudio[2236]: ratelimit.c: 16 events suppressed
    Feb 22 18:23:15 Mandriva last message repeated 2 times
    Feb 22 18:23:20 Mandriva pulseaudio[2236]: ratelimit.c: 11 events suppressed
    Feb 22 18:23:45 Mandriva klogd: gvfsd-metadata[29737]: segfault at 8 ip 0804cbca sp bfbe15c0 error 4 in gvfsd-metadata[8048000+d000]
    Feb 22 18:25:14 Mandriva syslogd 1.5.0: restart.
    2nd try:
    Quote Originally Posted by /var/log/messages
    Feb 22 18:33:25 Mandriva rtkit-daemon[26476]: Sucessfully made thread 26474 of process 26474 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:33:25 Mandriva pulseaudio[26474]: pid.c: Stale PID file, overwriting.
    Feb 22 18:33:25 Mandriva rtkit-daemon[26476]: Sucessfully made thread 26494 of process 26474 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:33:25 Mandriva rtkit-daemon[26476]: Sucessfully made thread 26495 of process 26474 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:33:26 Mandriva rtkit-daemon[26476]: Sucessfully made thread 26498 of process 26498 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:33:26 Mandriva pulseaudio[26498]: pid.c: Daemon already running.
    Feb 22 18:33:27 Mandriva draksnapshot-applet[26516]: ### Program is starting ###
    Feb 22 18:33:28 Mandriva mdkapplet[26525]: ### Program is starting ###
    Feb 22 18:33:28 Mandriva net_applet[26527]: ### Program is starting ###
    Feb 22 18:33:30 Mandriva draksnapshot-applet[26516]: ### Program is exiting ###
    Feb 22 18:33:31 Mandriva mdkapplet[26525]: running: ionice -p 26525 -n7
    Feb 22 18:33:47 Mandriva pulseaudio[26474]: ratelimit.c: 1 events suppressed
    Feb 22 18:33:52 Mandriva pulseaudio[26474]: ratelimit.c: 43 events suppressed
    Feb 22 18:33:57 Mandriva pulseaudio[26474]: ratelimit.c: 26 events suppressed
    Feb 22 18:34:01 Mandriva CROND[28295]: (root) CMD ( /usr/share/msec/promisc_check.sh)
    Feb 22 18:34:02 Mandriva pulseaudio[26474]: ratelimit.c: 16 events suppressed
    Feb 22 18:34:08 Mandriva klogd: hda_codec: resetting BUS due to fatal communication error
    Feb 22 18:34:09 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29589 of process 29589 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:34:09 Mandriva pulseaudio[29589]: pid.c: Stale PID file, overwriting.
    Feb 22 18:34:09 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29604 of process 29589 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:34:09 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29605 of process 29589 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:34:15 Mandriva klogd: hda_codec: resetting BUS due to fatal communication error
    Feb 22 18:34:16 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29700 of process 29700 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:34:16 Mandriva pulseaudio[29700]: pid.c: Stale PID file, overwriting.
    Feb 22 18:34:16 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29710 of process 29700 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:34:16 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29717 of process 29700 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:34:22 Mandriva klogd: hda_codec: resetting BUS due to fatal communication error
    Feb 22 18:34:23 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29814 of process 29814 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
    Feb 22 18:34:23 Mandriva pulseaudio[29814]: pid.c: Stale PID file, overwriting.
    Feb 22 18:34:23 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29815 of process 29814 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:34:23 Mandriva rtkit-daemon[26476]: Sucessfully made thread 29819 of process 29814 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
    Feb 22 18:35:43 Mandriva syslogd 1.5.0: restart.
    Note: I know people have had problems with using ALSA; I've tried using my mic with OSS as I find there is no mic distortion but using OSS with TeamSpeak 3 also ends up with a crash on my machine just as ALSA does.

  7. #52
    Join Date
    February 2010
    Location
    U.S.
    Posts
    20
    I too use Mandriva 2010. I have disabled Pulse audio on my machine, and TS3 now runs fine.
    also I'd like to note that pulse audio does nothing for me anyhow, as everything else runs fine without it as well. I have this set up.

    Mandriva 2010
    KDE 4.4.0
    Hardware - Your card currently uses the ALSA "snd_intel8x0" driver (default driver for your card is "snd_intel8x0")

    kernel:
    Code:
    [[email protected] ~]$ uname -a
    Linux localhost 2.6.31.12-desktop-1mnb #1 SMP Tue Jan 26 03:35:36 EST 2010 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GNU/Linux
    [[email protected] ~]$ uname-r
    bash: uname-r: command not found
    [[email protected] ~]$ uname -r
    2.6.31.12-desktop-1mnb
    [[email protected] ~]$
    hehe did you notice my fail command? hahaha i'm retarded.




    OH! P.S. as far as the runscript problem.... I posted a work around here that does not involve editing the client:
    http://forum.teamspeak.com/showthread.php?t=50895
    its just a simple script.

    Marcus

  8. #53
    Join Date
    March 2010
    Location
    Germany
    Posts
    1

    problems _without_ pulseaudio

    Hi,
    I'm having several problems with TeamSpeak (3.0.0-beta16 [Build: 10314]),
    like 100% CPU usage, the program taking a long time to start (when running under gdb trying to debug the crash.. I guess thats an anti-debug feature? gdb even crashes after a while...). I do not use PulseAudio. It is not running and not even installed. The only PulseAudio related thing installed are the client libraries, but _not_ the pulse audio alsa plugin!

    This is on debian unstable, using

    00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

  9. #54
    Join Date
    November 2009
    Location
    Dublin, Ireland
    Posts
    379
    tested ubuntu 9.10 64bit
    beta pulse audio 1.0.9.22

    Still getting the the cpu hikes and audio drops.
    Last edited by azzy101; March 11th, 2010 at 12:08 AM.

  10. #55
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    Quote Originally Posted by azzy101 View Post
    tested ubuntu 9.10 64bit
    beta pulse audio 1.0.9.22

    Still getting the the cpu hikes and audio drops.
    terminal > pulseaudio -k
    start teamspeak 3

    done

    (to activate pulseaudio again, type "pulseaudio -D"

  11. #56
    Join Date
    November 2009
    Location
    Dublin, Ireland
    Posts
    379
    Quote Originally Posted by cr4wl View Post
    terminal > pulseaudio -k
    start teamspeak 3

    done

    (to activate pulseaudio again, type "pulseaudio -D"
    thanks.
    hopefully the pulseaudio backend for fmod will be developed soon.

  12. #57
    Join Date
    January 2010
    Location
    Melbourne, Australia
    Posts
    4
    Just so there isn't any confusion, we only plan to support a PulseAudio backend as a last resort. We have provided TeamSpeak with a potential solution that avoids need for the new backend, we are waiting on feedback before proceeding with any new development.

    I'll send a ping to the devs to try and get this issue wrapped up soon.

  13. #58
    Join Date
    December 2009
    Location
    Poland / Wrocław (Breslau)
    Posts
    15
    Quote Originally Posted by cr4wl View Post
    terminal > pulseaudio -k
    start teamspeak 3

    done

    (to activate pulseaudio again, type "pulseaudio -D"
    For me it's unacceptable. I'm streamming sound from my laptop to big speakers which are connected to a NetTop using PulseAudio over Wifi.

    I know writing Pulse backend is the last resort. But (I'm not completly sure) other backends are in minority (except ALSA). I don't know which distro supports OSS by default, same in case of E-sound. Pulse is future, at least in GNOME distros.

  14. #59
    Join Date
    March 2010
    Location
    Germany
    Posts
    2
    Hello there, I had the problem too, using ubuntu 9.10 64bit, WoW and TS3 Beta17. Nothing helped: .asound config files, sound buffers etc, stopping pulseaudio did not work, it was restarted every time. "pasuspend ts3client_runscript.sh" was not possible, TS3 could no longer connect to the server.

    Here's how I fixed it (runs for > 60min on a busy server right now), I used the source package for the alsa-pulseaudio plugin from the upcoming Ubuntu Release, Lucid, and compiled it for my own machine. This took ~200 MByte and some 20 Minutes.

    Steps to do the same, on a Commandline in an empty Directory:
    sudo aptitude install debootstrap
    sudo mkdir buildenvironment
    sudo debootstrap karmic buildenvironment
    sudo chroot buildenvironment
    export LANG=
    echo deb-src http://archive.ubuntu.com/ubuntu karmic main >> etc/apt/sources.list
    aptitude update
    aptitude install build-essential
    apt-get build-dep alsa-plugins
    echo deb-src http://archive.ubuntu.com/ubuntu lucid main >> etc/apt/sources.list
    aptitude update
    apt-get source alsa-plugins
    cd alsa-plugins-1.0.22
    dpkg-buildpackage -d
    exit

    After these steps (enter each line at the command line, one after the other) you should have
    (a) a complete ubuntu copy in a directory "buildenvironment"
    (b) within that, a directory containing "alsa-plugins-1.0.22" and a .deb file (package) that you can install from the file browser.

    This is called a "backport", and can possibly be done a lot better or simpler, or put online as ready built package. Please do not share the compiled .deb as there are many settings in that package that still point to "Ubuntu lucid"... I think...

    Sidenote: Yes, this is the famous "compile your own Operating System" part of Linux, if you do not know how to follow these instructions, please ask someone to show you.

    Comments?
    Last edited by strushb; March 16th, 2010 at 09:05 PM. Reason: Sidenote

  15. #60
    Join Date
    March 2010
    Location
    Germany
    Posts
    2
    Just got a note: This process can be automated, see https://wiki.ubuntu.com/Prevu

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] If no news, do not show news ticker.
    By Screech in forum Suggestions and Feedback
    Replies: 3
    Last Post: August 28th, 2015, 02:48 PM
  2. [Client API Request/Question] Access to main TS3 FMOD Thread
    By jaynus in forum Client Plugins / Lua Scripts
    Replies: 15
    Last Post: January 15th, 2011, 03:58 PM
  3. [Fmod unfixable] No wave sound played since beta 30
    By Styks in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: October 14th, 2010, 12:53 PM
  4. Beta 21 - FMOD system initialization changes?
    By jaynus in forum Client Plugins / Lua Scripts
    Replies: 8
    Last Post: June 14th, 2010, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •