Forum

Results 1 to 13 of 13
  1. #1
    Join Date
    December 2009
    Location
    UK
    Posts
    768

    Hearing own voice through headset

    I've just had my 1st conversation with someone on TS3 & find my own voice is being played back through my headset. I don't get this problem with my TS2 client so don't believe it's anything to do with PC audio settings.

    Anyone any clues?

  2. #2
    Join Date
    June 2008
    Posts
    18,144
    someone inside the room produced this echo?

  3. #3
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    It's not an echo, my voice is being relayed back through my headset, don't get this problem with TS2 & can't find a solution

  4. #4
    Join Date
    June 2008
    Posts
    18,144
    What happens, when you disblae all checkboxes under Seetings > Options > Capture Echo and all options under advanced?

  5. #5
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    No change.........

  6. #6
    Join Date
    January 2010
    Location
    netherlands
    Posts
    1

    sound mixer

    i had the same prob its not your TS3 but the setting of your mic
    hearing yourself means that your sound mixer is enabled
    after i had shut that off prob fixed

  7. #7
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    My microphone is muted in audio settings, as I said in my 1st post I don't get this problem on my TS2 client so believe it's a problem with the TS3 client

  8. #8
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    Well I'm not sure which setting has caused it, but I'm not getting my own voice through the headset any more. I'll post back when I've had more time to investigate.

  9. #9
    Join Date
    June 2012
    Posts
    1

    Talks to others, hearing myself in the headset.

    The headline says it all, how can I prevent that, itīs annoying.

    This post got moved
    Last edited by dante696; June 20th, 2012 at 03:17 PM.

  10. #10
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    There can be few posibilities...

    Could you (assuming you use windows XP or similar) go in your volume control and make sure that for playback is microphone muted?

    Check in teamspeak3 that it is actually your side, and not other user in a channel doing echo(what they hear get's back into the microphone then back to you), which makes you hear yourself talking.

    It is annoying and common problem.

    Also look here: http://forum.teamspeak.com/showthrea...hrough-headset

  11. #11
    Join Date
    June 2012
    Posts
    2

    hearing own voice/mixer settings

    Hello

    my problem seems to be common but I was unable to find a solution for my specific situation in this forum.
    I'm at the start in capture settings, without connection to any server. I have properly set a mic as a default communication device but capturing runs only if I allow monitoring in Mic Properties/levels tab. but this cause a common problem: hearing of my own voice. switching on Echo reduction and Echo cancellation only reduces the problem but not cures the root.
    My expectation is it should work like in skype: capturing runs also with monitoring off and I don't hear my own voice during speaking.
    Can anybody help?
    thanx a lot

    This thread got moved.
    Last edited by dante696; June 26th, 2012 at 07:57 AM.

  12. #12
    Join Date
    June 2012
    Posts
    2
    maybe this screenshot will help to get a hint
    Name:  Untitled.png
Views: 30545
Size:  794.4 KB
    the capturing runs only when the speakr icon in the tab levels unchecked. but this causes own voice hearing

  13. #13
    Join Date
    September 2010
    Location
    colorado U.S.A
    Posts
    10
    sorry to reactivate a very old thread but i just happened to find this post through a google search read it and find an answer that i myself deal with every time i get done with a pc reboot now i am not sure how well this answer will work for some and i am sorry if it it does not solve the problem still but i just thought i give my 2 cents about it

    first of all it is not an echo it is your own voice feed backing on its self when you talk your hearing your own voice

    second this can not be solved in your sounds setting how ever it can hopefully be solved this way

    1st step
    http://i210.photobucket.com/albums/b...psyncxttfo.png
    2nd step
    http://i210.photobucket.com/albums/b...psnexqyz4v.png
    through right clicking on the speaker icon
    3rd step
    http://i210.photobucket.com/albums/b...ps8vjfakxq.png
    have you tried lowering the button bar all the way down?

    *sorry for my screens not showing themselves on this forms here i don't know why its not doing that or i don't know how to get it to show themselves*

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hearing my own voice
    By hearingmyself in forum Windows
    Replies: 1
    Last Post: November 17th, 2014, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •