Forum

Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 46 to 60 of 118
  1. #46
    Join Date
    June 2010
    Location
    germany
    Posts
    11

    Question Crash on startup, error (0xc0150002)

    Yes, I tried the search, please read on.

    TS Client 3 worked for some weeks, but since a few days I get the infamous

    "The application failed to initialize properly (0xc0150002). Click on OK to terminate the application."

    I'm on Win XP Pro SP3 with all updates (in fact I think this problem was caused by some win update, but I'm not sure).

    I reinstalled .NET Framework 3.5 SP1
    I reinstalled the Microsoft Visual C++ 2008 Redistributable Package SP1
    I reinstalled the TS 3 Client
    I deinstalled and reinstalled into another folder

    None of this worked, I still get the error.

    TS3 Client version is TeamSpeak3-Client-win32-3.0.0-beta21

    Any further insights or ideas? Thanks in advance.
    Last edited by xanathon; June 7th, 2010 at 06:49 PM.

  2. #47
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    This does not seem to be trivial...

    http://forum.teamspeak.com/showthread.php?t=50584

  3. #48
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    I tried some other .NET programs, to test this problem and probably get more insights, but not one besides the TS3 client gives me this error.

    It was said by the developers said that this is a "windows bug" that can be solved by reinstalling .NET3.5 or the VC-dll but that does not help me in the least, so I would presume that the real culprit lies with the TS3-client.

    Still any insights and comments are appreciated...

  4. #49
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    Searched the web just for the error number.

    Reinstalled SP3.

    Did not help.

    I checked the TS3 client exe with Dependency Walker:

    Error: The Side-by-Side configuration information for "m:\teamspeak 3 client\QTCORE4.DLL" contains errors. Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren (14001).
    Error: The Side-by-Side configuration information for "m:\teamspeak 3 client\QTGUI4.DLL" contains errors. Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren (14001).
    Error: The Side-by-Side configuration information for "m:\teamspeak 3 client\QTNETWORK4.DLL" contains errors. Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren (14001).
    Error: At least one required implicit or forwarded dependency was not found.
    Profiler says:

    Second chance exception 0xC0150002 (Unknown) occurred in "NTDLL.DLL" at address 0x7C9766C6.
    Edit: here's the complete profiling:

    Starting profile on 08.06.2010 at 23:24:05

    Operating System: Microsoft Windows XP Professional (32-bit), version 5.01.2600 Service Pack 3
    Program Executable: m:\teamspeak 3 client\TS3CLIENT_WIN32.EXE
    Program Arguments:
    Starting Directory: M:\TeamSpeak 3 Client\
    Search Path: C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32 \WBEM;E:\Programme\Autodesk\Maya 8.5 Personal Learning Edition\bin;C:\Programme\ATI Technologies\ATI.ACE\Core-Static;e:\Panda3D-1.5.1\python;e:\Panda3D-1.5.1\bin;C:\Programme\VDMSound;e:\Programme\Hugin \bin\;C:\Programme\Calibre2\;m:\games\Hedgewars 0.9.12\bin

    Options Selected:
    Simulate ShellExecute by inserting any App Paths directories into the PATH environment variable.
    Log DllMain calls for process attach and process detach messages.
    Hook the process to gather more detailed dependency information.
    Log LoadLibrary function calls.
    Log GetProcAddress function calls.
    Log debug output messages.
    Automatically open and profile child processes.
    --------------------------------------------------------------------------------

    Started "TS3CLIENT_WIN32.EXE" (process 0x116C) at address 0x00400000. Successfully hooked module.
    Loaded "NTDLL.DLL" at address 0x7C910000. Successfully hooked module.
    Loaded "KERNEL32.DLL" at address 0x7C800000. Successfully hooked module.
    DllMain(0x7C910000, DLL_PROCESS_ATTACH, 0x00000000) in "NTDLL.DLL" called.
    DllMain(0x7C910000, DLL_PROCESS_ATTACH, 0x00000000) in "NTDLL.DLL" returned 1 (0x1).
    DllMain(0x7C800000, DLL_PROCESS_ATTACH, 0x00000000) in "KERNEL32.DLL" called.
    DllMain(0x7C800000, DLL_PROCESS_ATTACH, 0x00000000) in "KERNEL32.DLL" returned 1 (0x1).
    Injected "DEPENDS.DLL" at address 0x08370000.
    DllMain(0x08370000, DLL_PROCESS_ATTACH, 0x00000000) in "DEPENDS.DLL" called.
    DllMain(0x08370000, DLL_PROCESS_ATTACH, 0x00000000) in "DEPENDS.DLL" returned 1 (0x1).
    Loaded "QTCORE4.DLL" at address 0x67000000. Successfully hooked module.
    LDR: LdrpWalkImportDescriptor() failed to probe m:\teamspeak 3 client\QtCore4.dll for its manifest, ntstatus 0xc0150002
    Loaded "TFWAH.DLL" at address 0x10000000. Successfully hooked module.
    Loaded "WS2_32.DLL" at address 0x71A10000. Successfully hooked module.
    Loaded "ADVAPI32.DLL" at address 0x77DA0000. Successfully hooked module.
    Loaded "RPCRT4.DLL" at address 0x77E50000. Successfully hooked module.
    Loaded "SECUR32.DLL" at address 0x77FC0000. Successfully hooked module.
    Loaded "MSVCRT.DLL" at address 0x77BE0000. Successfully hooked module.
    Loaded "WS2HELP.DLL" at address 0x71A00000. Successfully hooked module.
    Loaded "USER32.DLL" at address 0x7E360000. Successfully hooked module.
    Loaded "GDI32.DLL" at address 0x77EF0000. Successfully hooked module.
    Loaded "SHELL32.DLL" at address 0x7E670000. Successfully hooked module.
    Loaded "SHLWAPI.DLL" at address 0x77F40000. Successfully hooked module.
    Loaded "OLE32.DLL" at address 0x774B0000. Successfully hooked module.
    Loaded "OLEAUT32.DLL" at address 0x770F0000. Successfully hooked module.
    DllMain(0x67000000, DLL_PROCESS_ATTACH, 0x00000000) in "QTCORE4.DLL" called.
    Unloaded "TFWAH.DLL" at address 0x10000000.
    Unloaded "OLEAUT32.DLL" at address 0x770F0000.
    Unloaded "OLE32.DLL" at address 0x774B0000.
    Unloaded "SHELL32.DLL" at address 0x7E670000.
    Unloaded "SHLWAPI.DLL" at address 0x77F40000.
    Unloaded "USER32.DLL" at address 0x7E360000.
    Unloaded "GDI32.DLL" at address 0x77EF0000.
    Unloaded "WS2_32.DLL" at address 0x71A10000.
    Unloaded "WS2HELP.DLL" at address 0x71A00000.
    Unloaded "MSVCRT.DLL" at address 0x77BE0000.
    Unloaded "ADVAPI32.DLL" at address 0x77DA0000.
    Unloaded "RPCRT4.DLL" at address 0x77E50000.
    Unloaded "SECUR32.DLL" at address 0x77FC0000.
    Second chance exception 0xC0150002 (Unknown) occurred in "NTDLL.DLL" at address 0x7C9766C6.
    Exited "TS3CLIENT_WIN32.EXE" (process 0x116C) with code -1072365566 (0xC0150002).
    Last edited by xanathon; June 8th, 2010 at 10:25 PM.

  5. #50
    Join Date
    June 2008
    Posts
    18,144
    I can't exactly tell how you can fix that error.
    User fixed 0xc0150002 on startup with reinstalling the needed Visual C++ Redistributable Package.

    And TeamSpeak needs this one
    Microsoft Visual C++ 2008 SP1 Redistributable Package (32-bit)
    or Microsoft Visual C++ 2008 SP1 Redistributable Package (64-bit)

  6. #51
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    Yes, that would probably help if I had not written in my first post that I already reinstalled that...

  7. #52
    Join Date
    May 2010
    Location
    UK
    Posts
    3
    With apologies for being way less tech savvy than you guys are
    I'm also getting this; posted a couple of relevant dump files in the Crashdump Collection thread. I've re-installed the C++, .net and visual basic stuff mentioned on here and re-installed TS3. I've tried it with every Beta from 20 onwards and no joy. Sometimes I get the error message but sometimes I don't. I always get the icon in the sys tray which dissapears if you mouse over it.
    I'm on XP home edition, and just changed from AVG to Avast on the offchance that was the issue.

  8. #53
    Join Date
    June 2010
    Location
    Louisiana
    Posts
    3
    i have this same problem. i tried to restore to a previous restore point and found that it worked until i updated it to 11315, then i started to get this problem.

    i figured since there were other problems on my computer at the time that i would go ahead and reformat it (yes, it was so bad that i reformatted my hard drive)
    yet when i downloaded the latest version of TS (today) i got the same issue (i try to run TS and all i get is the icon in the system tray, and when i mouse over the icon it disapears).
    BUT, im not sure if anyone else got this, but i got a message on my comp for just the first run (each subsequent attempt to run TS resulted in the usual "disapearing icon", but no message)
    i took a screen shot just in case(which turned out too big to attach), and the message said to REPORT TO THE TEAMSPEAK 3 DEVELOPERS.

    it wont let me attach it to this post but the file name is:
    ts3_clientui-win32-11315-2010-06-13 09_33_45.531250.dmp

    where do i go to send it to them?
    Last edited by 'Antonio'; June 13th, 2010 at 09:42 PM. Reason: found out it the update number was 11315

  9. #54
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    @'Antonio'

    Put that file in a zip file and go here to post a description of the problem and any steps you took along with the dump file.

    http://forum.teamspeak.com/showthread.php?t=46880

  10. #55
    Join Date
    June 2010
    Location
    Louisiana
    Posts
    3
    thanks poisonpanik, i posted the file and the screenshot in zips at that thread. i would really like to get my client working asap ><
    about how often do they go through that thread?

  11. #56
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    In my case I do not even get a dump or a tray icon, just the error window.

    Funny thing is: I tried to install the latest client on my old laptop which worked even if there are neither the VC++ nor the .NET 3.5SP1 installed...

  12. #57
    Join Date
    June 2008
    Posts
    18,144
    Quote Originally Posted by xanathon View Post
    In my case I do not even get a dump or a tray icon, just the error window.

    Funny thing is: I tried to install the latest client on my old laptop which worked even if there are neither the VC++ nor the .NET 3.5SP1 installed...
    The needed c++ files are included in installer, but sometimes it failed to install them.

  13. #58
    Join Date
    June 2010
    Location
    germany
    Posts
    11
    Just tried the lastest client, no change, still the error, dependency walker still gives me the problems with the QT libraries.

  14. #59
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Can you please install the Visual Studio runtime libraries from this site and check if the TeamSpeak 3 client will start?

    http://www.microsoft.com/downloads/d...displaylang=en

    If you look at the Details page of the downloaded vcredist_x86.exe file, you should see file version 9.0.21022.8

    This is not the runtime library included in the TeamSpeak 3 installer, but I'd be interested to know if this might solve your problem. On a clean Windows XP SP3 system, fresh install with only TeamSpeak 3, I see "Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17" in the list of installed software. Once I deinstall this package, TeamSpeak will not start with error 0xC0150002, as expected. Once I reinstall the redistributable file, TS3 starts up again.

    For reference, the redistributable included in the latest TS3 installer is this one for 32-bit systems:

    http://www.microsoft.com/downloads/d...displaylang=en

    Now on my clean Windows XP SP3 test system TS3 will start with both redistributables, either one or both installed.

    If you use the 64 bit TS3 client, either get the appropriate redistributable files for 64 bit or just use the 32 bit TS3 client, which might be easier.

    As a note, TeamSpeak does not require any .NET. It is a C++ program and requires the C++ runtime libraries. Those might be included in the .NET installer (I don't know), but .NET is no requirement for TeamSpeak nor does make TeamSpeak any use of .NET libraries. I've seen this written a couple of times and I wanted to take the chance to clarify.

  15. #60
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Alternative suggestion: Download the attached zipfile and extract it into your TeamSpeak 3 Client installation folder. This includes the required runtime libraries.
    I'd be interested if this might solve your issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. failed to initialize properly
    By grof5 in forum Windows
    Replies: 3
    Last Post: April 27th, 2014, 11:44 AM
  2. Replies: 1
    Last Post: July 4th, 2011, 03:36 PM
  3. Failed To Initialize (0xc0150002)
    By Farss in forum Windows
    Replies: 14
    Last Post: May 21st, 2010, 06:25 AM
  4. Failed to Initialize
    By jdrambam in forum Windows
    Replies: 0
    Last Post: February 12th, 2010, 02:45 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •