Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    December 2009
    Location
    UK
    Posts
    9

    Unable to find valid license key

    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead


    Code:
    [email protected]:~/ts3$ ./ts3server_linux_amd64 inifile=ts3server.ini
    Logging started
    2010-01-14 20:06:37.731537|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta12 [Build: 9596]
    2010-01-14 20:06:37.732996|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-01-14 20:06:37.733193|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-01-14 20:06:44.235793|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2010-01-14 20:06:44.785788|INFO    |FileManager   |   | listening on 95.130.11.112:30033
    2010-01-14 20:06:44.894007|INFO    |VirtualServer |  1| listening on 95.130.11.112:9987
    2010-01-14 20:06:44.895767|INFO    |Query         |   | listening on 95.130.11.112:10011
    When starting my server I get this error I have a license file licensekey.dat in the same dir as the ts3server_linux_amd64 however it doesnt seem to want to use it.

    My licensekey.dat:
    Code:
    Company name : ***edit***
    address      : ***edit***
    address2     : ***edit***
    zipcode      : ***edit***
    city         : ***edit***
    country      : United Kingdom (Great Britain)
    phone        : ***edit***
    fax          : 
    sales contact: ***edit*** (***edit**************)
    tech contact : ***edit*** (***edit**************)
    
    type         : Nonprofit
    start date   : Tue Dec 29 00:00:00 2009
    end date     : Wed Dec 29 00:00:00 2010
    max. virtual servers: 10
    max. slots   : 512
    description  : TeamSpeak 3 Non-Profit License (apg-clan.com)
    
    ==key==
    VFMzTGljZW5***edit***ANLmZztq8K7WU2vE00otjgBUlkdkvMOOrhBD7xS8+3RxWdZyyPPuK07VEH+B5N+2bQIxAL49***edit***eEJ1xpngmUP6JckJluO/PK0uNXAXM3***edit***7U5Hi/pSP/RryrN61dXKtxrRV/l4wNzFdN7qwkuT3w49Cyf/Z4eC9GnAo7eYx***edit***L64GK5upUIH4baHTTsw+r0VpFl1Pp5CX/9kHnzQ***edit***1pQVax1F+4ex4Fk/AIDlT88oFiI8lt9sL02iZA4Cn1G2iDfxhEl7***edit***Z2zUasxqOes30c56t5u6AhYuZ4wWbaL***edit***9MpDDvYdzDQ==
    My ts3server.ini is set up as follows:
    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=95.130.11.112
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=95.130.11.112
    query_port=10011
    query_ip=95.130.11.112
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=1
    Last edited by florian_fr40; November 15th, 2011 at 10:20 AM.

  2. #2
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Hi,

    could be that your licen file have a idffrent user or group ?

    Please report an: ls -l

    cheech

  3. #3
    Join Date
    December 2009
    Location
    UK
    Posts
    9
    -rw-r--r-- 1 moose moose 8412 Dec 31 05:50 CHANGELOG
    -rw-r--r-- 1 moose moose 23747 Dec 31 05:50 LICENSE
    drwxr-x--- 2 moose moose 4096 Dec 31 05:50 doc
    drwxr-x--- 3 moose moose 4096 Jan 10 15:51 files
    -rwxr-xr-x 1 moose moose 212235 Dec 31 05:50 libts3db_mysql.so
    -rwxr-xr-x 1 moose moose 952289 Dec 31 05:50 libts3db_sqlite3.so
    -rw-r--r-- 1 moose moose 931 Jan 14 21:58 licensekey.dat
    drwxr-x--- 2 moose moose 4096 Jan 14 21:59 logs
    drwxr-x--- 2 moose moose 4096 Dec 31 05:50 serverquerydocs
    drwxr-x--- 4 moose moose 4096 Dec 31 05:50 sql
    -rwxrwxrwx 1 moose moose 287 Jan 11 23:31 ts3server.ini
    -rw-r--r-- 1 moose moose 1206272 Jan 15 18:20 ts3server.sqlitedb
    -rwxr-xr-x 1 moose moose 3777904 Dec 31 05:50 ts3server_linux_amd64

    thanks ive tried running both as root and moose

  4. #4
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Hi,

    did you start the server 1st as root server if yes, search in this forum, you have to del a file but i don't find it at the moment.

    cheech

  5. #5
    Join Date
    December 2009
    Location
    UK
    Posts
    9
    I can't find anything while searching, god why did they have to bring in this crap license key system? Grrr

  6. #6
    Join Date
    December 2009
    Location
    London
    Posts
    32
    Quote Originally Posted by TheMadMoose View Post
    I can't find anything while searching, god why did they have to bring in this crap license key system? Grrr
    Its called Business ;-)

  7. #7
    Join Date
    December 2009
    Location
    UK
    Posts
    9
    Lol, I have made a windows server and the key works fine Ill just reinstall the server and move over the old database.

    EDIT: Still doesn't work, btw I found the file that needs to be owned it's in /dev/shm

    DOUBLE EDIT: Got it working I stopped using the inifile.
    Last edited by TheMadMoose; January 18th, 2010 at 03:15 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: September 9th, 2014, 07:23 PM
  2. Unable to find valid license key, falling back to limited
    By lathrodectus in forum Linux / FreeBSD
    Replies: 10
    Last Post: May 21st, 2012, 12:45 PM
  3. [Solution] Unable to find valid license key
    By UnfoundSanity in forum Server Support
    Replies: 4
    Last Post: January 13th, 2012, 04:15 PM
  4. [Resolved] Unable to find valid license key
    By Kevinos in forum Linux / FreeBSD
    Replies: 6
    Last Post: October 14th, 2011, 05:51 PM
  5. Unable to find valid license key
    By [DP-R]EvilSheep in forum Server Support
    Replies: 11
    Last Post: December 31st, 2009, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •