Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    November 2006
    Location
    USA
    Posts
    55

    [Solved] Server crashes unknown cause

    I have no idea why but the server randomly crashes with this error

    |CRITICAL|StringHelpers | | Failed to convert string "" to unsigned __int64

    I am not doing anything. A few times I left the server run and came back to have it crashed. I was logged off and tried to connect to find I could not so I checked the log to find this error.

    I hope someone has an answer.

  2. #2
    Join Date
    November 2006
    Location
    USA
    Posts
    55
    Saddly the server is still crashing with this error for no known reason.

    At times there is no one even on when it fails.

  3. #3
    Join Date
    June 2008
    Posts
    18,396
    Does this still appear with server beta15 and new database?

  4. #4
    Join Date
    November 2006
    Location
    USA
    Posts
    55
    I did not do a new dB however I could try that. Is there a change to the dB?

  5. #5
    Join Date
    November 2006
    Location
    USA
    Posts
    55
    This continues to be a problem. Going days without an issue seems to make me think that its someone connecting with an old beta client. Could this be the case? Is there a way to find out? I have the logs on but its not catching anything at the time it crashes.

  6. #6
    Join Date
    November 2006
    Location
    USA
    Posts
    55
    I finaly tracked down the issue I have been having.

    Long story short

    I have my own site/application that registers my users for several features and applications forums, openfire, ts2, ts3 ext. This application manages all these accounts for my members.

    The issue was that when I created the client information I was not adding a last connected entry. So when they tried to login TS3 choked and crashed. So all I needed to do was set the table with a default 0 value.

    Problem solved.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [solved] Unknown error
    By bakino in forum Windows
    Replies: 2
    Last Post: September 7th, 2010, 11:09 AM
  2. [solved] Unknown connect - timeout
    By -Striker- in forum Linux / FreeBSD
    Replies: 4
    Last Post: August 30th, 2010, 01:53 PM
  3. [Solved] Unknown connections
    By danGeR! in forum Windows
    Replies: 1
    Last Post: March 13th, 2010, 02:24 AM
  4. [Solved] Unknown spams the server chat log
    By Slater in forum General Questions
    Replies: 3
    Last Post: February 28th, 2010, 04:44 PM
  5. Replies: 5
    Last Post: December 22nd, 2009, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •