Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    14

    Upgrade to Beta 15 failed

    Upgrade from beta 12 -> 15:

    2010-01-18 15:22:28.120799|INFO |ServerLibPriv | | Server Version: 3.0.0-beta15 [Build: 9884]
    2010-01-18 15:22:28.121870|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-01-18 15:22:28.122178|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-01-18 15:22:28.122768|INFO |DatabaseQuery | | checking database integrity
    2010-01-18 15:22:28.753257|INFO |Accounting | | Licensing Information
    2010-01-18 15:22:28.754668|INFO |Accounting | | type : Non-profit
    2010-01-18 15:22:28.755817|INFO |Accounting | | starting date : Tue Dec 22 00:00:00 2009
    2010-01-18 15:22:28.756850|INFO |Accounting | | ending date : Wed Dec 22 00:00:00 2010
    2010-01-18 15:22:28.757796|INFO |Accounting | | max virtualservers: 10
    2010-01-18 15:22:28.758710|INFO |Accounting | | max slots : 512
    2010-01-18 15:22:28.794107|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-01-18 15:22:28.885834|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::except ion_detail::error_info_injector<boost::system::sys tem_error> >'
    what(): epoll: Function not implemented
    Aborted

  2. #2
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hey,

    we do NOT ship *any* database (it is created by the server when non exists
    on the first start-up), and I doubt this error message has anything to do with
    the database. Just for testing sake, can you please confirm that you get this
    same error even with a fresh install (with no database/settings copied into the
    beta15 install).

    The way I read the error message is that your linux system is lacking the implementation
    of "epoll" which is described here: http://www.kernel.org/doc/man-pages/...4/epoll.4.html

    Note the paragraph about versions:
    Code:
           The epoll API was introduced in Linux kernel 2.5.44.  Support was added to
           glibc in version 2.3.2.
    So my guess would be you are either running a 2.4.x (or older) kernel and/or glibc older than 2.3.2.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    Hm, that makes sense.

    The Kernel seems to be tooooooooooo old. Yey blame me and my old linux server ^^

    $ uname -a
    Linux debian 2.4.33.2 #1 Thu Aug 31 09:38:38 CEST 2006 i686 GNU/Linux


    $ strings /lib/libc.so.6 | grep GLIBC
    GLIBC_2.0
    GLIBC_2.1
    GLIBC_2.1.1
    GLIBC_2.1.2
    GLIBC_2.1.3
    GLIBC_2.2
    GLIBC_2.2.1
    GLIBC_2.2.2
    GLIBC_2.2.3
    GLIBC_2.2.4
    GLIBC_2.2.6
    GLIBC_2.3
    GLIBC_2.3.2
    GLIBC_2.3.3
    GLIBC_2.3.4
    GLIBC_PRIVATE

  4. #4
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    franzi: Yes, your kernel is at fault, you need a 2.6.x kernel - your glibc is new enough

    MeisterVampir: plz create a new topic, as your problem is a different one.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  5. #5
    Join Date
    December 2009
    Location
    NL
    Posts
    6

    beta15 dumps core

    On startup, the beta15 executable dumps core on my system, claiming that epoll() is not implemented. Beta12 did not exhibit this issue. Core dump available if a developer desires.

    Any suggestions on what I can do to fix this? For completeness' sake: the binary ran under linux emulation on NetBSD 4.

    # TeamSpeak Server 3.0.0-beta15 [Build: 9884]
    (c)TeamSpeak Systems GmbH

    Logging started
    2010-01-20 16:02:45.769954|INFO |ServerLibPriv | | Server Version: 3.0.0-beta15 [Build: 9884]
    2010-01-20 16:02:45.776239|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-01-20 16:02:45.778510|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-01-20 16:02:45.783552|INFO |DatabaseQuery | | checking database integrity
    2010-01-20 16:02:46.704395|INFO |Accounting | | Licensing Information
    2010-01-20 16:02:46.715827|INFO |Accounting | | type : Non-profit
    2010-01-20 16:02:46.725922|INFO |Accounting | | starting date : X
    2010-01-20 16:02:46.735321|INFO |Accounting | | ending date : Y
    2010-01-20 16:02:46.744843|INFO |Accounting | | max virtualservers: 10
    2010-01-20 16:02:46.754355|INFO |Accounting | | max slots : 512
    2010-01-20 16:02:47.034925|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-01-20 16:02:47.620771|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::except ion_detail::error_info_injector<boost::system::sys tem_error> >'
    what(): epoll: Function not implemented

  6. #6
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Solved] beta 27, upgrade help
    By benhat in forum Server Support
    Replies: 3
    Last Post: September 5th, 2010, 03:08 PM
  2. Upgrade to Beta 16; icons are blank
    By markgm5 in forum Client Support
    Replies: 0
    Last Post: February 25th, 2010, 03:10 AM
  3. upgrade to beta 9 and lost account
    By sailan in forum Permission System
    Replies: 0
    Last Post: January 2nd, 2010, 10:23 PM
  4. Upgrade to Beta 11 from Beta 6
    By nitramf in forum Linux / FreeBSD
    Replies: 2
    Last Post: December 30th, 2009, 11:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •