Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    January 2010
    Location
    Hellas
    Posts
    4

    Making TeamSpeak 3 work on Ubuntu 9.10

    Making TeamSpeak 3 work on Ubuntu
    TeamSpeak 3, you can download the Linux client from their site. The only problem is that currently (beta11) the client don't play nice with pulseaudio.

    After digging in the Ubuntu forums (can't find the exact post link), I came with the following solution:

    * Extract the client (cd /opt && sh ~/Downloads/TeamSpeak3-Client-linux_amd64-3.0.0-beta11.run)
    * Create the following script
    code of the script
    ************************************************** ***************
    #!/bin/bash

    # Make teamspeak work on Ubuntu (basically disable pulseaudio before launching)

    conf=$HOME/.pulse/client.conf
    backup="${conf}.bak"

    if [ -f "$conf" ]; then
    mv "$conf" "$backup"
    fi
    echo "autospawn = no" > "$conf"
    pulseaudio --kill

    cleanup() {
    rm "$conf"
    if [ -f "$backup" ]; then
    mv "$backup" "$conf"
    fi
    pulseaudio -D
    }

    cd /opt/TeamSpeak3-Client-linux_amd64/
    ./ts3client_linux_amd64&
    pid=$!
    trap "kill -9 $pid; cleanup" SIGINT SIGTERM
    wait $pid
    cleanup
    ************************************************** **************
    (1) you can extract the client wrere ever you want actually
    (2) the script works both 32 and 64 bit client
    (3) the script file is a new file that you ll create so you can put it in
    (4)run it as an executable and you re done

    Good luck!

  2. #2
    Join Date
    November 2006
    Location
    Germany
    Posts
    11
    You really should not kill -9 the client. That will kill it cold (SIGKILL cannot be handled gracefully), and has a good chance of corrupting config files and whatnot.

    I am wondering why you are running it in the background anyway, simply running it and calling cleanup after it finishes should do the trick.

    Of course, FMOD and ALSA not being broken PoS would help a lot.

  3. #3
    Join Date
    January 2010
    Location
    US
    Posts
    8

    Another possible mitigation for TS3 in Ubuntu

    If you have at least a dual-core processor, you can also try confining TS3 to just one core so that it can't max out both. I tried running TS3 this way just now, and it seemed to eliminate the large and random framerate drops in Urban Terror that I was having before.

    I used the schedtool command to set TS3's affinity to the first core. The command looked something like this:
    Code:
    schedtool -a 0 4692
    where 4692 happened to be the process ID for the TS3 client at the time.

    I'm not sure how you'd make the change permanent, so that TS3 gets stuck with just one core every time you start it. The default is for processes to be able to use all cores.

  4. #4
    Join Date
    January 2010
    Location
    Hellas
    Posts
    4
    Try it ,and make your replies here . i use a quad processor , and i dont have actually problems using TS3. (temporary till the devs fix the prob) .|So if you have any better ideas how to improve the code, plz post it.(Also the full script)

  5. #5
    Join Date
    July 2006
    Location
    Sweden
    Posts
    76
    Quote Originally Posted by paulkokos View Post
    The only problem is that currently (beta11) the client don't play nice with pulseaudio.
    The issue didn't come with beta 11, it has been there since beta 1. And there's nothing wrong with the client itself, but rather FMOD in the client causes PulseAudio to go berserk and consume tons of cpu.

    More info: http://forum.teamspeak.com/showthread.php?t=49202

  6. #6
    Join Date
    December 2009
    Location
    Flroida
    Posts
    65
    there is a patch for pulse audio which works perfectly for me and it's in the bug report.

  7. #7
    Join Date
    July 2006
    Location
    Sweden
    Posts
    76
    Quote Originally Posted by Whinis View Post
    there is a patch for pulse audio which works perfectly for me and it's in the bug report.
    You mind pointing me to the source where they fix the problem and not just completely disable pulseaudio? Because that's all I have found so far.

  8. #8
    Join Date
    December 2009
    Location
    France
    Posts
    8
    Where is this marvellous patch ?

  9. #9
    Join Date
    December 2009
    Location
    Dublin, Ireland
    Posts
    379
    Quote Originally Posted by Jissay View Post
    Where is this marvellous patch ?

    it apparently has been implemented in the Ubuntu 10.04 Alpha.

    Mixed opinions on the results.

    ( i had a link to ubuntu launchpad bug notes but it seems to have been removed..)
    Last edited by azzy101; January 25th, 2010 at 01:05 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [HELP] Making Another TeamSpeak
    By Waker in forum Server Support
    Replies: 3
    Last Post: October 4th, 2012, 10:29 AM
  2. Mic doesn't work | Ubuntu 10.10, TS3
    By tsfunktioniertnicht in forum Linux
    Replies: 26
    Last Post: April 14th, 2011, 10:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •