Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    August 2009
    Location
    Across the street
    Posts
    216

    Isn't it a bit odd...

    ...to add the new permission for minimum client version, only to not allow us to edit it via the client permissions window?

    I've seen that you have to manually edit the database in order to allow the server owner to even touch it, or simply make a new database. This is a bit strange to me.

    When will we have the option to simply work with the new features from the client as they are added?

  2. #2
    Join Date
    December 2009
    Location
    Washington USA
    Posts
    17
    Yep, I'm still scratching my head over this one.

    Fortunately it appears that beta15 server forces the use of the latest (beta11) client. Which is good I guess because I can't figure out a way to modify the new setting.

  3. #3
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    This is intentional, the feature to limit client version was mostly added because we changed the
    protocol and wanted to require beta11+ clients for the new server. The fact that we made it
    configurable but not available in the client settings was a concious decision: It is easy to mess up
    this settings, and lock yourself out, and also there are only very few servers out there (e.g. our
    test servers) where it really makes sense to force clients to upgrade.

    I think you can edit it via serverquery though (not only database).
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  4. #4
    Join Date
    August 2009
    Location
    Across the street
    Posts
    216
    Quote Originally Posted by Peter View Post
    This is intentional, the feature to limit client version was mostly added because we changed the
    protocol and wanted to require beta11+ clients for the new server. The fact that we made it
    configurable but not available in the client settings was a concious decision: It is easy to mess up
    this settings, and lock yourself out, and also there are only very few servers out there (e.g. our
    test servers) where it really makes sense to force clients to upgrade.

    I think you can edit it via serverquery though (not only database).
    Thanks for the response, Peter.

    I tried editing it via query, but it always returns an error about unknown parameters or something.

    Anyway, thanks for explaining the reason. I appreciate that.

  5. #5
    Join Date
    October 2008
    Location
    Alberta, Canada
    Posts
    166
    Yes the two new permissions involving min client version and custom search aren't enabled at default. It's best this way though I think as people who upgrade don't have to worry about the permissions being granted automatically.

    You can't grant them via ServerQuery either as even group 2 doesn't have the Grant permission for those.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •