Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    December 2009
    Location
    United States
    Posts
    24

    Thumbs up Restoring Default Template Groups

    For those who deleted some or all of your default template groups, I found these SQL statements to resolve my problem so I thought I would share with you!

    I am running TeamSpeak Server in Windows. These steps should be similar with other operating systems.

    Code:
    INSERT INTO groups_server VALUES(3,0,'Server Admin',0);
    INSERT INTO groups_server VALUES(4,0,'Normal',0);
    INSERT INTO groups_server VALUES(5,0,'Guest',0);
    INSERT INTO groups_server VALUES(6,1,'Server Admin',1);
    INSERT INTO groups_server VALUES(7,1,'Normal',1);
    How I did it:
    1. Closed TeamSpeak Server.
    2. Backed up my existing ts3server.sqlitedb database file.
    3. Downloaded SQLite Browser, extracted, and executed the software.
    4. Opened my ts3server.sqlitedb database file
    5. Used the "Execute SQL" tab at the top.
    6. Copied the above code and pasted it into the box at the top of SQLite Browser.
    7. Clicked "Execute Query"
    8. Clicked the Save button at the top.
    9. Exited SQLite Browser
    10. Relaunched TeamSpeak Server with success!
    Last edited by SkyviewGuru; January 20th, 2010 at 09:16 PM. Reason: Corrected filename of database file

  2. #2
    Join Date
    January 2010
    Location
    Secret Base in Arctic Region
    Posts
    1,671
    Why would someone delete the template groups?
    And, did you check that the their permissions are restored as well?

  3. #3
    Join Date
    December 2009
    Location
    United States
    Posts
    24
    Quote Originally Posted by Alcazar View Post
    Why would someone delete the template groups?
    And, did you check that the their permissions are restored as well?
    Well, prior to the recent beta server, those groups had no purpose for me. I only had, and only needed, one virtual server. I made groups how I wanted them and the template groups were just extra fluff in the way.

    Now that it's mandatory that these template groups exist, even for those who don't need multiple virtual servers, I had to find a way to restore them. I saw several people in the forums asking how to do it but nobody would answer them. So I found out the answer on my own and posted it here.

    No, this doesn't restore permissions to these template groups (to my knowledge), but it at least gets your server back online so you can use it without wiping your database.

    Edit: Having rechecked my Server Groups permissions, it *does* appear that the permissions are restored.
    Last edited by SkyviewGuru; January 24th, 2010 at 04:24 PM. Reason: Correction

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Delete template groups
    By vERKE in forum Permission System
    Replies: 1
    Last Post: August 10th, 2015, 09:49 PM
  2. [Not possible] Assign Template Groups & make default group permanent?
    By RickyB98 in forum Server Support
    Replies: 4
    Last Post: November 12th, 2014, 03:55 PM
  3. How to use the new template groups
    By mcfly_98 in forum General Questions
    Replies: 5
    Last Post: August 3rd, 2010, 08:06 AM
  4. Restoring everything to default
    By Martin_Weare in forum Permission System
    Replies: 1
    Last Post: June 17th, 2010, 10:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •