Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2010
    Location
    Barcelona
    Posts
    5

    [Solved] [DMZ host]no external connection

    Hi everybody,

    I've already read all topics about this, but even i don't succeeded.
    As said in topic, i'm able to connect in local network, but not from outside. So the problem should be my router, not some firewall stuff.

    I've setup a ts3 server on madriva 2007. This installation of mandriva works on a virtual pc host machine.
    IP of eth1 interface : 192.168.0.25
    Port of ts : 9987

    To connect to my ts3 server, i use a VPN (my pc is out of the local network).
    With the VPN, and using 192.168.0.25:9987, i manage to connect, authentify, view server logs etc.

    The local network is behind a router :
    IP : xx.xx.221.173

    DMZ host configuration :
    TCP & UDP
    internal port range : from 9980 to 10100
    internal ip : 192.168.0.25
    external port range : from 9980 to 10100
    external ip : 0.0.0.0

    One time VPN is down, i cant manage to connect using xx.xx.221.173:9987

    Why ?
    Does anybody have an idea ?

    Thanks in advance

  2. #2
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    "DMZ" poorly connecting to "port ranges".
    And problem is virtualbox, i'm afraid.

  3. #3
    Join Date
    January 2010
    Location
    Barcelona
    Posts
    5
    What do you mean with virtual box ?

    i'm sorry for my ignorance, but i'm glad to remember you that you were one, too.

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    You hosting (trying to) TS3 server from virtual pc installation. That's the problem.
    It is highly NOT recommended way of doing things.
    Aside from the internal server issues, you have to have very special network configuration on your host to allow services from virtual machine to be visible outside of your host.

  5. #5
    Join Date
    December 2009
    Location
    florida
    Posts
    263
    only way i get external connections on my home server thru my router is bind
    my ts3 server to internal ip with the command line.

    i use a desktop shortcut with targat command line..
    "C:\Program Files\teamspeak3-server_win32\ts3server_win32.exe" voice_ip=192.168.1.3 query_ip=192.168.1.3 filetransfer_ip=192.168.1.3

    server log
    2010-01-22 01:24:01.015625|INFO |ServerLibPriv | | Server Version: 3.0.0-beta16 [Build: 9929]
    2010-01-22 01:24:01.031250|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-01-22 01:24:01.031250|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-01-22 01:24:01.046875|INFO |DatabaseQuery | | checking database integrity
    2010-01-22 01:24:01.171875|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2010-01-22 01:24:01.765625|INFO |FileManager | | listening on 192.168.1.3:30033
    2010-01-22 01:24:01.968750|INFO |VirtualServer | 1| listening on 192.168.1.3:9987
    2010-01-22 01:24:01.984375|INFO |Query | | listening on 192.168.1.3:10011

    ports are
    9987 UDP
    10011 TCP
    30033 TCP
    Last edited by HHD_HELLBOUND; January 24th, 2010 at 03:30 AM. Reason: port info

  6. #6
    Join Date
    January 2010
    Location
    Barcelona
    Posts
    5
    Thanks guys.

    I found the problem. This was a misconfiguration between mandriva UI and cmd line.

    my server works fine now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [solved] External Server Query
    By Jordi in forum Windows
    Replies: 9
    Last Post: April 12th, 2011, 04:08 PM
  2. no connection from external ip
    By daverogers in forum Windows
    Replies: 10
    Last Post: January 3rd, 2011, 10:37 PM
  3. [solved] Cannot connect via External WAN
    By FireRush in forum Windows
    Replies: 6
    Last Post: April 24th, 2010, 09:14 PM
  4. No Connection with External IP
    By Redstar in forum Windows
    Replies: 7
    Last Post: December 21st, 2009, 02:34 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •