Forum

Page 1 of 9 123 ... LastLast
Results 1 to 15 of 134
  1. #1
    Join Date
    December 2009
    Location
    England
    Posts
    6

    TeamSpeak 3 Referral Error

    Quote Originally Posted by dante696 View Post
    For anyone who want's to report
    Client 3.0.19 (or newer) does not start anymore after update because the error "A referral was returned from the server" appears.

    For Vista users
    The support for Vista was dropped
    - Install all updates and Service Pack 2
    - And try this fix from Microsoft https://support.microsoft.com/en-us/kb/2763674

    For all User

    - Install all updates and restart
    - Change UAC settings for testing (please revert the change after testing for your own security!)
    - Try to deactivate firewall/antivirus tools or anything else that could block programs (if this works tell us which program caused the problem)
    - Install the client again via installer from http://www.teamspeak.com/downloads

    Additional to this topic
    http://forum.teamspeak.com/threads/5...913#post332913

    Running windows vista on the computer with this issue, had ts2 running fine on it before but after downloading ts3 realised that when opening it it gives the message: A referral was returned from the server. (the program does not open at all)

    Anyone have any ideas what this means or how to fix?
    Last edited by dante696; April 27th, 2018 at 02:44 PM.

  2. #2
    Join Date
    August 2009
    Location
    Across the street
    Posts
    216
    Are you running it as Administrator?

  3. #3
    Join Date
    December 2009
    Location
    England
    Posts
    6
    Same issue, still won't open as admin.

  4. #4
    Join Date
    August 2009
    Location
    Across the street
    Posts
    216
    Can you load up Event Viewer after trying to launch the server to see if you have something going on with Windows internally? This is very odd to me, hehe. I am sure the devs would have more information, though. Hopefully one will look here.

  5. #5
    Join Date
    January 2010
    Location
    North Carolina
    Posts
    1

    Problem Running Ts3

    I Have just dl ts3 and when i try to run it a message pops saying
    "A Referral Was Sent from the server"
    Help....

  6. #6
    Join Date
    June 2008
    Posts
    18,143
    More information / screenshots please

  7. #7
    Join Date
    January 2010
    Location
    OK
    Posts
    6

    TeamSpeak 3 Referral Error

    I have one member of my clan who cannot run teamspeak 3. When he tries to run it, he keeps getting a REFERRAL ERROR.

    Anyone know what we can do to fix this?

    We've tried the latest updated version also

    -Dark

  8. #8
    Join Date
    January 2010
    Location
    OK
    Posts
    6
    Any suggestions on this? anything??

  9. #9
    Join Date
    June 2008
    Posts
    18,143
    We need more inforamtion, Logs, Crashdump, OS, Client Version, Error Message?

  10. #10
    Join Date
    January 2010
    Location
    OK
    Posts
    6
    Well Its not me , So i dont have the logs, but i guess I could get them.

    But I know its Teamspeak3, the latest updated beta, and my member is running Vista. If you tell me where to get the logs from i can ask the guy for them

    We are definatly interested in getting this to work.

    all the error message says is "Referral Error"

  11. #11
    Join Date
    January 2010
    Location
    OK
    Posts
    6
    So can someone help me? Or I should just switch to vent?

    I really want to solve this problem for my clan member.

    contact me on here or via STEAM: [email protected]

    Or my website, www.realmofdarkness.info

  12. #12
    Join Date
    June 2008
    Posts
    18,143
    Microsoft Visual C++ 2008 SP1 Redistributable has to be installed to run TeamSpeak client properly.
    http://www.microsoft.com/downloads/d...displaylang=en

  13. #13
    Join Date
    February 2010
    Location
    U.S.A
    Posts
    1

    Referral Error

    When i try to start up TS3 i get the error message:

    "A Referral was returned from the server".

    I have Windows Vista (If that makes a difference).

    I dont have the slightest clue on how to fix it.

    Any ideas?

    All i tried was reinstalling it seeing if it downloaded wrong

  14. #14
    Join Date
    January 2010
    Location
    OK
    Posts
    6
    The guy went to your link and downloaded and installed and a message box appeared and said that he needed the current version.

    Is the Current Version MicroSoft C++ 2008 Express Edition?

    http://www.microsoft.com/express/Dow...008-Visual-CPP

    or that one wouldnt work for TS3?

  15. #15
    Join Date
    February 2010
    Location
    UK
    Posts
    1

    A referral was returned from the server"

    Im getting the same re installed several times

    running Vista also

    please help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A referral was returned from the server
    By teamspeakfan5 in forum Windows
    Replies: 9
    Last Post: September 25th, 2011, 03:56 AM
  2. TS3 Referral from server!
    By James3127 in forum Windows
    Replies: 1
    Last Post: April 9th, 2011, 11:44 PM
  3. A referral was returned from Server Error
    By PWebber in forum Windows
    Replies: 0
    Last Post: July 17th, 2010, 01:35 AM
  4. Referral Error
    By AllTheRage in forum Windows
    Replies: 0
    Last Post: February 2nd, 2010, 10:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •