Forum

Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 46
  1. #16
    Join Date
    June 2008
    Posts
    18,151
    There is definitly the same virtual server running on the internet or the old server got killed and had no chance to unregister the virtual server.

    Please wait 2 hours, before you start your server or find the the server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #17
    Join Date
    June 2014
    Posts
    7
    I think i have fixed the problem, i deleted serverkey.dat and it recreated a new one when i launched the server and now it has been up for 1 and a half hours with no problems.

    I'll post back if it solves it completely.

    -------------merged-------------


    Sadly had the problem again, going to turn the teamspeak off for 2 hours and see what happens.
    Last edited by dante696; June 11th, 2014 at 06:07 PM.

  3. #18
    Join Date
    June 2008
    Posts
    18,151
    Buddy, it's a copy of your virtual server or databse, that causes the problem.
    The Server with it's unique ID is registred in our system and marked as running.
    The only ways to get it out of the system are:
    - A normal server shutdown
    - A normal instance shutdown
    - Or a timeout, when no server replied twice [takes ~2 - 3hours]

    Maybe you moved your server to a new location, or someone else with access has a copy of your database or you just made a copy of a virtual server into the same instance. Or something like that.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #19
    Join Date
    June 2014
    Posts
    7
    Quote Originally Posted by dante696 View Post
    Buddy, it's a copy of your virtual server or databse, that causes the problem.
    The Server with it's unique ID is registred in our system and marked as running.
    The only ways to get it out of the system are:
    - A normal server shutdown
    - A normal instance shutdown
    - Or a timeout, when no server replied twice [takes ~2 - 3hours]

    Maybe you moved your server to a new location, or someone else with access has a copy of your database or you just made a copy of a virtual server into the same instance. Or something like that.
    How can i change the servers Unique ID?

  5. #20
    Join Date
    June 2008
    Posts
    18,151
    That's nothing we support.
    I toled you already, how you can solve it.

    One soloution is left (ignoring the others) -> Start your server with a new virtual server or server database.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #21
    Join Date
    June 2014
    Posts
    7
    I moved my teamspeak server to a new VPS but it's not running on the other one, i do know somebody else has the teamspeak files so there is a possibility of somebody currently using it.

    I have tried everything you have said and NOTHING has fixed it.

    ------------------------merged------------------------

    I appeared to have fixed it but now its closing down because of this error

    too many slots hosted, shutting down!

    I'm on a NPL license.
    Last edited by dante696; June 12th, 2014 at 12:21 PM.

  7. #22
    Join Date
    June 2008
    Posts
    18,151
    The server did not unregister it's slots. Same story as before. Do not kill the server, shut it down.

    Please wait 2-3 hours, before you use the license.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #23
    Join Date
    June 2014
    Posts
    7
    Quote Originally Posted by dante696 View Post
    The server did not unregister it's slots. Same story as before. Do not kill the server, shut it down.

    Please wait 2-3 hours, before you use the license.
    Oh last time i completely killed the server, the actual process not just the virtual server. I'll do it now.

  9. #24
    Join Date
    June 2014
    Posts
    7
    Turns out it was my NPL License, apparently somebody else had it so i got it relicensed and its all good now.

    Thanks.

  10. #25
    Join Date
    October 2014
    Posts
    2

    One more "virtual server id 1 is running elsewhere, shutting down!" thread

    There are the private server on non-profit license with huge channel-tree (about thousand sub-channels) and very complicated server groups and permission settings. It have taken very long time to create all these channels and permission settings.

    Previous server administrator has old database backup for this server.
    And now he launches his old copy of database on his own machine several times a day for some ugly reasons.
    The main server keeps shutting down every time he launches his copy of backup.
    This seems to me like a security breach that the MAIN server is shutting down, not the copy.

    I have read all the threads about this issue and understand that this is a "feature" (thery strange feature indeed).

    The question is: How we can resist such "launch a copy and kill the server" attack ???

    I think the best solution would be to create new server from scratch with new "ServerID". But I cannot find simple way to transfer all channel and permissions settings to new server as well as user database.

    Would you recommend how we can transfer all server settings to another instance with new serverID?

  11. #26
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    Request license replacement, I think?

  12. #27
    Join Date
    October 2014
    Posts
    2
    It seems to be the license does not matter.
    And anyway license binded to static IP address.

    One could start database copy without license file.
    Just edit slot count to default 32 in "server_properties" table.

    I wonder, if I simply copy all database tables except "servers" and "server_properties" to fresh server with new serverID.
    Will it work or not?

    All I need - a way to transfer channel tree, permission settings and user database to fresh TS installation.

  13. #28
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Thousand subchannels on an NPL? That's madness. Channels > Slots is always stupid.

    There is some backup stuff in YaTQA, but I have been reported that it doesn't work for unreasonable high numbers of channels. Group backup works on one-by-one basis.

  14. #29
    Join Date
    July 2016
    Posts
    3

    Random TS server has stopped

    Dear

    Can someone help me please?
    My TeamSpeak server 64bit (hosted on Windows Server 2012 R2 64bit) is randomly stopped for no reason and I dont know why.
    Server allways autodisconnect all users and then is stopped. TS server process is still running but all users can't connect back to this server.
    I must allways manual restart this server.

    this is log from this problem

    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Ananazo'(id:9409) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'SuaL'(id:9285) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Mati'(id:9991) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Casper'(id:10425) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Jebemboha'(id:4203) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'smajdovic'(id:10267) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Roccosaurus REX :E'(id:6478) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Blooder'(id:8703) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Patrik'(id:9493) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Eradas'(id:8021) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'habo'(id:7399) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'prosto'(id:9825) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'xer'(id:9753) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'čoooo'(id:7339) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Veldo'(id:10431) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'mlask'(id:10426) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Tonkik'(id:10423) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'RIDGID'(id:10420) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'macka'(id:8956) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'nuber'(id:7364) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Bled'(id:8758) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.698218|INFO |VirtualServerBase|1 |client disconnected 'Olof'(id:10428) reason 'reasonmsg=Server Shutdown!'
    2016-07-09 22:28:03.963869|INFO |VirtualServerBase|1 |stopped
    Last edited by dante696; July 11th, 2016 at 09:52 AM. Reason: merged

  15. #30
    Join Date
    September 2012
    Posts
    6,078
    show full _0.log and _1.log
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Virtual Server shutting down
    By yousan in forum Linux / FreeBSD
    Replies: 8
    Last Post: June 17th, 2013, 07:22 PM
  2. Replies: 12
    Last Post: August 19th, 2010, 04:53 PM
  3. Virtual server is running elsewhere, shutting down!
    By MoXNoX in forum Server Support
    Replies: 9
    Last Post: June 8th, 2010, 09:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •