Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    December 2009
    Location
    Munich
    Posts
    25

    Problems with starting up Ts3 server beta 17

    hey guys,
    If i start the minimal run script i get the error ./ts3server_linux_amd64: no such file or directory. But im sure that the file is there. if you dont believe in me i can upload a screenshot of my ts3 dictionary.

    Im thanking you in anticipition of your answers.

    LG Zion

  2. #2
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191
    Paste the exact way you run your script, then run "pwd" and "ls -Fla" and "whoami" for us after the script failed to start (and paste the entire thing).

  3. #3
    Join Date
    December 2009
    Location
    Munich
    Posts
    25
    Hey Peter,

    exakt way how i start up the script:
    cd ts3
    ./ts3server_minimal_runscript.sh start
    after doing this i get the error

    Here you are

    pwd
    root/ts3

    [email protected]:~/ts3# ls
    CHANGELOG libts3db_sqlite3.so ts3server_minimal_runscript.sh
    LICENSE serverquerydocs ts3server_startscript.sh
    doc sql
    libts3db_mysql.so ts3server_linux_amd64

    [email protected]:~/ts3# whoami
    root

  4. #4
    Join Date
    December 2009
    Location
    Munich
    Posts
    25
    Hey Guys,
    now i get another error code:
    [email protected]:/root/ts3$ ./ts3server_startscript.sh start
    -sh: ./ts3server_startscript.sh: /bin/bash^M: bad interpreter: No such file or directory

    I hope anyone of you can help me with this Problem.
    Im thanking you in anticipation of your answers
    best regards

  5. #5
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191
    hmm I ask for "ls -Fla" and you give output of "ls". Your new error is that you copied your file to windows, edited it and reupped it O_o. Extract the beta17 archive *on*linux*, edit the file (if you must) *on*linux*. Everything else messes up permissions and line endings.

  6. #6
    Join Date
    December 2009
    Location
    Munich
    Posts
    25
    Sry Peter my mistake. Here is what you asked for:
    sh-3.1$ ls -fla
    total 6680
    drwxr-xr-x 7 ts root 4096 Feb 6 20:02 .
    drwxr-xr-x 6 root root 4096 Feb 6 11:05 ..
    -rw-r--r-- 1 root root 13919 Feb 6 19:42 CHANGELOG
    -rw-r--r-- 1 root root 195085 Feb 6 19:42 libts3db_mysql.so
    -rw-r--r-- 1 root root 827409 Feb 6 19:43 libts3db_sqlite3.so
    -rw-r--r-- 1 root root 23747 Feb 6 19:42 LICENSE
    -rwxrwxrwx 1 root root 5520348 Feb 6 19:46 ts3server_linux_x86
    -rwxrwxrwx 1 root root 157 Feb 6 19:43 ts3server_minimal_runscript.sh
    -rwxrwxrwx 1 root root 2629 Feb 6 19:57 ts3server_startscript.sh
    drwxr-xr-x 2 root root 4096 Feb 6 19:43 doc
    drwxr-xr-x 2 root root 4096 Feb 6 19:46 serverquerydocs
    drwxr-xr-x 4 root root 4096 Feb 6 19:46 sql
    -rw-r--r-- 1 root root 75 Feb 6 19:53 ts3db_mysql.ini
    -rw-r--r-- 1 root root 310 Feb 6 19:53 ts3server.ini
    drwx------ 2 ts ts 4096 Feb 6 19:59 logs
    -rw-r--r-- 1 ts ts 171008 Feb 6 20:01 ts3server.sqlitedb
    drwx------ 3 ts ts 4096 Feb 6 19:59 files
    -rw-r--r-- 1 ts ts 10 Feb 6 19:59 query_ip_whitelist.txt
    -rw-r--r-- 1 root root 930 Feb 6 20:02 licensekey.dat

    I will now edit the startscript on linux because i need to edit the start parameter inifile=ts3server.ini

    big thanks to you for your helping
    best regards

  7. #7
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Hi,

    login as root
    go t parent directory of your ts3 folder and do an: chown -R ts:ts ts

    Then change user with: su ts

    And now try to start your server again.

    Cheech

  8. #8
    Join Date
    December 2009
    Location
    Munich
    Posts
    25
    Hey Guys,

    Now i get a error by starting the minimal_runscript.sh
    Here is my Logifle:
    2010-02-07 11:35:38.742137|INFO |ServerLibPriv | | Server Version: 3.0.0-beta17 [Build: 10115]
    2010-02-07 11:35:38.744249|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-02-07 11:35:38.744852|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-02-07 11:35:38.745853|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-02-07 11:35:38.814134|INFO |SQL | | db_CreateTables() tables created
    2010-02-07 11:35:39.980906|INFO |Accounting | | Licensing Information
    2010-02-07 11:35:39.982754|INFO |Accounting | | type : Non-profit
    2010-02-07 11:35:39.984549|INFO |Accounting | | starting date : Mon Dec 21 00:00:00 2009
    2010-02-07 11:35:39.986323|INFO |Accounting | | ending date : Tue Dec 21 00:00:00 2010
    2010-02-07 11:35:39.987916|INFO |Accounting | | max virtualservers: 10
    2010-02-07 11:35:39.990193|INFO |Accounting | | max slots : 512
    2010-02-07 11:35:40.062576|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-02-07 11:35:40.760839|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    2010-02-07 11:35:40.763574|INFO |VirtualServer | 1| client 'server'(id:0) added token for servergroup 'Server Admin'(id:6)
    2010-02-07 11:35:40.765631|WARNING |VirtualServer | 1| --------------------------------------------------------
    2010-02-07 11:35:40.766789|WARNING |VirtualServer | 1| ServerAdmin token created, please use the line below
    2010-02-07 11:35:40.769110|WARNING |VirtualServer | 1| token=/---------------------------------------------------
    2010-02-07 11:35:40.770676|WARNING |VirtualServer | 1| --------------------------------------------------------
    2010-02-07 11:35:40.772279|INFO |Query | | whitelist ips: 127.0.0.1,
    2010-02-07 11:35:40.776095|CRITICAL| | | Failure during pthread_create 12

  9. #9
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. having problems starting server
    By brandon789 in forum Linux / FreeBSD
    Replies: 15
    Last Post: November 17th, 2013, 08:14 PM
  2. Server Starting problems
    By uaksz555 in forum Windows
    Replies: 1
    Last Post: November 10th, 2010, 12:09 PM
  3. Starting Server fater update Beta 17 failed
    By Passe0815 in forum Linux / FreeBSD
    Replies: 3
    Last Post: February 5th, 2010, 09:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •