Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 23 of 26 FirstFirst ... 132122232425 ... LastLast
Results 331 to 345 of 377
  1. #331
    Join Date
    March 2009
    Location
    French
    Posts
    51
    Hello,

    ./ts3phpbot.sh start
    starting all instances of ts3phpbot:
    starting config/virtualServer/9987... done

    [email protected]:/home/serveur/teamspeak3/ts3phpbot# Sat, 17 Mar 2012 20:38:41 +0100 TS3PHPBot: [EMERG] flood ban


    I can still connect to the TeamSpeak server by cons impossible to restart the bot.

    edit : ok, but how to disable ServerQuery please ?


    Best regards
    Last edited by ALpha__; March 17th, 2012 at 09:13 PM.

  2. #332
    Join Date
    January 2010
    Location
    Germany
    Posts
    252
    Quote Originally Posted by ALpha__ View Post
    ok, but how to disable ServerQuery please ?
    You can disable the ServerQuery logs in your TeamSpeak3 server settings.

    Quote Originally Posted by ALpha__ View Post
    /ts3phpbot.sh start
    starting all instances of ts3phpbot:
    starting config/virtualServer/9987... done

    [email protected]:/home/serveur/teamspeak3/ts3phpbot# Sat, 17 Mar 2012 20:38:41 +0100 TS3PHPBot: [EMERG] flood ban

    Add your bot IP address to your TeamSpeak3 whitelist. The file is called "query_ip_whitelist.txt" You can enter an infinite number of IP addresses to the whitelist, one IP address per line. The file also supports Classless Inter-Domain Routing (CIDR) notation.

    See http://media.teamspeak.com/ts3_liter...y%20Manual.pdf for full description.

  3. #333
    Join Date
    March 2009
    Location
    French
    Posts
    51
    Ok, I look... thanks.

  4. #334
    Join Date
    February 2009
    Location
    Poland
    Posts
    13
    Bot seems to be joining set channel but he disconnects immediately after that...
    log:
    Code:
    [Mar 26 18:45:58]   notice: Starting TS3PHPBot daemon, output in: '/home/xxx/ts3bot/logs/9988_2012-03-26_18:45:58.log'
    [Mar 26 18:45:58]  warning: Orphaned pidfile found and removed: /home/xxx/ts3bot/pids/9988.pid. Previous process crashed?
    [Mar 26 18:45:58]     info: Changed identify to 'xxx':'xxx'
    [Mar 26 18:45:58]   notice: TS3PHPBot version 2.0.0 [Build: 595]
    [Mar 26 18:45:58]   notice: Copyright 2011-2012  <[email protected]>
    [Mar 26 18:45:58]   notice: License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    [Mar 26 18:45:58]   notice: This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law.
    [Mar 26 18:45:58]     info: Nice level set to 20
    [Mar 26 18:45:58]     info: I/O scheduling class set to 3
    [Mar 26 18:45:58]     info: using TeamSpeak 3 PHP Framework version 1.1.11
    [Mar 26 18:45:58]  warning: [Chat]                        This plugin may cause a memory flood! Use at own risk!
    [Mar 26 18:45:58]     info: connected to TeamSpeak 3 server at 127.0.0.1
    [Mar 26 18:45:59]     info: logged in as user serveradmin
    [Mar 26 18:45:59]     info: joned server at port 9988
    [Mar 26 18:45:59]   notice: [AntiRecording]               plugin enabled punishment set to kick, using server group(s) 9,10, using query group(s) 2
    [Mar 26 18:45:59]   notice: [AutoAFK]                     plugin enabled, using channel xxxx(46) as AFK channel, using channel xxx(46) as sound mute channel, using server group(s) 9, using query group(s) 2
    [Mar 26 18:45:59]   notice: [AutoJoin]                    plugin enabled using using channel xxxx (cid: 3)
    [Mar 26 18:45:59]   notice: [BadChannelNames]             plugin disabled
    [Mar 26 18:45:59]   notice: [BadNickNames]                plugin disabled
    [Mar 26 18:45:59]   notice: [Chat]                        plugin enabled, accepting private messages, loaded chat commands: help,memory,moveall,moveservergroup,pokeall,pokeservergroup,version
    [Mar 26 18:45:59]   notice: [CheckUploadedFiles]          plugin disabled
    [Mar 26 18:45:59]   notice: [DumpIP]                      plugin disabled
    [Mar 26 18:45:59]   notice: [IlligalClientChars]          plugin disabled
    [Mar 26 18:45:59]     info: [AutoJoin]                    joined channel xxxxx (cid: 3)
    --- Merged ---

    Yeah, I'm using Ubuntu 11.04 but just checked clean version of bot without any plugins and there is the same issue!

    --- Merged ---

    it's 2.6.18-308.el5.028stab099.3

    The problem is my VPS host doesn't allow changing kernel.
    Last edited by florian_fr40; March 29th, 2012 at 09:39 AM.

  5. #335
    Join Date
    January 2010
    Location
    need not to know
    Posts
    26
    hey kwiski43 sorry dude but my problem didnt got reseolved by downgrading my system to 10.04 LTS .. i just spent my whole evening to make those downgrades and the bots AUTOAFK is still making him disconnect.

    Running on Ubuntu 10.04 LTS with 2.6.38-13 Kernel
    on a TS3-Server-Version: 3.0.3 (17.03.2012 07:12:11) Linux

  6. #336
    Join Date
    January 2010
    Location
    Germany
    Posts
    252
    Quote Originally Posted by Neytiri86 View Post
    hey kwiski43 sorry dude but my problem didnt got reseolved by downgrading my system to 10.04 LTS .. i just spent my whole evening to make those downgrades and the bots AUTOAFK is still making him disconnect.

    Running on Ubuntu 10.04 LTS with 2.6.38-13 Kernel
    on a TS3-Server-Version: 3.0.3 (17.03.2012 07:12:11) Linux
    Nice catch. I'll try to reproduce the problem this weekend. As Neytiri says it seems that the AutoAFK plugin is causing this error.

  7. #337
    Join Date
    March 2012
    Posts
    1

    Auto Afk

    Dear Teamspeak Community,

    I've done a lot of research on how to set up an Auto AFK setting for team speak between google and even some searches on this forum site but I still cannot find a simple solution. I did not set up my team speak server but I am a server administrator.

    Please help me learn how to set up an AFK setting for teamspeak where after X amount of time (lets say 20 mins) of inactivity that person gets moved to a channel designated "AFK" It seems simple enough to me but seems to be quite hard to find a solution.

    TIA,

    Dave

    Edit, thread got moved and has nothing to do with our SDK itself
    Last edited by dante696; March 28th, 2012 at 01:29 PM.

  8. #338
    Join Date
    January 2010
    Location
    Germany
    Posts
    252

    Exclamation

    I'm sorry, but the gremlins got into the AdvertisingMessage tarball. So i had to re-upload the plugin. If you are using the AdvertisingMessage please re-download the plugin from http://urbach-webhosting.de/download...1#qt-downloads

    --- Merged ---

    Quote Originally Posted by hoffinon View Post
    Please help me learn how to set up an AFK setting for teamspeak where after X amount of time (lets say 20 mins) of inactivity that person gets moved to a channel designated "AFK" It seems simple enough to me but seems to be quite hard to find a solution.
    Goto http://urbach-webhosting.de/downloads and download the TS3PHPBot core version and the AutoAFK plugin. Extract both tarballs to an directroy of your choise (keep the file structure intact). Then go into to the config/ folder and configure all INI files.

    If you've trouble configuring the TS3PHPBot feel free to contact me.

    Note: PHP5.3.2 with cURL extension, TeamSpeak 3 at least version 3.0.0-rc1 and at least a Kernel version 2.6.13 is mandatory.
    Last edited by florian_fr40; March 29th, 2012 at 09:40 AM.

  9. #339
    Join Date
    February 2009
    Location
    Poland
    Posts
    13
    After some testing plugins which makes bot crash after join are AutoAFK and AntiRecording. Also looks like ./ts3phpbot.sh stop does not stop bot for me, process is still active and must be manually killed.
    Last edited by kwski43; March 28th, 2012 at 09:09 PM.

  10. #340
    Join Date
    January 2010
    Location
    need not to know
    Posts
    26
    Hey guys,
    I did some sourcecode research tonight and found some problems in one or two plugins .

    For everybody with the Bot crashing after activating AutoAFK or AntiRecording just simple download and install StickyChannel and enable it and set stickychannel same as afkchannel somehow faral made a dependencie between those two plugins^^

    So DOWNLOAD AND INSTALL AutoAFK or AntiRecording and StickyChannel for those who have the Bot-Crash on AutoAFK or AntiRecording enabled problem.


    BTW Faralsimbor you can add
    Ubuntu 12.04 LTS with Kernel 3.2.0-20-generic-pae
    Teamspeak3 Server 3.0.5-pre1 (28.03.2012 11:57:01)
    to the bots supported configuration list
    Last edited by Neytiri86; March 29th, 2012 at 12:28 PM.

  11. #341
    Join Date
    January 2010
    Location
    Germany
    Posts
    252
    For those who have the Bot-Crash on AutoAFK, AntiRecording, Illigal Client Chars or Bad Nicknames please update this plugins to version 2.0.1

    Quote Originally Posted by kwski43 View Post
    ... looks like ./ts3phpbot.sh stop does not stop bot for me, process is still active and must be manually killed.
    edit the file class/TS3Bot/Helper/RemoteControl.php and uncomment the following code (remove the /* and */ )

    Line 56 - 63

    Code:
    usleep(1000);
    if (file_exists($pidFilename)) {
     echo "gracefull shutdown failed - sending kill signal\n";
     posix_kill($data, SIGQUIT); // force execution of plugin shutdown functions
     usleep(250);
     @posix_kill($data, SIGKILL);
     @unlink($pidFilename);
    }
    Note that this code is experimental and may not be used in an productive enviroment!
    Last edited by florian_fr40; April 1st, 2012 at 10:58 PM.

  12. #342
    Join Date
    October 2006
    Location
    Germany
    Posts
    30
    Hi my problem ist this:


    starting config/virtualServer/9987...\tTue, 03 Apr 2012 12:03:24 +0200 TS3PHPBot: [EMERG] The file "=config/daemon.ini" is not readable, file exists?

    Yes the file is there and it has 744

  13. #343
    Join Date
    January 2010
    Location
    Germany
    Posts
    252
    Quote Originally Posted by Micromac View Post
    starting config/virtualServer/9987...\tTue, 03 Apr 2012 12:03:24 +0200 TS3PHPBot: [EMERG] The file "=config/daemon.ini" is not readable, file exists?
    Got to http://urbach-webhosting.de/node/47 and download the updated startscript. It seems that your system did not understand the = as parameter delimiter e.g.: ./ts3phpbot.php -d=config/daemon.ini ... . instead your system requires a blank e.g: ./ts3phpbot.php -d config/daemon.ini ... .

  14. #344
    Join Date
    December 2009
    Location
    ger
    Posts
    12
    Hi i don´t understand my problem.

    When i start the Bot i get this error:

    ./ts3phpbot.sh start
    starting all instances of ts3phpbot:
    starting config/virtualServer/9987...\tsh: /uname: No such file or directory
    PHP Notice: Undefined offset: 0 in /home/ts3phpbot/class/TS3Bot/Abstract.php on line 165
    PHP Notice: Undefined offset: 0 in /home/ts3phpbot/class/TS3Bot/Abstract.php on line 167
    Thu, 12 Apr 2012 19:30:29 +0200 TS3PHPBot: [EMERG] You are using an outdated Kernel. At least Kernel version 2.6.13 is required to run this daemon
    done\n

    I don´t understand whats wrong in the PHP-files and my actually kernel is

    uname -r
    2.6.32-028stab094.3

    i hope you cn help me

    Thanks Vinter

  15. #345
    Join Date
    January 2010
    Location
    Germany
    Posts
    252
    Quote Originally Posted by Vinterland View Post
    starting config/virtualServer/9987...\tsh: /uname: No such file or directory
    PHP Notice: Undefined offset: 0 in /home/ts3phpbot/class/TS3Bot/Abstract.php on line 165
    PHP Notice: Undefined offset: 0 in /home/ts3phpbot/class/TS3Bot/Abstract.php on line 167
    Thu, 12 Apr 2012 19:30:29 +0200 TS3PHPBot: [EMERG] You are using an outdated Kernel. At least Kernel version 2.6.13 is required to run this daemon
    This message says that the command "uname" is not executable with the user you've stated the bot with.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Release] TS3PHPBot-Plugin
    By Neytiri86 in forum Tools / Web Based
    Replies: 0
    Last Post: August 25th, 2010, 12:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •