Forum

Page 123 of 140 FirstFirst ... 2373113121122123124125133 ... LastLast
Results 1,831 to 1,845 of 2089
  1. #1831
    Join Date
    December 2015
    Posts
    3
    2016-07-31 08:38:57 JTS3ServerMod STATUS Virtual bot instance "bot1" starts now (build 6105)
    2016-07-31 08:38:57 JTS3ServerMod STATUS Activate log level: INFO
    2016-07-31 08:38:57 JTS3ServerMod INFO Successful connected to basalt.typefrag.com!
    2016-07-31 08:38:58 JTS3ServerMod INFO Login as "Melinia" successful!
    2016-07-31 08:38:58 JTS3ServerMod INFO Successful selected virtual server on port 5215!
    2016-07-31 08:38:58 JTS3ServerMod WARNING Unable to receive permission list! If possible, please set the permission "b_serverinstance_permission_list" to the bot query account "Melinia" or the "Guest Server Query" group.
    2016-07-31 08:38:59 JTS3ServerMod ERROR Unable to receive private chat messages!
    2016-07-31 08:38:59 JTS3ServerMod EXCEPTION de.stefan1200.jts3serverquery.TS3ServerQueryExcept ion: ServerQuery Error 3331: flood ban
    2016-07-31 08:38:59 JTS3ServerMod ERROR Unable to receive server chat messages!
    2016-07-31 08:38:59 JTS3ServerMod EXCEPTION java.lang.IllegalStateException: null object, maybe connection to TS3 server interrupted.
    2016-07-31 08:38:59 JTS3ServerMod ERROR Error while getting channel list!
    2016-07-31 08:38:59 JTS3ServerMod EXCEPTION java.lang.IllegalStateException: Not connected to TS3 server!
    2016-07-31 08:38:59 JTS3ServerMod INFO Unloaded all functions!
    2016-07-31 08:38:59 JTS3ServerMod STATUS Virtual bot instance "bot1" stopped

    I've given it permissions and I've whitelisted the bot. Any help?

  2. #1832
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by Goldio View Post
    I've whitelisted the bot.
    Seems not, because the bold message is from the TS3 server:
    2016-07-31 08:38:59 JTS3ServerMod EXCEPTION de.stefan1200.jts3serverquery.TS3ServerQueryExcept ion: ServerQuery Error 3331: flood ban

  3. #1833
    Join Date
    December 2015
    Posts
    3
    I thought I whitelisted it but I guess not. Is there a guide on how to properly do it because of searched and found nothing useful. The server is through Typefrag.com and doesn't list anywhere on there how to whitelist and there's nothing on my ban list on the control panel or through TS3 itself.

  4. #1834
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by Goldio View Post
    I thought I whitelisted it but I guess not. Is there a guide on how to properly do it because of searched and found nothing useful. The server is through Typefrag.com and doesn't list anywhere on there how to whitelist and there's nothing on my ban list on the control panel or through TS3 itself.
    As I wrote in the manual, the IP address of the machine, where the JTS3ServerMod is running, has to be whitelisted by the global TS3 server admin using the query_ip_whitelist.txt file on the server.

    But if you don't have access to it and the global TS3 server admin will not whitelist it for you, you can try the bot_slowmode = 1 in the bot settings. But you have to wait 10 minutes after the last start of the JTS3ServerMod to get your ip address unbanned.

    Query bans like this will not be displayed on your own TS3 server, because that is a global ban for the whole TS3 server process.

  5. #1835
    Join Date
    June 2013
    Posts
    16

    welcome message problem

    Hi everyone

    I have a problem by welcome message.

    When user connect to teamspeak server JTS3ServerMod sent 2 Messages to user.
    How fix this problem until sent one message to users.

    & I have a question :
    When I change config files {Exp:automove.cfg , idlemessages.cfg , ...} Should be JTS3ServerMod restarted ? Its not good . how can do this work without restarting ?

  6. #1836
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by clack View Post
    I have a problem by welcome message.

    When user connect to teamspeak server JTS3ServerMod sent 2 Messages to user.
    How fix this problem until sent one message to users.
    Please send me the log file of the bot (by default named JTS3ServerMod_server1.log).

  7. #1837
    Join Date
    June 2013
    Posts
    16
    Quote Originally Posted by Stefan1200 View Post
    Please send me the log file of the bot (by default named JTS3ServerMod_server1.log).
    Code:
    2016-07-31 21:28:57	JTS3ServerMod	STATUS	Virtual bot instance "bot1" starts now (build 6105)
    2016-07-31 21:28:57	JTS3ServerMod	STATUS	Activate log level: INFO
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: Advertising / advertising
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: AutoMove / automove
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: AwayMover / away
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: BadChannelNameCheck / badchannelname
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: BadNicknameCheck / badnickname
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: ChannelNotify / channelnotify
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: IdleCheck / idle
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: InactiveChannelCheck / icc
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: LastSeen / lastseen
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: MuteMover / mute
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: RecordCheck / record
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: ServerGroupNotify / servergroupnotify
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: ServerGroupProtection / servergroupprotection
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: WelcomeMessage / welcome
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Successfully loaded function: WelcomeMessage / welcome_guest
    2016-07-31 21:28:57	JTS3ServerMod	INFO	Timezone successfully set to: Iran
    2016-07-31 21:28:57	Function channelnotify	ERROR	Exception in loadConfig(), disable() or activate()!
    2016-07-31 21:28:57	Function channelnotify	EXCEPTION	java.lang.NumberFormatException: Config value of "channelnotify_channel_id" is not a number! Current value: 
    2016-07-31 21:28:57	Function mute	ERROR	Exception in loadConfig(), disable() or activate()!
    2016-07-31 21:28:57	Function mute	EXCEPTION	de.stefan1200.jts3servermod.BotConfigurationException: Headphone and Microphone detection in config disabled!
    2016-07-31 21:28:57	Function record	ERROR	Exception in loadConfig(), disable() or activate()!
    2016-07-31 21:28:57	Function record	EXCEPTION	java.lang.NumberFormatException: Config value of "record_channel_id" is not a number! Current value: 
    2016-07-31 21:28:57	Function servergroupnotify	ERROR	Exception in loadConfig(), disable() or activate()!
    2016-07-31 21:28:57	Function servergroupnotify	EXCEPTION	de.stefan1200.jts3servermod.BotConfigurationException: No server groups in bot configuration set. Check config values of servergroupnotify_groups and servergroupnotify_grouptargets
    2016-07-31 21:28:57	Function servergroupprotection	ERROR	Exception in loadConfig(), disable() or activate()!
    2016-07-31 21:28:57	Function servergroupprotection	EXCEPTION	de.stefan1200.jts3servermod.BotConfigurationException: Server Group Protection needs at least one server group set! Check config key: servergroupprotection_groups
    2016-07-31 21:28:58	JTS3ServerMod	INFO	Successful connected to ts.com!
    2016-07-31 21:28:58	JTS3ServerMod	INFO	Login as "serveradmin" successful!
    2016-07-31 21:28:58	JTS3ServerMod	INFO	Successful selected virtual server on port 1000!
    2016-07-31 21:29:00	JTS3ServerMod	INFO	Server connection log is activated and will be written into the file: C:\Users\IBS\Desktop\JTS3ServerMod_6.1.5\JTS3ServerMod\JTS3ServerMod_server1_login.csv
    2016-07-31 21:29:00	JTS3ServerMod	INFO	Creating client database cache...
    2016-07-31 21:29:00	Function advertising	INFO	Advertising will be send to virtual server every 30 minutes (1 messages found)
    2016-07-31 21:29:00	Function automove	INFO	Auto Move is enabled, default channels for 1 server groups set
    2016-07-31 21:29:00	Function away	INFO	Clients with away status will be moved to Channel "AFK" (id: 736) after 5 seconds and moved back if not away anymore!
    2016-07-31 21:29:00	Function badchannelname	INFO	Bad Channel Name Check is enabled, 3 rules loaded and matching channel names will be deleted, if rename is not possible!
    2016-07-31 21:29:00	Function badnickname	INFO	Bad Nickname Check is enabled, 3 rules loaded (client will be kicked)
    2016-07-31 21:29:00	Function idle	INFO	Clients will be moved into Channel "AFK" (id: 736) after being idle for 10 minutes (if min 1 clients online). Clients will be moved back, if not idle anymore.
    2016-07-31 21:29:00	Function icc	INFO	Delete semi-permanent channels if empty for at least 168 hours!
    2016-07-31 21:29:00	Function lastseen	INFO	Check the last seen time of a client with the command !lastseen, this can be used by bot admins!
    2016-07-31 21:29:00	Function record	INFO	Clients will be moved into Channel "null" (id: -1) after start recording
    2016-07-31 21:29:00	Function welcome	INFO	All new connecting clients get the welcome message from file config/server1/welcomemessages.cfg
    2016-07-31 21:29:00	Function welcome_guest	INFO	All new connecting clients get the welcome message from file config/server1/welcomemessages.cfg
    2016-07-31 21:29:00	JTS3ServerMod	INFO	Bot started and connected successful, write !botinfo in server chat to get an answer!
    2016-07-31 21:29:05	JTS3ServerMod	INFO	Client database cache created, 7 clients in cache.
    2016-07-31 21:29:28	Function automove	INFO	Client "IboE" (db id: 1455) has connected, moved to channel: sd(id: 759)
    2016-07-31 21:29:39	Function away	INFO	Client status of "IboE" (db id: 1455) is away, client was moved!

  8. #1838
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    @ clack: Well, there are some errors, which you should fix.

    But the reason, why you have two welcome messages:
    2016-07-31 21:29:00 Function welcome INFO All new connecting clients get the welcome message from file config/server1/welcomemessages.cfg
    2016-07-31 21:29:00 Function welcome_guest INFO All new connecting clients get the welcome message from file config/server1/welcomemessages.cfg
    You configured two welcome messages (welcome and welcome_guest) to do the same...

  9. #1839
    Join Date
    June 2013
    Posts
    16
    Quote Originally Posted by Stefan1200 View Post
    @ clack: Well, there are some errors, which you should fix.

    But the reason, why you have two welcome messages:


    You configured two welcome messages (welcome and welcome_guest) to do the same...
    Thank you. This fixed.

    when a user connect to server by special group moving to the special channel ,now.
    How i can set a special channel that when users by special server group join it moving to another channel(that i chose it) ??

  10. #1840
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by clack View Post
    How i can set a special channel that when users by special server group join it moving to another channel(that i chose it) ??
    Such a function don't exists. I also don't know why someone would need this.

  11. #1841
    Join Date
    June 2013
    Posts
    16
    Quote Originally Posted by Stefan1200 View Post
    Such a function don't exists. I also don't know why someone would need this.
    When users connect to teamspeak server moving to the channel.
    But this is not good because maybe users not wanting to moving to your special channel.
    & this work helping to teamspeak servers that have very much channels.

    & you said : there are some errors, which you should fix.
    How Fix there ERRORs ?

    &
    When I change config files {Exp:automove.cfg , idlemessages.cfg , ...} Should be JTS3ServerMod restarted ? Its not good . how can do this work without restarting ?

  12. #1842
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by clack View Post
    & you said : there are some errors, which you should fix.
    How Fix there ERRORs ?
    By reading and understanding the error messages in the log file, see bold text here:
    2016-07-31 21:28:57 Function channelnotify EXCEPTION java.lang.NumberFormatException: Config value of "channelnotify_channel_id" is not a number! Current value:
    2016-07-31 21:28:57 Function mute EXCEPTION de.stefan1200.jts3servermod.BotConfigurationExcept ion: Headphone and Microphone detection in config disabled!
    2016-07-31 21:28:57 Function record EXCEPTION java.lang.NumberFormatException: Config value of "record_channel_id" is not a number! Current value:
    2016-07-31 21:28:57 Function servergroupnotify EXCEPTION de.stefan1200.jts3servermod.BotConfigurationExcept ion: No server groups in bot configuration set. Check config values of servergroupnotify_groups and servergroupnotify_grouptargets
    2016-07-31 21:28:57 Function servergroupprotection EXCEPTION de.stefan1200.jts3servermod.BotConfigurationExcept ion: Server Group Protection needs at least one server group set! Check config key: servergroupprotection_groups

    Quote Originally Posted by clack View Post
    When I change config files {Exp:automove.cfg , idlemessages.cfg , ...} Should be JTS3ServerMod restarted ? Its not good . how can do this work without restarting ?
    Using the chat command: !botcfgreload

  13. #1843
    Join Date
    January 2015
    Posts
    4

    Adding JTS3ServerMod

    Hey all,

    I'm looking for some help. I'm having quite a bit of trouble getting the JTS3 mod set up.

    Would I be able to have someone join my teamspeak and set it up for me?

    Any help would be appreciated.


    http://forum.teamspeak.com/threads/5...Mute-Welcome-)

    Regards
    Last edited by dante696; August 8th, 2016 at 03:13 PM. Reason: merged

  14. #1844
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    Quote Originally Posted by Futcher View Post
    I'm looking for some help. I'm having quite a bit of trouble getting the JTS3 mod set up.
    If you want, send me your JTS3ServerMod_server1.log file to my mail address and a description which kind of problems you have.

  15. #1845
    Join Date
    July 2016
    Posts
    4

    !msgchannel issue

    Hello Stefan1200, I am using JTS3Servermod bot. This is a great bot, but I have a little problem using the !msg command. I am Bot admin and i can use the command, but no one recieve my messages.

    HTML Code:
    <04:03:08> "ME": !msgchannelgroup 79 Hello guys!
    <04:03:08> "Server Bot": Message sent to 0 clients!
    I know there is people in the channel i am sending it to, but they dont revieve anything..
    Would really appreciate help to figure it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [No Bug] Idle Time even thou people are not idle.
    By brewek in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: November 10th, 2011, 04:27 PM
  2. [Resolved] JTS3ServerMod server query permission help
    By n406c in forum Permission System
    Replies: 2
    Last Post: April 1st, 2011, 11:08 PM
  3. Replies: 4
    Last Post: January 9th, 2011, 03:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •