Forum

Page 59 of 140 FirstFirst ... 949575859606169109 ... LastLast
Results 871 to 885 of 2089
  1. #871
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    @ sgtrwe: Thanks for your suggestion. Currently only two different welcome message are possible. It was on my ToDo list to change that, but in the near future I have no time for bigger changes. Currently I focus on smaller changes and bugfixes. But I don't forget your suggestion, maybe someday in the far future :-)
    Last edited by Stefan1200; November 9th, 2011 at 08:39 AM.

  2. #872
    Join Date
    November 2011
    Posts
    33
    I've recently tried to install and use this bot. It connects to my teamspeak correctly, but doesn't work. It doesn't respond to !botinfo, nor does it move anyone, or do anything when using bad words in nicknames. It's as if it connects, but that's as far as it gets. I think i may be doing something wrong. My log file is in attachments.
    Attached Files Attached Files

  3. #873
    Join Date
    June 2010
    Location
    Germany
    Posts
    27
    Quote Originally Posted by LogicSequence View Post
    I've recently tried to install and use this bot. It connects to my teamspeak correctly, but doesn't work. It doesn't respond to !botinfo, nor does it move anyone, or do anything when using bad words in nicknames. It's as if it connects, but that's as far as it gets. I think i may be doing something wrong. My log file is in attachments.
    Hello, LogicSequence..

    Please take care of these lines in the readme.txt
    -= Needed Permissions for the Bot =-
    Make sure that the following permissions are granted for the bot (in brackets why this permission is needed):
    b_virtualserver_channel_list (Always needed)
    b_virtualserver_client_list (Always needed)
    b_virtualserver_client_dblist (Client Database Cache)
    b_virtualserver_notify_register (Always needed)
    b_serverinstance_permission_list (Displaying missing permission names in log)
    b_channel_delete_permanent (Bad Channel Name Check)
    b_channel_delete_semi_permanent (Bad Channel Name Check)
    b_channel_delete_temporary (Bad Channel Name Check)
    b_channel_delete_flag_force (Bad Channel Name Check)
    b_channel_join_permanent (Allow joining all channels)
    b_channel_join_semi_permanent (Allow joining all channels)
    b_channel_join_temporary (Allow joining all channels)
    b_channel_join_ignore_password (Allow joining all channels)
    i_channel_join_power (Allow joining all channels)
    i_group_member_remove_power (Server Group Protection)
    i_group_member_add_power (Server Group Protection)
    b_group_is_permanent (The bot stay at this group after reconnecting)
    i_client_modify_power (Server Group Protection)
    i_client_kick_from_server_power (Many functions)
    i_client_move_power (Many functions)
    i_client_complain_power (Many functions if complain is enabled)
    i_client_poke_power (Many functions if poke is choosen as message mode)
    i_client_private_textmessage_power (Always needed)
    b_client_channel_textmessage_send (Advertising)
    b_client_server_textmessage_send (Advertising)
    b_client_info_view (Welcome Message)
    b_virtualserver_select (To connect)

    May be needed in later version:
    b_virtualserver_info_view

    The Guest Server Query group also needs:
    b_serverquery_login (To connect)
    Because of this lines in your JTS3ServerMod_server1.log:
    2011-11-15 00:04:21 PERMISSION_CACHE Warning: Unable to receive permission list! If wanted, set permission b_serverinstance_permission_list.
    2011-11-15 00:04:21 PERMISSION_CACHE ServerQuery Error 2568 @ getList(): insufficient client permissions - Permission ID: 4358
    2011-11-15 00:26:25 MOVE_ERROR ServerQuery Error 2568 @ moveClient(): insufficient client permissions - Permission ID: 21181 - Client ID: 5
    2011-11-15 00:04:21 START_ERROR ServerQuery Error 2568 @ moveClient(): insufficient client permissions - Permission ID: 13695
    Check your permissions for the Bot-Server-Group (Admin Server Query)


    //EDIT
    PermissionID 4358: b_serverinstance_permission_list

    - LolRiTTeR

  4. #874
    Join Date
    November 2011
    Posts
    33
    The bot is in the admin server query group, and has all permissions. I got it to log in correctly, i messed up on a database thing. However, it still has a major problem. It won't actually DO ANYTHING. I can use all the !bothelp commands, check last seens, etc... But it won't do anything else, it won't kick people for recording, won't move afk people, won't kick people for bad names, nothing else but interacting via !bothelp type commands.
    Last edited by LogicSequence; November 18th, 2011 at 09:31 AM.

  5. #875
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    Hi LogicSequence, if you solved the permission problems, please send me a new logfile. You can also contact me by a messenger or email to solve this issue faster (see here for contact details).

  6. #876
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    New version:

    Version 3.6.2 Final (20.11.2011)
    + Added Server Group Notify function. If clients from a specified server group joins the server,
    all members of selected server groups get an information by chat or poke message.
    New config values at the end of the JTS3ServerMod_server1.cfg file.
    + Added new keyword for the Server Group Name at the Server Group Protection message.
    - Bugfix: Small bugfix in the client database cache if the TS3 server sends invalid dates.
    o Changed servergroup argument to sgprotection for !botcfgreload command, added sgnotify as argument.
    o Updated JTS3ServerQuery library with smaller changes for the new TS3 server version.
    JTS3ServerMod should still be compatible with older TS3 servers, because the changed stuff are not used by the bot.
    Like always: Download link and more informations at the first post on page 1.

  7. #877
    Join Date
    November 2011
    Posts
    33
    I think i got everything working finally. Just a complicated series of issues i had to work through on my end. However, i do have a question:

    Some people on my server are complaining that they're getting the "chat message received" sound every time the bot advertises. Is there a way to disable this sound for the server chat window and not channel chats?

  8. #878
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    Quote Originally Posted by LogicSequence View Post
    Some people on my server are complaining that they're getting the "chat message received" sound every time the bot advertises. Is there a way to disable this sound for the server chat window and not channel chats?
    I think this is not possible. And unfortunately this is nothing I can change on my end.

  9. #879
    Join Date
    December 2010
    Location
    Belgium
    Posts
    51

    How to run JTS3

    I just installed my JTS3server mod on linux server

    How can i run the .exe of it
    cuz server is running on linux and i cant just double click the file to run it
    whats the console command for it ?

    thank you

    *** Thread Merged ***
    Last edited by florian_fr40; November 27th, 2011 at 09:00 AM.

  10. #880
    Join Date
    December 2009
    Location
    Holland
    Posts
    37

    Post Switching to afk channel

    Hello,

    This question is probably asked before bud I can't find the answer.

    If somebody uses the "set globally away" I want them to switch to a AFK channel.

    How can make this happen?

    Thank you

    Edit by mod
    Thread merged. This tool can help you.
    Last edited by florian_fr40; November 27th, 2011 at 05:07 PM.

  11. #881
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    Quote Originally Posted by Creativeee View Post
    cuz server is running on linux and i cant just double click the file to run it
    whats the console command for it ?
    Please read the readme.txt or documents/readme.html file of the bot.

  12. #882
    Join Date
    June 2011
    Location
    Russian Federation
    Posts
    204
    Good evening, dear friends! I have a question about the bot!
    Boat excellent, it works fine without any complaints, bugs and TE
    My question is this:

    the fact that I have teamspeak 3 server (last version) is on a virtual machine running Linux (Ubuntu - 11.10) I'm running a bot with a parameter
    screen-d-m-S ts3bot java-jar JTS3ServerMod.jar for all that I have it eats 15% of memory. tell me! Do I understand correctly that if I have a bot run with the screen-d-m-S ts3bot java-mx30M-jar JTS3ServerMod.jar, I reduced the memory? if so, by how much?

    and that this change? speed? work ability? slower or faster will be?
    Last edited by Ar2rJke; November 29th, 2011 at 05:47 PM.

  13. #883
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    @ Ar2rJke: The command
    screen -d -m -S ts3bot java -mx30M -jar JTS3ServerMod.jar
    limit the memory usage to 30 MB (but this does not match with the information of the linux ps / top command, because they also count other stuff by the java virtual machine).

    A single bot on smaller TS3 servers don't need much memory (less than 20 MB including the java vm), it is just the linux java vm which reserves much memory (but never need it).

  14. #884
    Join Date
    February 2010
    Location
    Internet
    Posts
    62
    Hi,
    Seems to work, but, the log shows:

    java.lang.NumberFormatException: For input string: "653
    l_id=69608"
    at java.lang.NumberFormatException.forInputString(Unk nown Source)
    at java.lang.Integer.parseInt(Unknown Source)
    at java.lang.Integer.parseInt(Unknown Source)
    at de.stefan1200.jts3servermod.JTS3ServerMod.checkTS3 Clients(JTS3ServerMod.java:3086)
    at de.stefan1200.jts3servermod.JTS3ServerMod.runCheck (JTS3ServerMod.java:4269)
    at de.stefan1200.jts3servermod.JTS3ServerMod.access$5 (JTS3ServerMod.java:4265)
    at de.stefan1200.jts3servermod.JTS3ServerMod$7.run(JT S3ServerMod.java:4303)
    at java.util.TimerThread.mainLoop(Unknown Source)
    at java.util.TimerThread.run(Unknown Source)

    2011-12-17 17:54:32 WARNING An error occurred, make sure that you use at least TS3 server version beta 19!
    2011-12-17 17:54:32 Server_2: EXCEPTION - Bot Version: 3.6.2 Final (20.11.2011)
    java.lang.NullPointerException
    at de.stefan1200.jts3servermod.JTS3ServerMod.checkTS3 Clients(JTS3ServerMod.java:3084)
    at de.stefan1200.jts3servermod.JTS3ServerMod.runCheck (JTS3ServerMod.java:4269)
    at de.stefan1200.jts3servermod.JTS3ServerMod.access$5 (JTS3ServerMod.java:4265)
    at de.stefan1200.jts3servermod.JTS3ServerMod$7.run(JT S3ServerMod.java:4303)
    at java.util.TimerThread.mainLoop(Unknown Source)
    at java.util.TimerThread.run(Unknown Source)
    2011-12-17 17:56:54 STOP_MOD Virtual bot instance stopped

    And others...

    Version:3.0.1 (17/11/2011 05:34:30) on Linux

    Please,
    Can you help me?

  15. #885
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    @ TeamSpeak3: It seems that the TS3 server answeres with wrong and invalid data. Maybe the bot gets flood banned while it do the work. Did you added the IP address of the bot to the query_ip_whitelist.txt file? Or do you use the slow mode without modification to this file?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. [No Bug] Idle Time even thou people are not idle.
    By brewek in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: November 10th, 2011, 03:27 PM
  2. [Resolved] JTS3ServerMod server query permission help
    By n406c in forum Permission System
    Replies: 2
    Last Post: April 1st, 2011, 10:08 PM
  3. Replies: 4
    Last Post: January 9th, 2011, 02:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •