Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    February 2010
    Location
    Poland
    Posts
    1

    Server start normally but u CANT still connect? look here

    Edit by mod
    NEVER make a changes directly in the database for that. Use the start parameter - Look at server_quickstart.txt


    Hiho,

    If u:
    - have more then 1 ip binded to server
    - opened all ts3 ports in iptables
    - checked logs where everything is fine
    - checked if ts3 process is up - and it it
    - can connect via query

    and still can't join ur server, do this:

    1. delete all u have atm
    2. wget and tar last beta
    3. go to sql/
    4. edit defaults.sql
    Find:
    Code:
    -- bindings
    insert into bindings (ip, type) values ("0.0.0.0", 0);
    and insert ur Ip which will be used for connecting to ts, for ex:
    Code:
    -- bindings
    insert into bindings (ip, type) values ("120.215.176.244", 0);
    5. save file
    6. start server.

    its worked for me.
    (debian5 32, 2ips)
    Last edited by florian_fr40; November 15th, 2011 at 11:59 AM.

  2. #2
    Join Date
    January 2010
    Location
    France - Paris
    Posts
    3
    ...
    interesting
    thanks

  3. #3
    Join Date
    March 2010
    Location
    Bristol, UK
    Posts
    3
    I can confirm this works for Linux machines (Fedora 12 x8) with multiple IP addresses.

    While I could connect @ localhost 10011 for queries, any connections to 9987 on any ip address from the machine itself, or externally were refused.

    Changing this default 0.0.0.0 binding to one of the many ip addresses has resolved the issue. What is interesting is that a netstat shows that 9987 was actually being bound to on * but just didn't respond.

    Excellent fix, thank you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: January 21st, 2014, 11:57 PM
  2. Server Start but not connect
    By heberpcl in forum Linux / FreeBSD
    Replies: 3
    Last Post: October 22nd, 2012, 09:51 PM
  3. TS3 Server start fine but cant connect
    By Silfro in forum Linux / FreeBSD
    Replies: 0
    Last Post: June 9th, 2011, 08:29 PM
  4. Server wont start/can't connect?
    By ClarelAkaKurt in forum Windows
    Replies: 1
    Last Post: March 22nd, 2011, 09:20 AM
  5. [solved] Cant use/start/connect to my own NPL Server
    By Cnopie in forum Server Support
    Replies: 14
    Last Post: August 24th, 2010, 08:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •