Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    December 2009
    Location
    France
    Posts
    11

    Question 3D sound and 5.1 / surround

    I made a plugin which use the 3D sound function (fmod_Channelset3DAttributes) with ArmA 2.
    The plugin is available here (source code too)
    But some users reported a problem with 5.1 / surround system.

    We noticed

    problems
    headphones stereo emulator 3D works 9 of 10 (only sound behind sometimes you hear like in the front)
    headphones true 5.1 does not work properly (front and back misleading)

    or maybe someting must be set up.
    Sorry I'm asking but search function found nothing for 'back, behind, 3D' words.

    We noticed that sound mapping is only in stereo. No surround mapping.
    It is limitation of current version or we forgot about something.

    Note, that we are 3D enabled in TS3 settings.

    Best regards
    I do not have a 5.1 so I can't confirm.
    Is it a teamspeak side bug, a plugin side bug or this users have problems with their settings ?

  2. #2
    Join Date
    December 2009
    Location
    France
    Posts
    11
    A have a more interesting report:

    more test taken.

    a2t v2
    creative X-FI, speakers 5.1, win7 32

    I can not make front and side speakers work at the same time to emulate off centre position.

    example:
    person at 12 o'clock -> front speaker only
    person at 1 or 2 oclock -> right speaker only
    there is not middle position of sound for 1-2 o'clock,. should be front&right speaker.

    during testing 3D Setup in teamspeak every thing works OK.

  3. #3
    Join Date
    December 2009
    Location
    France
    Posts
    11
    I am definitely an idiot !
    I inverted Y and Z axis because the Z axis is the height in the game.... but not in teamspeak.
    So it works like a charm now !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TeamSpeak 3 no surround sound
    By Litey in forum Windows
    Replies: 3
    Last Post: November 27th, 2017, 01:28 PM
  2. 3D sound in surround/stereo?
    By MartinA in forum General Questions
    Replies: 1
    Last Post: May 4th, 2012, 09:17 PM
  3. Surround Sound Cutting Out
    By Alpha52 in forum Windows
    Replies: 2
    Last Post: April 16th, 2011, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •