Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 10 of 10
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    14

    Howto fix 100% CPU in Ubuntu 9.10 (the easy way)

    i have created a simple solution to fix this problem

    do this:
    open Teamspeak 3
    go to Settings>Options>Playback
    select Alsa
    close Teamspeak 3

    -

    open terminal
    type:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    Code:
    sudo apt-get update && sudo apt-get dist-upgrade
    and the Problem is gone
    (tested on 5 different machines running ubuntu 9.10)

    make sure you remove the line in
    Code:
    /etc/apt/sources.list
    after you upgraded pulseaudio, because this stuff is for testing.


    Only do this stuff below if upgrading Pulseaudio still givs the 100%CPU bug
    |
    v


    type
    Code:
    sudo gedit
    write "autospawn = no", save it in /home/your_username/.pulse/client.conf
    (hit strg+h to see hidden files, "client.conf" doesnt exist, its normal, just create it)
    (the line in client.conf says: do not restart pulseaudio)
    and then, before you start ts3, type
    Code:
    pulseaudio -k
    in a terminal
    (pulseaudio -k stops pulseaudio)

    Start ts3 > done

    if you want to use pulseaudio again, restart, or type "pulseaudio -D" in a terminal

    sry for my bad english, it's not my native language
    Last edited by cr4wl; March 6th, 2010 at 06:20 AM.

  2. #2
    Join Date
    December 2009
    Location
    Poland / Wrocław (Breslau)
    Posts
    15
    Thanks, it helped. It fixed my microphone so I can communicate with my friends over LAN. I still get the bug (I didn't follow your guide to the end, i only upgraded PA and that's all). I don't want to disable PA, because i'm using it to connect my Laptop to external speakers via wifi-n.

    I'm using Ubuntu 9.10 32bit on Intel Atom CPU (N330). By the way, TS3 eats nearly 20% of one of my cores on idle, 40% when i'm talking. I know Intel Atom is weak, but... is this normal? I don't own a netbook with windows so I can't test it myself.

    Even if TS3 will work on PA through ALSA, i still want to use native PA for its features. I hope the FMOD guys will create PA backend.

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    14

    re

    Jep, TS3 eats alot of CPU on my Windows Machine (25%)

    under Linux, the Problem with the CPU Usage was gone since i disable pulseaudio when i use teamspeak (i enable it when i close teamspeak 3 by typing "pulseaudio -D")
    When PulseAudio is enabled, TS3 eats 15-30% on my 2.2ghz dualcore (when mic is used, 100%CPU all the time) .. pulseaudio needs more Power then Alsa native too, but Mumble needs like 2% CPU with enabled Pulseaudio, so it's a little bit confusing.
    Some guys wrote that its getting better on 10.04 (tested the Alpha3)
    so i hope on 10.04 Final the Problem is gone ..

    I hope also the Teamspeak Guys just adding full PulseAudio Support in the Final, and not going to emulated Alsa.

    I think i made some mistakes to write correct English, sry for that

  4. #4
    Join Date
    January 2010
    Location
    US
    Posts
    8
    Well, that didn't work either.

    After doing the pulseaudio upgrade detailed above, TS3 was still eating 100% of my CPU. So I killed pulseaudio as well (pulseaudio -k). Now I get sound in TS3, but not in most games (Urban Terror, Nexuiz).

    Strangely, other sound apps still work (RhythmBox) even though I would have thought they relied on PulseAudio.

    So this isn't fixed yet.

  5. #5
    Join Date
    December 2009
    Location
    Dublin, Ireland
    Posts
    379
    didnt work for me either.

  6. #6
    Join Date
    August 2008
    Location
    city 17
    Posts
    7
    not working.. just for the first 2 minutes.. then the CPU graph hits the top again
    (using ubuntu 9.10)
    Last edited by W4RH4WK; March 21st, 2010 at 04:21 PM.

  7. #7
    Join Date
    December 2009
    Location
    Tunisia
    Posts
    37

    Ubuntu 10.04 will solve a lot

    Since Friday Night i test Ubuntu 10.04 with pulseaudio and also with an bluetooth headset (Plantronics Voyager 520) and it seems that a lot of problems will gone.

    With normal sound i really can work as well as under Win7 or XP.

    The Bluetooth make a lot of trouble in this moment, but under Ubuntu 9.04 i can not use it, because the pulse problem.

    So wait till the final release of 10.04 is online or test also like me the beta of Ubuntu 10.04 in this moment.

  8. #8
    Join Date
    December 2009
    Location
    Dublin, Ireland
    Posts
    379
    i upgraded to 10.04 beta, and i have not had pulse problems.
    If i do have problems i will update my post.

  9. #9
    Join Date
    March 2010
    Location
    Lancaster, Pennsylvania
    Posts
    1

    GreaT!

    Cr4wl, killing pulse audio worked! Do you know how to make it so it automatically kills pulse when Teamspeak starts and starts it when the program is closed?

    Thanks a bunch!

  10. #10
    Join Date
    August 2008
    Location
    city 17
    Posts
    7
    Quote Originally Posted by ChoiceForGrowth20 View Post
    Cr4wl, killing pulse audio worked! Do you know how to make it so it automatically kills pulse when Teamspeak starts and starts it when the program is closed?

    Thanks a bunch!
    just write your self a script like that

    Code:
    #!/bin/bash
    
    pulseaudio -k
    /opt/ts3cl/run.sh
    pulseaudio -D
    
    exit 0
    change /opt/ts3cl/run.sh wherever your ts3 folder is
    that should do the trick... probably need to be run as root
    don't forget to make executeable

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Howto upgrade ubuntu TS3 server
    By Sparky7277 in forum Linux / FreeBSD
    Replies: 1
    Last Post: May 24th, 2011, 08:48 AM
  2. easy help please
    By stomach in forum Permission System
    Replies: 1
    Last Post: March 11th, 2011, 05:51 AM
  3. Replies: 10
    Last Post: February 22nd, 2011, 12:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •