Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    March 2010
    Location
    Nederland
    Posts
    2

    Cannot start client "The application failed to initialize properly"

    After installing the TS3 client on my Windows XP SP3 (32bit) system, it fails to start with the message "The application failed to initialize properly (0xc01500020). Click on OK to terminate the application."

    Some searching on the forum lead me to a suggestion to reinstall .NET 3.5 SP1, but that did not solve the issue.

    Looking with depends.exe, I noticed that dwmapi.dll and msvcp90.dll were missing dependencies.
    I copied msvcp90.dll from the VisualStudio redist folder, and got dwmapi.dll from the internet. But still it does not run.

    Starting it within VisualStudio gives the following output:

    'ts3client_win32.exe': Loaded 'C:\Program Files\TeamSpeak 3 Client\ts3client_win32.exe', No symbols loaded.
    'ts3client_win32.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
    'ts3client_win32.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
    'ts3client_win32.exe': Loaded 'C:\Program Files\TeamSpeak 3 Client\QtCore4.dll', No symbols loaded.
    LDR: LdrpWalkImportDescriptor() failed to probe C:\Program Files\TeamSpeak 3 Client\QtCore4.dll for its manifest, ntstatus 0xc0150002
    Debugger:: An unhandled non-continuable exception was thrown during process load
    The program '[4712] ts3client_win32.exe: Native' has exited with code -1072365566 (0xc0150002).


    What would be the right solution to this problem?

    rhp

  2. #2
    Join Date
    December 2009
    Location
    Portugal
    Posts
    492
    Hi

    I've never seen anyone reporting that error code. Maybe you meant "0xc0150020" instead of "0xc0150002". Anyways, THIS has been working for everyone.

    Regards

  3. #3
    Join Date
    March 2010
    Location
    Nederland
    Posts
    2
    Hi Jonybat,

    You are right about the errorcode.
    As I indicated I already tried reinstalling the .NET service-pack.
    I have also installed the vc redist file, however it still doesn't work.
    I even tried the SP1 to the VC redist file: no luck.

    Please note that I have VS2008 installed, so I shouldn't actually need the VC redist in the first place.

    Thanks,

    Ronald

  4. #4
    Join Date
    January 2010
    Location
    Germany
    Posts
    9
    Maybe it's the same errorI have with TS3...

    http://forum.teamspeak.com/showthread.php?t=50584

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Error on server start "bind failed"
    By Magnetto in forum Server Support
    Replies: 11
    Last Post: November 1st, 2016, 10:16 AM
  2. failed to initialize properly
    By grof5 in forum Windows
    Replies: 3
    Last Post: April 27th, 2014, 11:44 AM
  3. application failed to initialize properly (0c0000006)
    By sombra in forum Client Support
    Replies: 1
    Last Post: July 4th, 2011, 03:36 PM
  4. Replies: 1
    Last Post: July 4th, 2011, 03:36 PM
  5. "The application failed to initialize properly"
    By karimali831 in forum Windows
    Replies: 0
    Last Post: December 24th, 2009, 02:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •