Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2010
    Location
    Netherlands
    Posts
    32

    [Fixed] Wrong text in TTS when client switches away

    Hi when a client switches away from the channel I'm in the TTS text is wrong in my opinion.
    Situation:
    I have 2 channels
    - Lobby
    - Away
    We both are in "Lobby" when he switches away it says:
    - "Person1" left your channel "Away" on "Server"

    But I think it should be one of the following:
    - "Person1" left your channel to "Away" on "Server"
    - "Person1" left your channel "Lobby" to "Away" on "Server"
    - "Person1" left your channel "Lobby" on "Server"

    In the current situation it looks like if we are in the "Away" channel and not in the "Lobby" channel.
    I think that the problem is in the part of ${channelname} that it is used from the switching user and not (me).

  2. #2
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    You can change this yourself by editing the settings.ini file in

    C:\Program Files\TeamSpeak 3 Client\sound\default_speech

    I took out the server name on a lot of them since I rarely ever log in to more than 1 server.

  3. #3
    Join Date
    January 2010
    Location
    Netherlands
    Posts
    32
    Quote Originally Posted by poisonpanik View Post
    You can change this yourself by editing the settings.ini file in

    C:\Program Files\TeamSpeak 3 Client\sound\default_speech

    I took out the server name on a lot of them since I rarely ever log in to more than 1 server.
    Ok that's true, but it stays wrong. So with a new update (if you didn't copy it) it is wrong again. Or if you copied it you need to check if there are new texts available whenever there is a new update.

    Eventhough it still is a beta, we are supposed of reporting these things instead of creating workarounds.

  4. #4
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    I agree that it should be reported. I was just giving you an option until it does get fixed

  5. #5
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Changed default_speech/settings.ini:

    CLIENT_SWITCHED_FROM_CURRENT_CHANNEL_DISAPPEARS = say("${clientname} left your channel and disappears to ${channelname} on ${servername}")
    CLIENT_SWITCHED_FROM_CURRENT_CHANNEL_STAYS = say("${clientname} left your channel and switched to ${channelname} on ${servername}")

    channelname being the new channel in both cases now (this was a change to the code, so just replacing the ini file with the current client won't help).

    I'd consider the new channel name more interesting than the old, I assume I do know my existing channel name. :-)

  6. #6
    Join Date
    January 2010
    Location
    Netherlands
    Posts
    32
    Quote Originally Posted by PeterS View Post
    Changed default_speech/settings.ini:

    CLIENT_SWITCHED_FROM_CURRENT_CHANNEL_DISAPPEARS = say("${clientname} left your channel and disappears to ${channelname} on ${servername}")
    CLIENT_SWITCHED_FROM_CURRENT_CHANNEL_STAYS = say("${clientname} left your channel and switched to ${channelname} on ${servername}")

    channelname being the new channel in both cases now (this was a change to the code, so just replacing the ini file with the current client won't help).

    I'd consider the new channel name more interesting than the old, I assume I do know my existing channel name. :-)

    Thanks it sounds much better now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Fixed] wrong server name
    By singlong in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: May 21st, 2010, 05:55 AM
  2. Text to speech output on wrong device
    By Trekkan in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: May 8th, 2010, 03:58 PM
  3. [Fixed] Wrong text in TTS when client switches away
    By axellexa in forum Client Support
    Replies: 5
    Last Post: April 16th, 2010, 09:46 AM
  4. [Fixed] TTS wrong channel
    By PeterW in forum Windows
    Replies: 9
    Last Post: February 1st, 2010, 11:25 AM
  5. [Fixed] Suggestion: ${servername} token in text to speech
    By Gandhi in forum Suggestions and Feedback
    Replies: 1
    Last Post: January 22nd, 2010, 12:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •