Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Join Date
    December 2004
    Location
    Germany
    Posts
    15

    Solved Can not start MySQL version. (Unknown database 'test')

    ts3server.ini
    machine_id=xxx.xxx.xxx.xxx
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    logpath=logs
    logquerycommands=0
    ts3db_mysql.ini
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=XXXXXXXXXX
    database=teamspeak3
    socket=
    #~: ./ts3server_linux_amd64 inifile=ts3server.ini


    2009-12-29 21:19:42.101322|INFO |ServerLibPriv | | Server Version: 3.0.0-beta11 [Build: 9559]
    2009-12-29 21:19:42.107604|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-29 21:19:42.107848|INFO |DatabaseQuery | | dbPlugin version: 1
    2009-12-29 21:19:42.116737|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Unknown database 'test'
    Segmentation fault

    what is wrong :/

  2. #2
    Join Date
    March 2009
    Location
    USA
    Posts
    20
    did you remember to add an extra empty line at the end of both configuration files?

  3. #3
    Join Date
    December 2004
    Location
    Germany
    Posts
    15
    ok i forget thx

  4. #4
    Join Date
    December 2009
    Location
    BRASIL
    Posts
    4

    Wink

    ts3db_mysql.ini
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=XXXXXXXXXX
    database=teamspeak3
    ***space white***

    ts3server.ini
    machine_id=xxx.xxx.xxx.xxx
    default_voice_port=9987
    voice_ip=0.0.0.0 =IP SERVER
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0 =IP SERVER
    query_port=10011
    query_ip=0.0.0.0 =IP SERVER
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    logpath=logs
    logquerycommands=0


    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead


    nohup ./ts3server_linux_x86 inifile=ts3server.ini dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql/ &

    24/7

    Soon
    Last edited by florian_fr40; November 9th, 2011 at 05:14 PM.

  5. #5
    Join Date
    August 2011
    Posts
    11
    Hello, I have the same problem but in Windows (dont wanna to create similar theme there)
    So, I use such command line (after cd C:\ts3server):
    ts3server_win64.exe inifile=ts3server.ini
    logs:
    2012-04-04 21:09:33.197429|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.3 (2012-03-17 06:12:11)
    2012-04-04 21:09:33.198429|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2012-04-04 21:09:33.198429|INFO |DatabaseQuery | | dbPlugin version: 1
    2012-04-04 21:09:33.203429|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Unknown database 'test'
    2012-04-04 21:09:33.203429|CRITICAL|ServerLibPriv | | Server() DatabaseError
    ts3server.ini
    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    <empty line>
    ts3db_mysql.ini
    [config]
    host=localhost
    port=3306
    username=root
    password=
    database=teampseak
    socket=
    <empty line>
    What's wrong?

  6. #6
    Join Date
    March 2010
    Location
    Germany
    Posts
    114
    Hey,

    There is a typo in your ts3db_mysql.ini, maybe thats the fail, if your database is called teamspeak and not teampseak.

    [config]
    host=localhost
    port=3306
    username=root
    password=
    database=teampseak
    socket=
    <empty line>
    Kind regards
    Last edited by Maxe___; April 5th, 2012 at 10:37 AM.

  7. #7
    Join Date
    August 2011
    Posts
    11
    No, it's specially)) MySQL plugin just doesn't use my config file, that's why all settings are default.

    Should I create the same theme in Windows section to get some help?
    Last edited by florian_fr40; April 11th, 2012 at 10:02 AM.

  8. #8
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    If you search around the forums you should be able to find your solution. It has been answered recently.

  9. #9
    Join Date
    August 2011
    Posts
    11
    I was searching for my solution before posting my first message here. And I still don't know what's wrong with it. Please, if you know the solution give me a link or an advice.

  10. #10
    Join Date
    May 2010
    Posts
    6,310
    Hello

    The server try to point on a test database if there is no valide ts3db_mysql.ini

    But before all, instead use the root user (without password, etc), create a new database on your mysql server (like e.g. ts3BDD with password and why no the same user)

    Now check if your ts3db_mysql.ini file has a good name (I guess you have a windows seven or greater system). Check if the extension is .ini and NOT .ini.ini

    After that write this :
    Code:
    [CONFIG]
    host=localhost
    port=3306
    username=ts3BDD
    password=<password>
    database=ts3BDD
    socket=
    Now re try
    Last edited by florian_fr40; April 11th, 2012 at 11:52 AM.

  11. #11
    Join Date
    August 2011
    Posts
    11
    Hi again.
    My new "ts3db_mysql.ini" NOT "ts3db_mysql.ini.ini", "ts3db_mysql.ini.txt" or something like that.
    [CONFIG]
    host=localhost
    port=3306
    username=qwester
    password=parol
    database=qwester
    socket=
    with empty line at the end (and without empty line it doesn't work anyway).

    And my logs:
    2012-04-11 09:32:46.567839|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.3 (2012-03-17 06:12:11)
    2012-04-11 09:32:46.567839|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2012-04-11 09:32:46.567839|INFO |DatabaseQuery | | dbPlugin version: 1
    2012-04-11 09:32:46.567839|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Unknown database 'test'
    2012-04-11 09:32:46.567839|CRITICAL|ServerLibPriv | | Server() DatabaseError
    As you see it still doesn't work.

  12. #12
    Join Date
    May 2010
    Posts
    6,310
    Are you allow to connect to this database with a tool like HeidiSQL ?

    Also could you try to start your server like that :
    Code:
    ts3server_win64.exe dbplugin=ts3db_mysql dbsqlpath=sql/ dbsqlcreatepath=create_mysql/
    And little question, do you try to start your server as Admin (right on exe file > Run as Admin)

  13. #13
    Join Date
    August 2011
    Posts
    11
    I don't use HeidiSQL and also don't know what is it. I use webserver with Mysql database and I can to connect to the database over my php script or PHPMyAdmin using parameters from ts3db_mysql.ini file.

    Trying to start teamspeak server using
    Code:
    ts3server_win64.exe dbplugin=ts3db_mysql dbsqlpath=sql/ dbsqlcreatepath=create_mysql/
    gives the same result.

    I have created a link to ts3server_win64.exe inside teamspeak server folder and tried to start it as Admin but I got the same result as before. Well, the plugin just doesn't use its config file and I don't know why. If you need I can upload my teamspeak server folder with all files (.exe, .ini, etc.).

  14. #14
    Join Date
    May 2010
    Posts
    6,310
    You talk about a webserver, do you mean a dedicated server (or vps) with a Teamspeak server and MySQL server ?

    I suggest you to delete the ts3db_mysql.ini file and create a new one (just to avoid any broken file story)

  15. #15
    Join Date
    August 2011
    Posts
    11
    I have virtual webserver on my computer (localhost), OS Windows 7 64bit. Moreover Teamspeak server works fine if I create database named 'test' (in this case plugin uses default settings (login: root, db: test, empty password)). As I said before I can to connect to my database on my PC, I have all permissions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: May 22nd, 2019, 02:01 AM
  2. Replies: 3
    Last Post: November 8th, 2012, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •