Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    April 2010
    Location
    norway
    Posts
    4

    Smile [Solved] Cant connect to my own server. Frustrated

    Hey everyone
    I've spent a couple of hours trying to figure this out myself. And Im sorry if this is a stupid question to ask.

    I've done everythin exactly as the tutorial showed me how to setup a server and when it comes to when im supposed to click "connect" this comes up on the chat: Failed to resolve IPv4 address for 'localhost'.

    Im using port 9987. In adress I write localhost. And my username is sumanto.
    And I've opened the server program.

    If I write my IP instead it just says: Failed to connect to server.

    I have absolutley no idea what IPv4 is. I searched on the internet and read about what it was but didnt udnerstand any of it.

    Does anyone know what I can do to get it to work? Please help me out =)

    Im runing version client version 10609. My operating system is Windows Vista 32bit.

  2. #2
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    You have serious issue with your system. Before you resolve it, there's little we could do to help you.
    "localhost" must be resolved to local address by the system itself.

    Check the "%SystemRoot%/System32/drivers/etc/hosts" file, if it is present and contain all the relevant entries.

  3. #3
    Join Date
    April 2010
    Location
    norway
    Posts
    4
    It is there. in the "etc" file there is 5 files : Hosts. Imhost.sam (SAM-file). Networks. protocol. services.

    Is that what you ment?

  4. #4
    Join Date
    January 2010
    Location
    Germany / Frankfurt
    Posts
    29
    The file is there, that is good. Try to open the hosts-file with notepad or another editor.
    The file should contain at least the following line:
    Code:
    127.0.0.1       localhost
    Please check that your hosts-file contains these line.

  5. #5
    Join Date
    April 2010
    Location
    norway
    Posts
    4
    That line isnt there.

    It says

    : : 1 localhost

    thats the only place it says localhost. Here is a upload of the text:

    http://img175.yfrog.com/i/hosts.jpg/ Image Shack

    When I try to write : 127.0.0.1 localhost... It says "no access to file xxxx"
    Last edited by sumanto; April 6th, 2010 at 03:17 PM.

  6. #6
    Join Date
    January 2010
    Location
    Germany / Frankfurt
    Posts
    29
    Quote Originally Posted by sumanto View Post
    It says "no access to file xxxx"
    I assume you use Vista or Win 7. Try to run your editor with administrator rights. Then add this line and restart your computer. Hopefully it is fixed then.
    How to edit your hosts file with administrator rights
    The hosts-file should look like this:
    Code:
    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
     
    127.0.0.1       localhost
    ::1             localhost

  7. #7
    Join Date
    April 2010
    Location
    norway
    Posts
    4
    Okey. I got it to work now =D Thank you all so much ! <3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Frustrated with TS3 !
    By jihadOnYourFace in forum General Questions
    Replies: 2
    Last Post: March 18th, 2013, 02:57 PM
  2. Replies: 3
    Last Post: August 21st, 2010, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •