Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    April 2010
    Location
    Canada
    Posts
    9

    Illegal instruction on startup

    Hey, i havn't been able to fix on an error i get on start up, my ts3 did work, back when it was beta 15 i believe, but now beta 18 wont work. so is there any packages i need to install, change anything withing the teamspeak setttings?

    This is what my start up output is

    Code:
    /TeamSpeak3-Client-linux_x86$ ./ts3client_runscript.sh 
    2010-04-10 16:21:25.358058|INFO    |MPSingleton   |   | Detected local codeset to be: UTF-8
    2010-04-10 16:21:25.380402|INFO    |              |   | Logging started, clientlib version: 3.0.0-beta18 [Build: 10609]
    ./ts3client_runscript.sh: line 9:   612 Illegal instruction     ./ts3client_linux_x86 [email protected]
    I use Debian lenny
    Last edited by wannabe; April 11th, 2010 at 09:44 AM. Reason: forgot to state my distro

  2. #2
    Join Date
    December 2009
    Posts
    237
    EDIT:
    Hmm never mind, i just had a look at the startscript but it didnt help identifying the problem.

  3. #3
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Output of "uname -a" and "cat /proc/cpuinfo" please
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  4. #4
    Join Date
    April 2010
    Location
    Canada
    Posts
    9
    Code:
    cat /proc/cpuinfo
    processor	: 0
    vendor_id	: AuthenticAMD
    cpu family	: 6
    model		: 4
    model name	: AMD Athlon(tm) processor
    stepping	: 2
    cpu MHz		: 1102.518
    cache size	: 256 KB
    fdiv_bug	: no
    hlt_bug		: no
    f00f_bug	: no
    coma_bug	: no
    fpu		: yes
    fpu_exception	: yes
    cpuid level	: 1
    wp		: yes
    flags		: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
    bogomips	: 2206.62
    clflush size	: 32
    power management:
    Code:
    uname -a
    Linux debian 2.6.26-2-486 #1 Tue Mar 9 17:10:34 UTC 2010 i686 GNU/Linux

  5. #5
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hello,

    the problem is your athlon is not "athlon xp" or higher which the system requirement
    page says is required ( http://www.teamspeak.com/?page=requirements ). Your athlon
    does not have SSE support, and the TS3 server is compiled with SSE instructions enabled.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  6. #6
    Join Date
    April 2010
    Location
    Canada
    Posts
    9
    Quote Originally Posted by Peter View Post
    Hello,

    the problem is your athlon is not "athlon xp" or higher which the system requirement
    page says is required ( http://www.teamspeak.com/?page=requirements ). Your athlon
    does not have SSE support, and the TS3 server is compiled with SSE instructions enabled.
    So i can't run ts3 ever on this setup?
    Last edited by wannabe; April 12th, 2010 at 01:15 AM.

  7. #7
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    correct, we drew the line at SSE, your CPU is very very old, you can probably get a newer one out of the trash if you find the right trash
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  8. #8
    Join Date
    April 2010
    Location
    Canada
    Posts
    9
    God damn. well thanks for you info, mods may close topic if wanted, nothing else is needed to be said.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [solved] SSE Instruction Set
    By Dean01 in forum Windows
    Replies: 6
    Last Post: May 10th, 2011, 03:54 PM
  2. ts3.0.9592: Illegal instruction
    By boahey in forum Suggestions and Feedback
    Replies: 0
    Last Post: December 31st, 2009, 09:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •