Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    62

    Beta 22 Too many...

    I have a Problem with the server

    Code:
    2010-04-16 08:45:06.844947|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta22 [Build: 10724], Linux
    2010-04-16 08:45:06.845498|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-04-16 08:45:06.845610|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-04-16 08:45:06.846134|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2010-04-16 08:45:06.872490|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-04-16 08:45:07.158532|INFO    |Accounting    |   | Licensing Information
    2010-04-16 08:45:07.159594|INFO    |Accounting    |   | type              : Non-profit
    2010-04-16 08:45:07.160544|INFO    |Accounting    |   | starting date     : Fri Apr  2 00:00:00 2010
    2010-04-16 08:45:07.161442|INFO    |Accounting    |   | ending date       : Sat Apr  2 00:00:00 2011
    2010-04-16 08:45:07.162360|INFO    |Accounting    |   | max virtualservers: 10
    2010-04-16 08:45:07.163193|INFO    |Accounting    |   | max slots         : 512
    2010-04-16 08:45:07.224695|INFO    |FileManager   |   | listening on 93.186.192.91:****
    2010-04-16 08:45:07.313989|INFO    |VirtualServer |  1| listening on 93.186.192.91:****
    2010-04-16 08:45:07.315193|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
    2010-04-16 08:45:07.316500|INFO    |Query         |   | listening on 93.186.192.91:*****
    2010-04-16 08:45:07.693396|ERROR   |Accounting    |   | too many slots hosted, shutting down!
    2010-04-16 08:45:07.775208|INFO    |VirtualServer |  1| stopped
    What am I doing wrong?

    MyStartscript:

    Code:
    #!/bin/bash
    # Copyright (c) 2010 TeamSpeak Systems GmbH
    # All rights reserved
    
    COMMANDLINE_PARAMETERS="inifile=ts3server.ini" #add any command line parameters you want to pass here
    BINARYPATH="."
    cd "${BINARYPATH}"
    LIBRARYPATH="$(pwd)"
    
    if [ -e "ts3server_linux_x86" ]; then
    	BINARYNAME="ts3server_linux_x86"
    else
    	BINARYNAME="ts3server_linux_amd64"
    fi
    
    case "$1" in
    	start)
    		if [ -e ts3server.pid ]; then
    			if ( kill -0 $(cat ts3server.pid) 2> /dev/null ); then
    				echo "The server is already running, try restart or stop"
    				exit 1
    			else
    				echo "ts3server.pid found, but no server running. Possibly your previously started server crashed"
    				echo "Please view the logfile for details."
    				rm ts3server.pid
    			fi
    		fi
    		if [ "${UID}" = "0" ]; then
    			echo WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    			for c in $(seq 1 10); do
    				echo -n "!"
    				sleep 1
    			done
    			echo "!"
    		fi
    		echo "Starting the TeamSpeak 3 server"
    		if [ -e "$BINARYNAME" ]; then
    			if [ ! -x "$BINARYNAME" ]; then
    				echo "${BINARYNAME} is not executable, trying to set it"
    				chmod u+x "${BINARYNAME}"
    			fi
    			if [ -x "$BINARYNAME" ]; then
    				export LD_LIBRARY_PATH="${LIBRARYPATH}:${LD_LIBRARY_PATH}"					
    				"./${BINARYNAME}" ${COMMANDLINE_PARAMETERS} > /dev/null & 
    				echo $! > ts3server.pid
    				echo "TeamSpeak 3 server started, for details please view the log file"
    			else
    				echo "${BINARNAME} is not exectuable, cannot start TeamSpeak 3 server"
    			fi
    		else
    			echo "Could not find binaryname (ts3server_linux_x86 or ts3server_linux_amd64, aborting"
    			exit 5
    		fi
    	;;
    	stop)
    		if [ -e ts3server.pid ]; then
    			echo -n "Stopping the TeamSpeak 3 server"
    			if ( kill -TERM $(cat ts3server.pid) 2> /dev/null ); then
    				for c in $(seq 1 300); do
    					if ( kill -0 $(cat ts3server.pid) 2> /dev/null ); then
    						echo -n "."
    						sleep 1
    					else
    						break
    					fi
    				done
    			fi
    			if ( kill -0 $(cat ts3server.pid) 2> /dev/null ); then
    				echo "Server is not shutting down cleanly - killing"
    				kill -KILL $(cat ts3server.pid)
    			else
    				echo "done"
    			fi
    			rm ts3server.pid
    		else
    			echo "No server runing (ts3server.pid is missing)"
    			exit 7
    		fi
    	;;
    	restart)
    		$0 stop && $0 start || exit 1
    	;;
    	status)
    		if [ -e ts3server.pid ]; then
    			if ( kill -0 $(cat ts3server.pid) 2> /dev/null ); then
    				echo "Server is running"
    			else
    				echo "Server seems to have died"
    			fi
    		else
    			echo "No server running (ts3server.pid is missing)"
    		fi
    	;;
    	*)
    		echo "Usage: ${0} {start|stop|restart|status}"
    		exit 2
    esac
    exit 0
    My ts3server.ini file

    Code:
    machine_id=
    default_voice_port=*****
    voice_ip=93.186.192.91
    licensepath=key/
    filetransfer_port=*****
    filetransfer_ip=93.186.192.91
    query_port=*****
    query_ip=93.186.192.91
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=1

  2. #2
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Hi,

    1st add your IP into the whithlist.txt: 93.186.192.91

    Then put the keyfile in to the root directory and change licensepath=key/ to licensepath=

    and check that your ports are open...

    Cheech

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    62
    Okay, have I done. However, the error is still there.

    Have also tried the server using MYSQL to be run, but get the same error.

    Serversoftware: Debian 5+ (Lanny)

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    62
    I have test on Windows:

    Code:
    2010-04-16 14:51:33.632973|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta22 [Build: 10723], Windows
    2010-04-16 14:51:33.632973|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2010-04-16 14:51:33.632973|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2010-04-16 14:51:33.648573|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-04-16 14:51:33.898173|INFO    |Accounting    |   | Licensing Information
    2010-04-16 14:51:33.929373|INFO    |Accounting    |   | type              : Non-profit
    2010-04-16 14:51:33.944973|INFO    |Accounting    |   | starting date     : Fri Apr 02 00:00:00 2010
    2010-04-16 14:51:33.960573|INFO    |Accounting    |   | ending date       : Sat Apr 02 00:00:00 2011
    2010-04-16 14:51:33.991773|INFO    |Accounting    |   | max virtualservers: 10
    2010-04-16 14:51:34.007373|INFO    |Accounting    |   | max slots         : 512
    2010-04-16 14:51:34.334973|INFO    |FileManager   |   | listening on 85.114.131.79:****
    2010-04-16 14:51:35.442573|INFO    |VirtualServer |  1| listening on 85.114.131.79:****
    2010-04-16 14:51:35.458173|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 85.114.131.136, 85.114.131.79, 85.114.131.134, 85.114.137.36, 
    2010-04-16 14:51:35.473773|INFO    |Query         |   | listening on 85.114.131.79:****
    2010-04-16 14:51:35.692173|ERROR   |Accounting    |   | too many slots hosted, shutting down!
    2010-04-16 14:51:35.832573|INFO    |VirtualServer |  1| stopped
    Can this have to do with the license?

  5. #5
    Join Date
    December 2009
    Location
    The Game!
    Posts
    236
    Concerning the too many slots hosted, have you tried either of the following ?

    http://forum.teamspeak.com/showpost....8&postcount=12

    http://forum.teamspeak.com/showpost....00&postcount=3

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    62
    Yes, I have tried all options, still the same problem. Can it possibly be because that the license file is corrupted?
    So this is only a presumption that deliver the report had been sent incorrectly.

  7. #7
    Join Date
    December 2009
    Location
    Dublin, Ireland
    Posts
    379
    You could try downloading the liscense file from your attachments again.

  8. #8
    Join Date
    December 2009
    Location
    Germany
    Posts
    62
    I've already tried ... Has unfortunately also brought nothing!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BETA 3.0.17 to the BETA CHANNEL?
    By Rikku in forum Off Topic
    Replies: 1
    Last Post: December 9th, 2014, 04:30 PM
  2. Linux Server Beta 18 Update to Beta 22 how
    By totto4711 in forum Linux / FreeBSD
    Replies: 2
    Last Post: April 28th, 2010, 04:24 PM
  3. Replies: 5
    Last Post: March 9th, 2010, 03:46 PM
  4. Problem Serverupdate Beta 12 to Beta 15
    By Leitwolf in forum Server Support
    Replies: 3
    Last Post: January 20th, 2010, 05:04 PM
  5. Beta 1 to Beta 2 Updating?
    By Str1k3r in forum Linux / FreeBSD
    Replies: 6
    Last Post: December 21st, 2009, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •