Hi, I can't seem to start ts3server on Linux server. I've tried running it with strace and gdb with no luck.

From the error I'm assuming it's trying to do some sort of DNS resolution. I've checked my DNS; there is a local ISC bind `named` as well as a secondary/slave on another machine, and yes there are records (forward and reverse) for this machine as well as the rest of the network. /etc/resolv.conf contains the proper entries as well.

So what could be causing this problem? I get the same error whether or not I use my licensekey.dat (NPL), although without it, it goes slightly furthur then with it, but still aborts the same.

Thanks for any help.

# LD_LIBRARY_PATH=.  ./ts3server_linux_x86                                                
Logging started
2010-05-14 20:16:44.557800|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta12 [Build: 9596]
2010-05-14 20:16:44.560709|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, (c)TeamSpeak Systems GmbH
2010-05-14 20:16:44.561730|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
2010-05-14 20:16:44.604189|DEVELOP |              |   | TS3ANetwork::ResolveHostName failed error: -1 (Bad value for ai_flags) 4
2010-05-14 20:16:44.933464|CRITICAL|              |   | TS3ANetwork::IPFamilyToAf SHOULD NOT REACH THIS