Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    June 2010
    Location
    Germany
    Posts
    2

    Solved [Solved] TS3 Server binds to 0.0.0.0 aufter Update to beta23 from beta20

    Hello,
    I badly need your help!

    I have a TS3 beta20 Server running on Linux x86. Now i have to update this to beta23.

    I have stopped TS3 server.
    I have copied all files from linux-x86-beta23 archiv over the old files.
    I have started TS3 server.

    All is fine but it didnt bind the TS3 server to the IP i have specified in the ts3server.ini

    Is there a different between the ini file from beta20 and beta beta23?
    Can you imagine where the problem is? If i do an rollback with the beta20 files, all will be fine, TS3 will bind to the specific IP adress.

    Here is the entry from the log file of TS3 beta23 after starting it:
    Code:
    2010-06-03 07:29:01.414022|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta23 [Build: 11239], Linux
    2010-06-03 07:29:01.416527|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-06-03 07:29:01.416606|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-06-03 07:29:01.420665|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2010-06-03 07:29:01.564507|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-06-03 07:29:01.985637|INFO    |Accounting    |   | Licensing Information
    2010-06-03 07:29:02.338087|INFO    |Accounting    |   | type              : Non-profit
    2010-06-03 07:29:02.738230|INFO    |Accounting    |   | starting date     : Tue Mar 23 00:00:00 2010
    2010-06-03 07:29:03.097350|INFO    |Accounting    |   | ending date       : Wed Mar 23 00:00:00 2011
    2010-06-03 07:29:03.447840|INFO    |Accounting    |   | max virtualservers: 10
    2010-06-03 07:29:03.837047|INFO    |Accounting    |   | max slots         : 512
    2010-06-03 07:29:07.334168|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2010-06-03 07:29:18.218964|INFO    |VirtualServer |  1| listening on 0.0.0.0:10396
    2010-06-03 07:29:18.532824|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
    2010-06-03 07:29:18.735348|INFO    |Query         |   | listening on 0.0.0.0:10011
    With the old TS3 beta20 files i will got this log aftet starting TS3 server:
    Code:
    2010-06-03 19:35:02.091121|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta20 [Build: 10413], Linux
    2010-06-03 19:35:02.164674|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2010-06-03 19:35:02.164743|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-06-03 19:35:02.169361|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2010-06-03 19:35:02.488356|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-06-03 19:35:02.624687|INFO    |SQL           |   | pruning old guest clients where last connected time is older than 30 days, clients to remove: 6
    2010-06-03 19:35:10.399864|INFO    |Accounting    |   | Licensing Information
    2010-06-03 19:35:10.632068|INFO    |Accounting    |   | type              : Non-profit
    2010-06-03 19:35:10.824424|INFO    |Accounting    |   | starting date     : Tue Mar 23 00:00:00 2010
    2010-06-03 19:35:10.998399|INFO    |Accounting    |   | ending date       : Wed Mar 23 00:00:00 2011
    2010-06-03 19:35:11.156573|INFO    |Accounting    |   | max virtualservers: 10
    2010-06-03 19:35:11.309914|INFO    |Accounting    |   | max slots         : 512
    2010-06-03 19:35:13.356412|INFO    |FileManager   |   | listening on 192.168.77.47:12396
    2010-06-03 19:35:20.155911|INFO    |VirtualServer |  1| listening on 192.168.77.47:10396
    2010-06-03 19:35:20.402763|INFO    |Query         |   | whitelist ips: 127.0.0.1, 
    2010-06-03 19:35:20.562249|INFO    |Query         |   | listening on 192.168.77.47:11396
    Plz help me!


    EDIT:

    Solved!
    I have to add the TS3 ini file to the command line. For my startscript i changed in ts3server_startscript.sh:

    COMMANDLINE_PARAMETERS="" #add any command line parameters you want to pass here
    to
    COMMANDLINE_PARAMETERS="inifile=ts3server.ini" #add any command line parameters you want to pass here
    Last edited by Losti; June 3rd, 2010 at 09:22 AM.

  2. #2
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hello,

    you probably modified the ts3server_startscript.sh with your older build to actually use the .ini file. Since you overwrote your ts3server_startscript.sh with a "clean" unedited version now your .ini file is no longer read. So, the solution is to edit the startscript and change the line
    COMMANDLINE_PARAMETERS=""
    to something like
    COMMNADLINE_PARAMETERS="inifile=ts3server.ini"
    (make sure you use the right name for your ini file, any name is possible)
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  3. #3
    Join Date
    June 2010
    Location
    Germany
    Posts
    2
    Quote Originally Posted by Peter View Post
    Hello,

    you probably modified the ts3server_startscript.sh with your older build to actually use the .ini file. Since you overwrote your ts3server_startscript.sh with a "clean" unedited version now your .ini file is no longer read. So, the solution is to edit the startscript and change the line
    COMMANDLINE_PARAMETERS=""
    to something like
    COMMNADLINE_PARAMETERS="inifile=ts3server.ini"
    (make sure you use the right name for your ini file, any name is possible)
    Yeah, thats it, THX !!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [solved] Our TS3 server beta20 was hacked to night
    By Ratata in forum Server Support
    Replies: 2
    Last Post: September 7th, 2010, 08:40 AM
  2. [Solved] server beta23 - permissions - i_client_talk power
    By Osce1 in forum Bug Reports [EN/DE]
    Replies: 8
    Last Post: June 18th, 2010, 08:01 AM
  3. Replies: 4
    Last Post: June 7th, 2010, 01:49 PM
  4. Server database update (beta20→beta21)
    By timtimmtim2 in forum Server Support
    Replies: 0
    Last Post: April 2nd, 2010, 04:27 PM
  5. update from beta18 to beta20 on ubuntu server
    By LudoTw in forum Linux / FreeBSD
    Replies: 5
    Last Post: March 11th, 2010, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •