Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    June 2010

    Mouse side buttons push-to-talk problem

    I have a Razer Diamondback 3G mouse and I'm trying to set a button on the side (mouse button 4-5) to my push to talk, but TS3 would not detect it.

    I had this problem initially, but installed razer's 1.01 driver and it worked fine. However, I tried today and TS3 reverted back to not detecting my mouse side buttons. Mouse buttons 1-2-3 work perfectly fine.

    I reinstalled both the razer drivers and TS3, and even performed a registry scan. Still no luck.

    I've tried running in compatibility mode with Windows XP service pack 2 and running in both nonadmin and admin mode.

    Anyone know any solutions?

    Operating system: Windows 7
    Mouse: Razer Diamondback 3g w/ 1.01 driver

  2. #2
    Join Date
    June 2010

    nobody knows anything? I searched the forums and it seems there has been this problem in the past with razer mice. Any solutions?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 Connection disables side buttons on mouse
    By StrapMyBoot in forum Windows
    Replies: 1
    Last Post: March 24th, 2016, 12:53 PM
  2. Push-to-talk with Mouse extra buttons
    By jjwwide in forum Windows
    Replies: 1
    Last Post: September 4th, 2015, 01:06 AM
  3. [Resolved] Setting 2 push to talk buttons
    By MIGhunter in forum Suggestions and Feedback
    Replies: 16
    Last Post: March 21st, 2011, 09:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts