Forum

Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24
  1. #16
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    Quote Originally Posted by Cheech View Post
    Hi,

    a short question did you use this MYSQL for other applications or for your Website ? And is it working fine ?

    Cheech
    He has obvious problem with configuration file.
    But it's hard to tell, what the problem is for exact.

  2. #17
    Join Date
    June 2010
    Location
    San Francisco, CA
    Posts
    1

    Solved my version of this problem

    I'm running Gentoo and installed ts3 beta 23 using emerge. It creates a handy /etc/init.d/teamspeak3-server script for starting and stopping the server. My problem was exactly what the logged error message says: The ts3 mysql shared library could not be found by the executable. So, after finding no solution in this thread nor in the documentation, I went and learned something about shared libraries:

    http://tldp.org/HOWTO/Program-Librar...libraries.html

    My particular problem stemmed from the init.d script not calling ts3server_minimal_runscript.sh, which appends the install directory to the LD_LIBRARY_PATH. This would make the shared library in the install directory visible to the executable.

    My solution: Prepend the full path to libts3db_mysql.so to LD_LIBRARY_PATH in the startup script (in my case, /etc/init.d/teamspeak3-server):

    Code:
    start() {
    
            # Set the path to the ts mysql libary
            export LD_LIBRARY_PATH=/opt/teamspeak3-server:$LD_LIBRARY_PATH
    .
    .
    .
    Hopefully others with similar problems can find the right place in their server start-ups to define the correct library path.

  3. #18
    Join Date
    December 2009
    Location
    Good old Germany
    Posts
    222
    Hi,

    could you please an ls -al of your TS3 folder.

    thank you.

    Cheech

  4. #19
    Join Date
    December 2009
    Location
    Bergen, Norway
    Posts
    119
    Quote Originally Posted by aklouie View Post

    2010-06-02 02:38:27.751817|INFO |DatabaseQuery | | Please make sure you use the supplied ts3server_minimal_runscript.sh to run the server, or set LD_LIBRARY_PATH yourself

    [ps7488]$ ./ts3server_linux_amd64 dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql
    See what the error in the log says (Red letters), and see what you type to start the server (Purple letters).

    In those startscripts provided from TS3 team, is a statment:
    Code:
    export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"
    If you run the binary file (ts3server_linux_amd64) and not the script. The library will not be exported so ts3 can find it.

    Try: ./ts3server_minimal_runscript.sh dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql
    And see if that helps.

    -mancert-

    Edit: Haha... nevermind... i did not read all before i posted

  5. #20
    Join Date
    December 2009
    Location
    kp
    Posts
    3
    I have upload my Tabelle manuel but when i start get i now this error

    Code:
    TeamSpeak Server 3.0.0-beta25 [Build: 11421]
    (c)TeamSpeak Systems GmbH
    
    Logging started
    2010-06-26 11:37:20.563852|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta25 [Build: 11421], Linux
    2010-06-26 11:37:20.565162|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2010-06-26 11:37:20.565219|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2010-06-26 11:37:20.569750|CRITICAL|SQL           |   | db_CreateTables() unable to load instance default values

  6. #21
    Join Date
    December 2009
    Location
    The Game!
    Posts
    236
    @ Schwamm from what i saw in your previous thread, your ts3server.ini is a bit off :
    Change the red line in your file:
    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=188.**.**.***
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=188.**.**.***
    query_port=10011
    query_ip=188.**.**.***
    dbplugin=ts3db_mysql
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    logpath=logs
    logquerycommands=1
    and then start your server with :
    Code:
    ./ts3server_minimal_runscript.sh inifile=ts3server.ini

  7. #22
    Join Date
    December 2009
    Location
    Flroida
    Posts
    65
    I have setup many window server so i am positive that my ini is correct and same problem... i even renamed the mysql to the sqlite and it still didn't load ruling out that possibility.

    I have found my problem with no way to fix it.
    linux-vdso.so.1 => (0x00007fff9cbe9000)
    libmysqlclient.so.15 => not found
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f5e955db000)
    libm.so.6 => /lib/libm.so.6 (0x00007f5e95357000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f5e95140000)
    libc.so.6 => /lib/libc.so.6 (0x00007f5e94dbd000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f5e95b1c000)
    libmysqlclient-dev: Depends: libmysqlclient16 (= 5.1.41-3ubuntu12.3) but 7.0.9-1 is to be installed
    I already have a higher version of mysql and as such can not install the lower version.
    Last edited by Whinis; June 27th, 2010 at 06:05 AM.

  8. #23
    Join Date
    December 2009
    Location
    The Game!
    Posts
    236
    Quote Originally Posted by Whinis View Post
    libmysqlclient-dev: Depends: libmysqlclient16 (= 5.1.41-3ubuntu12.3) but 7.0.9-1 is to be installed
    I already have a higher version of mysql and as such can not install the lower version.
    What is needed is not another version of mysql but a specific mysql library.
    You can easily have all these libraries installed at the same time as each program will only use the ones that it has been compiled with.

    How to get the correct library : http://forum.teamspeak.com/showpost....02&postcount=8

  9. #24
    Join Date
    December 2009
    Location
    Flroida
    Posts
    65
    Thank you that worked for me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: November 11th, 2013, 06:04 PM
  2. Replies: 15
    Last Post: June 20th, 2012, 01:51 PM
  3. [Resolved] unable to load database plugin library "libts3db_mysql.so", halting!
    By PoL4K in forum Linux / FreeBSD
    Replies: 10
    Last Post: March 15th, 2012, 07:29 PM
  4. ts3db_sqlite3.dll halting
    By TheRaccoon in forum Windows
    Replies: 9
    Last Post: February 27th, 2012, 03:09 PM
  5. Replies: 4
    Last Post: January 26th, 2012, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •