Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 10 of 10

Hybrid View

  1. #1
    Join Date
    September 2004
    Location
    Pennsylvania
    Posts
    13

    TS3 is playing Windows Audio through Voice

    Let me preface this with the fact that I'm very, very frustrated at the moment so I'll keep this short...

    Teamspeak 3.0.0-beta21 [Build: 11239]

    Windows 7 64-bit Home Premium

    Logitech G33 USB Headset

    Using Voice Activation, Teamspeak turns my mic on whenever any Windows sounds play (YouTube video, TS's own Notifications, etc). This happens even when my mic is *muted* via the in-line mute control. The sound is NOT playing through the mic. It's a software loop somewhere...

    Using Push-to-Talk, Windows Audio still plays through if someone else is speaking or if there are OS sounds playing.

    My Windows 7 Sound Properties are set in a way that this should absolutely NOT be happening:
    Attachment 3478
    Attachment 3479

    My Teamspeak 3 settings seem right to me:
    Attachment 3476
    Attachment 3477

    Windows 7 has a nice mixer that has each application's sound independent to the other applications so you can mute things on an app-by-app basis:
    Attachment 3480

    If there were a recording mixer equivalent, one would think I could just uncheck everything and the ONLY sounds that would be played through TS3 would be my mic's input... W7 seems to lack such a mixer.

    I'm at my wit's end - any ideas?

  2. #2
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Try switching your capture device to Direct Sound

  3. #3
    Join Date
    June 2010
    Location
    France
    Posts
    4
    same problem here as op :L deactivating voice activation helps, but sadly this is not a good solution

    i don't like using push to talk

    changing to direct sound does not help either

  4. #4
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Is this because your mic picks up what your speakers play?

  5. #5
    Join Date
    June 2010
    Location
    France
    Posts
    4
    nope it seems to be looped through within the software or something. i tested it by muting my microphon (switch on the headset itself). my friends would not hear me talking, but they hear themeselves.

    it is as if the "what u hear" mixer is turned on and used for voice activation. but i definetely deactivated it completely ... also this is a teamspeak 3 issue only. maybe a bug

  6. #6
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Try changing your capture and/or playback devices in TS

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: October 17th, 2013, 07:21 AM
  2. Replies: 5
    Last Post: June 28th, 2012, 08:25 AM
  3. AUDIO messages keeps playing even when disabled
    By Lacart75 in forum General Questions
    Replies: 1
    Last Post: January 27th, 2012, 12:28 PM
  4. My voice lags while playing CS only
    By ftfw1 in forum Windows
    Replies: 1
    Last Post: August 16th, 2011, 10:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •