Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 25
  1. #1
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192

    TeamSpeak 3 Client 3.0.0-beta22 Available

    Hello all,

    we just finished uploading the new beta22 client. As usual it is available via auto update as well. Here is a list of the changes since beta21:

    Code:
    === Client Release 3.0.0-beta22 - 07 Jun 2010
    - Fixed mirror selection of updater          
    - Typo and text corrections, updated German translation
    - Fixed use of current identity name in statusbar. If an identiy was removed
      but still used inside a bookmark, the old instead of default name was shown.
    - Fixed channel edit trying to change codec or latency when those were reduced
      due to permissions.                                                         
    - Enabled dialog to ask for joining the servers default channel when maximum of
      "max family clients" is reached.                                             
    - No longer playing away notification when joining a server as "away".         
    - Client was able to send an offline message to server.                        
    - Fixed G15 plugin which did not detect connections properly.                  
    - It is no longer possible to paste newlines into server/channel groups.       
    - The identity name now has the same length limitation as a nickanme.          
    - Fix bug in filetransfer where after a failed transfer a 0 byte file would    
      remain on the receiver end                                                   
    - Mac: Fix issue that resulted in an outdated version of our updater being     
      used                                                                         
    - Linux: start scripts should now handle when they are executed from a         
      different location than in the client installation path                      
    + When using globally away on a server tab, new clients will join and set their
      status also to away afterwards.                                              
    + Added context menu to copy client uids to clipboard when listing all clients.
    Have fun, and please report any problems on the forums
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  2. #2
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Thanks Peter!

    **EDIT**

    Update froze at 77% so I closed it and reopened the client and attempted to update. It froze again at 97% so I closed it and reopened and it completed the update. Not sure why that is but it seems to be working after the update

  3. #3
    Join Date
    December 2009
    Location
    The Game!
    Posts
    236
    Thx for the update!

    @poisonpanik: Updater worked fine for me. Probably just a connection problem of some sort.

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    Thanks Peter

    Same problem

    Froze at 80% => Download timeout
    Froze at 97% => no message

    and reopened and it completed the update

    Same in windows XP pro, windows 7 ultimate, linux debian and ubuntu

  5. #5
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    I guess I was just too fast for it

  6. #6
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Did you guys that got the freezes during updater update from the last stable release?
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  7. #7
    Join Date
    December 2009
    Location
    germany
    Posts
    56
    same here....

    two stops and after restart the client updates.

  8. #8
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    That's correct, Beta 21->22

    I'm running Win7 x64 here. Everything appears to have worked properly it just took 2 tries to get the updater to finish doing it's thing.

  9. #9
    Join Date
    August 2008
    Location
    Netherlands
    Posts
    25
    Quote Originally Posted by florian_fr40 View Post
    Thanks Peter

    Same problem

    Froze at 80% => Download timeout
    Froze at 97% => no message

    and reopened and it completed the update

    Same in windows XP pro, windows 7 ultimate, linux debian and ubuntu
    Same problem here

  10. #10
    Join Date
    June 2010
    Location
    Holland
    Posts
    7
    als stuckt on 77% for a few min.

    when i do details i get this message:

    Stream 1 shutting down
    Stream 0, translations/lagos_de.qm._z_ OK
    Stream 0 shutting down
    Stream 3: Download error. Timeout 120 seconds to repeat.
    Stream 3: Download attempt 2
    Stream 3: Download error. Timeout 120 seconds to repeat.
    Stream 3: Download attempt 3
    Download finished.


    after some time its getting conection again and then it is finishing the patch procces.

    (i got noraml internet on that time and was serving on teamspeak forum

  11. #11
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    No problems in the UK updating 2 clients, maybe I got in before the rush!!

  12. #12
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,356
    On my system (Win 7 - 32 bit) the updater stopped download at 80%, but resumed after about 60 seconds. So it worked without problems here, just needed a little bit longer .

    Updated from beta 21 to 22.

  13. #13
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    with next update this issues should be fixed. (means they are fixed now :P)

  14. #14
    Join Date
    June 2010
    Location
    Karlsruhe
    Posts
    3

    Exclamation Update stops

    Windows XP Pro Administrator / beta22 and beta22-- (21?)

    Selfupdater stops occasionally and has to be restarted manually;
    Today (beta22) i had one initial and three restarts.

    at beta21(?) there has been one restart and a message about a locked file named "mirrors.ini" iirc.

    Best regards
    w8
    PS: Squaddies told me had same problem at windows7 prof 32-bit.

  15. #15
    Join Date
    February 2010
    Location
    England
    Posts
    11

    update working fine

    Hi,

    Used the auto-update on win-VISTA and Debian 5. Both worked as expected and was updated and re-connected within 1 minute.

    - I did notice that in 3.0.0-beta21/22 client the server uptime refresh no longer has a countdown but I also noticed that being connected for many hours no longer makes the refresh not work. In beta21 the refresh would fail after about 8 hours connectivity and a re-connect was needed to fix.

    Our server on beta23 uptime 7 days 8 hours, 47 minutes and 28 seconds running on deb 5.
    Stability is clearly no longer an issue. That said 22 was up for about 15 days until upgrade!


    Good work guys,
    Proxy settings request for client!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wierd connection problems after Beta22
    By Nerik in forum Windows
    Replies: 8
    Last Post: June 10th, 2010, 09:30 AM
  2. [Fixed with Beta22] [Bug] Client beta21 G19&G15 bug
    By Jaegermeist0r in forum Bug Reports [EN/DE]
    Replies: 23
    Last Post: June 7th, 2010, 03:05 PM
  3. Replies: 2
    Last Post: June 7th, 2010, 01:45 PM
  4. Replies: 29
    Last Post: June 1st, 2010, 05:21 PM
  5. update to beta22 bus access error
    By ubuntu in forum Linux / FreeBSD
    Replies: 1
    Last Post: May 6th, 2010, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •