Forum

Page 3 of 14 FirstFirst 1234513 ... LastLast
Results 31 to 45 of 202
  1. #31
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    Quote Originally Posted by Robirt55 View Post
    Microsoft Visual C++ 2010 Express
    Maybe my source only works with MinGW, I am not that good in C++ programming language, I am a Java programmer .

  2. #32
    Join Date
    May 2010
    Posts
    6,310
    Robirt55 Try with CodeBlock.
    To be sure, compare with the test_plugin.

  3. #33
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    Today I tried to update that plugin for TS3 RC1 pre 9. But I was unable to, TS3 client crash if I enter a command. Same if I try to compile the test plugin.

    Maybe something is wrong with my compiler, but I am unable to fix it. If I don't see a light in the next time, I may drop development of this plugin.

  4. #34
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,798
    Yeah quite a bit has changed with the NOFMOD updates. Make sure that if you are making the windows build you "#define NOFMOD". In my plugin I do this right away inside the existing "#ifdef WINDOWS" at the beginning of the code. Putting it there will work for now, but once they get to adding NOFMOD to Linux and/or Mac it may need to be adjusted some.

  5. #35
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    I reinstalled anything C++ related on my system. Still have the same problems. TS3 client crash on using chat commands.

    Funny is if I compile an API 8 plugin, it works great with TS3 Beta 36 on Windows. It seems anything is OK with my MinGW compiler.

    Same source code with API 9 also works with the Linux version of TS3 Client rc1 pre 9. Don't know where the problem is, it seems only to be a problem with the Windows TS3 Client pre-rc1.

    @ Screech: Adding that line to my source also not help. I still have a crashing TS3 client.

  6. #36
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,798
    If you want to compress the RC1-pre9 code I can glance at it for you, maybe a second set of eyes will help. I too had several problems with the new API on Windows, in the end I ended up starting over with a clean copy of the plugin.c that comes with the plugin skd and re-adding my functions and calls. Then it worked, so I was overlooking some change that affects the NOFMOD version.

  7. #37
    Join Date
    January 2010
    Location
    Hinterfeitupfing
    Posts
    40
    Version 0.4 (19.02.2011)
    + Added command fctc from Stefan1200 to moves all clients of one channel to another channel!
    o Updated TS3 Client API version to 109 (needed for rc1-pre9)

    Windows requires:
    • Microsoft Visual C++ 2010 Redistributable (x32, x64)
    • TeamSpeak 3 RC1-pre9
    Last edited by Mr. S; April 1st, 2011 at 03:13 PM.

  8. #38
    Join Date
    July 2010
    Location
    Italy
    Posts
    10
    Mr.S i got a problem. when i load the plugin x64 on my x64 client i get this error :

    Plugin failed to load:
    Failed to open plugin.

  9. #39
    Join Date
    January 2010
    Location
    Hinterfeitupfing
    Posts
    40
    I'm sorry, I forgot to post that I compiled the code with MS VC++2010. You have to install Microsoft Visual C++ 2010 Redistributable (x32, x64).

  10. #40
    Join Date
    July 2010
    Location
    Italy
    Posts
    10
    ahh i see let me try it =)
    RE: yes it works now! please write it on your post! =)

  11. #41
    Join Date
    January 2010
    Location
    Germany
    Posts
    24
    SAUBER thx 4 work ...

    running on Win7x64 TSł RC1-Pre11 !!!

    E.O.L. BioHaZaRD

  12. #42
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354
    @ Forum Mods: Please don't remove the download link for 0.4. Almost 3 weeks ago I wrote some private messages to change the owner on the TS3 Addon Page for this plugin. Still nothing changed until today. Plugin will be uploaded to Addon page as soon as Mr.S is allowed to do so.

  13. #43
    Join Date
    November 2010
    Location
    Brussels
    Posts
    8
    can you update this plugin?

  14. #44
    Join Date
    January 2010
    Location
    Hinterfeitupfing
    Posts
    40
    Yes, but I need some time to debug. They're changeing the API faster than I can update all my stuff.

    --- Merged ---

    Version 0.51 (14.05.2011)
    o Updated TS3 Client API version to 11 (needed for rc1 and rc2)

    Windows requires:
    • Microsoft Visual C++ 2010 Redistributable (x32, x64)
    • TeamSpeak 3 RC1 or RC2-pre1
    Last edited by florian_fr40; March 29th, 2012 at 09:03 AM.

  15. #45
    Join Date
    January 2010
    Location
    New England USA / Marnbach, Weilheim i.OB, Germany
    Posts
    425
    Thanks for the update!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3MassMover - TS3 Client Plugin to move clients
    By Mr. S in forum Client Plugins / Lua Scripts
    Replies: 15
    Last Post: August 4th, 2018, 10:54 AM
  2. [Outdated] WalkieTalkie TS3 plugin (addon)
    By cracker in forum Client Plugins / Lua Scripts
    Replies: 130
    Last Post: February 9th, 2016, 01:04 AM
  3. [Request] Move clients, move has to be accepted
    By steaked in forum Tools / Web Based
    Replies: 1
    Last Post: February 8th, 2016, 10:24 AM
  4. [Outdated] TS3 GroupChat Plugin
    By SilentStorm in forum Client Plugins / Lua Scripts
    Replies: 36
    Last Post: October 15th, 2014, 01:04 AM
  5. Replies: 3
    Last Post: July 14th, 2010, 09:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •