Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    July 2010

    Solved [solved] Ts3 Server Setup ubuntu 10.4 five hours setup no luck :(

    Hello, everyone
    So I am stress out like crazy I have put maybe 10 hours into getting this server setup running and be able to connect to the server from external ip. So now i am going to try to setup the server again and post everything I am doing. Please correct me if I do something wrong I am not the most l33t linux users just started to get use to the love hate relationship linux has to offer.

    Network system information
    ubuntu 10.4 os desktop
    system hardware
    Pentium D 3.2
    2 gig of ram 667

    ISP = Comcast dynamic ip address
    Monowall firewall/dhcp
    Firewall Nat Inbound allow
    If Proto Ext. port range NAT IP Int. port range
    WAN TCP 10011 webserver 10011
    WAN TCP 30033 webserver 30033
    WAN UDP 9987 webserver 9987
    firewall Rules * = any
    Proto Source Port Destination Port
    UDP * * webserver 9987
    TCP * * webserver 10011
    TCP * * webserver 30033

    So lets begin

    I went to teamspeak and downloaded the teamspeak3-server_linux-x86-3.0.0-beta25.tar.gz

    I then open up terminal and type

    cd Desktop

    sudo tar xvf teamspeak3-server_linux-x86-3.0.0-beta25.tar.gz

    This extract the files to the Desktop I then moved the files to another location

    sudo mv teamspeak3-server_linux-x86 /opt/ts

    This moved files to /opt/ts/ folder, I then
    cd /opt/ts3
    This brings me to the file where I moved the tarball
    I then try to start the server
    sudo ./ createinifile=1
    The server starts up and displays the tokens for admin and I copy the information to notepad for later use to gain access to admin rights in ts.

    I then ctrl+c to stop the server from running
    I then sudo gedit ts3server.ini to open and view the ts3server.ini file

    Here is the ts3server.ini info

    So now I have have the ts3server.ini files so I will restart the server using this file

    sudo ./ start inifile=ts3server.ini

    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file

    Now I go to another computer on the network and try to connect using the ipaddress of the linux box as the connection ip, the port 9987 and try to connect. I get connected and well that should be all good I guess, So now I try to connect to the box with my externail IP address and fail to connect. at this point I don't want to go any further and try to setup another users to have the server autostart because if I can't get this up and running and able to access this from the wan.

  2. #2
    Join Date
    May 2010

    You can't connect on your server from your internal network when you use the external IP. This the security system of all router

  3. #3
    Join Date
    July 2010


    OK it works now wtf

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Ubuntu 14.04, Maria 5.5.4 Setup Help
    By Napoleon_BlownApart in forum Linux / FreeBSD
    Replies: 10
    Last Post: January 20th, 2015, 02:49 PM
  2. [solved] TS3 Setup Mac OS X Server 10.6.x
    By tmm4264 in forum macOS
    Replies: 10
    Last Post: June 17th, 2010, 04:26 AM
  3. [Solved] One time token setup
    By CappinHoff in forum Permission System
    Replies: 8
    Last Post: May 28th, 2010, 02:36 PM
  4. [Solved] MySQL Setup Problems
    By LordNova2 in forum Server Support
    Replies: 8
    Last Post: January 14th, 2010, 02:21 AM
  5. [Solved] Unregistered Non-Profit server setup.
    By TheHatmaker in forum General Questions
    Replies: 4
    Last Post: January 11th, 2010, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts